How-to Thread For ADB SHELL


Is the Thread Helpful enough to sticky it?

  1. Yes

    48 vote(s)
    96.0%
  2. No

    2 vote(s)
    4.0%
Last Updated: 2010-09-08 09:00:14
  1. BH_MAN

    BH_MAN Well-Known Member

    Due to the Over whelming Question Regarding how-to do things in Android system regarding ADB, I've Decided to make a thread regarding this Issue..

    If you Have to ask a Question, be very clear so we can Keep this thread Clean.. Wiki Located here > ADB - Android Wiki

    To Fix ADB in Linux, Visit this Thread > http://androidforums.com/all-things-root-behold-2/60949-adb-linux-replacement-fix-file.html

    To start us Off.....

    If you would Like to Pull a File / App. First we would do this....

    Now we should have a Huge amount of App's in front of us, now we locate the name of the App we wish to pull Once we Find it, we do the Following.. ( In this example I'll be Pulling the alarmclock.apk )

    Next, If still in Command Prompt.
    running exit will drop you back into Command prompt shell, From there we Running the Following Commands in Blue...
    adb pull /system/app/AlarmClock.apk C:\AlarmClock.apk

    Now we should have the alram clock app in our Root Directory in C:\

    Now to Push the alarm clock app after we made changes to it...

    adb push C:\AlarmClock.apk /system/app/AlarmClock.apk


    Now we have Pull & Push a File into the system/app Directory.

    Now.... Lets say we want to remove an App from the /system/app Directory ( Be careful when doing this, Can cause phone Not to Boot... )

    In this example I'll be Removing the AlarmClock.apk from adb shell..
    Now, if the System uses .odex file, do the same regarding those file's as well.... The Command would look like this for .odex removal...
    More Example..

    Through ADB
    A2SD Commands
    If using any A2SD you would run these Commands as well to locate, Remove, Pull or Push.

    Pull apps off phone onto computer
    Push apps back to phone from the computer
    Delete existing apps on SD
    Please Post your How-to,

    Thanks,
    ~BH_MAN



    Thanks Paul :D
    HAHA LMAO we posted the same video, I'll delete mine!

    Advertisement
    ERJ, crump, bearsfan85 and 3 others like this.
  2. i2hi4u

    i2hi4u Well-Known Member

    I have tryed to get this going for a few days now with no luck. I have tryed different drivers all ran with signed drivers disabled. I've tryed a few cables and 3 different machines. Everytime i type in adb shell it says device is offline. I type in adb devices and it shows t939 device offline. I have usb debugging on and it set to samsung pc studio mode. i want bhmans rom badly... im not even gonna get this fabled update anyways. any help would be very much appreciated.

    P.S. i use win7 64bit ultimate, My other 2 machines are running winxp pro and win 2000.
  3. i found it much easier to use windows xp. so you do have the avd installed correct? i was having problems for a while too then i finally got it. also make sure ur device isnt in usb mass storage mode so when you plug in via usb dont mount. hope this helps if not let me know
  4. i2hi4u

    i2hi4u Well-Known Member

    what does avd have to do with it?? My phone is in samsung pc studio mode and i never mount it.
  5. avd is the android virtual device and you must have it set up in the sdk before adb runs. do u need me to help wit this?
  6. i2hi4u

    i2hi4u Well-Known Member

    Ive setup a few avd but it didnt change anything. Now adb devices shows the emulater
  7. ok. what computer are u currently using to run these commands?
  8. i2hi4u

    i2hi4u Well-Known Member

    I already told u i am using all 3
  9. kam187

    kam187 Well-Known Member

    In device manager do you see a adb device? Did it ask you for a driver when you turned on USB debugging?

    Try toggling usb debugging (its a known problem - not calling u dumb :) )
  10. kam187

    kam187 Well-Known Member

    You need to download the sdk or the tools.rar. Extract it and cd to the tools directory. Then run adb.

    Here's the tools directory you need including abd and the driver (windows should ask you for it when you turn on usb debugging and turn off mass storage mode)

    http://www.megaupload.com/?d=48D1QMWX
  11. phillynitro

    phillynitro Active Member

    How do you do it and what is needed I can not get my device to show up when I type adb shell. I download the android files from google but im stuck this is a big jump from my windows mobile world.
    Would love some help people thanks to all.
  12. Mastermind278

    Mastermind278 Well-Known Member

    Assuming you are running Windows...

    You must download the Android-SDK (Android SDK | Android Developers) Extract to the C:\.

    Then you must install the drivers for the Behold 2. Drivers can be found in the following file http://shrunk.me/uvij6.zip
    That file also include the ODIN files which allow you to flash back to completely stock (out of factory) for your phone. For ODIN instructions please reference this post: http://androidforums.com/377007-post8.html

    Now when you plug-in the phone via the USB, it will ask to install drivers and point them to the Behold 2 drivers.

    Assuming that you are running the stock Touchwiz you must put your phone into a mode that adb will work. On Touchwiz you go to Settings>>Application Settings>>Development>>USB Debugging (put a check mark). Then go to Settings>>Phone Settings>>USB Settings>>Samsung PC Studio, click SAVE. It should then install the ADB drivers. If not toggle between Mass Storage, click Save then click Samsung PC Studio and click save.

    Open a command prompt windows (Start>>Run>>CMD) then
    Code (Text):
    1. cd c:\android-sdk-windows\tools
    2. adb shell
    This will get you the adb shell onto the device, allowing you to enter the commands to install the MOD.

    Make sure to extract the files from BH_Man onto the root of your SDCARD and make sure its then mounted on the phone. Good Luck.
    ltlrags likes this.
  13. kkarlin

    kkarlin Well-Known Member

    One other thing I have noticed is that if you have an alternate Home - ie @Home, Home++, SweeterHome, etc you will not be able to get ADB to work until you are using the stock TW home.
  14. i2hi4u

    i2hi4u Well-Known Member

    I see it in device manager. I have not seen anything about usb debugging. I toggled it in the phone and nothing showed up...
  15. BH_MAN

    BH_MAN Well-Known Member

    Hit Menu on the Phone ( Not settings in the Launcher ).

    Menu > Settings > Applications > Development > USB debugging

    After a Phone reboot, be sure to toggle off, then back on.

    If you're running a Full stock Rom....
    Pull down the Menu bar ( Notification bar )... and

    Notification Bar > Phone Tab > USB settings > Samsung PC Studio
    ( Then follow the USB Debugging how-to ).
  16. BH_MAN

    BH_MAN Well-Known Member

    After SDK is setup & Driver's are installed...

  17. i2hi4u

    i2hi4u Well-Known Member

    Tryed that and its still says device offline.. Such is life..... its okay guys im not made to get anything
  18. meinstein1987

    meinstein1987 New Member

    ok so its probably been posted many many times and i know this because i have read 2 post on here and many other post from different web sites and i have read and tried so many times im fed up and really want this to work.

    I have done everything to a T to try and get this working with a no working status happing.

    SO IF THERE IS ANY ONE OUT THERE HAVING THIS SAME PROBLEM AND FIXED IT please please email me or post reply.

    i have tried uninstalling drivers reinstalling. i have reset phone. i have done every thing possible in my right mind from reading to try and get it recognized by adb but still cannot
  19. kkarlin

    kkarlin Well-Known Member

    Are you using a third party home screen? I have found that if you're using @home and SweeterHome you can not initiate an ADB connection.

    Can you mount the phone as a removable drive?

    What OS are you using (version and 32bit or 64bit)
  20. meinstein1987

    meinstein1987 New Member

    Do not have any of those things like I said I did a factory reset on it just to make sure. Yes I can mount as removable drive. I'm also using windows xp 32bit.

    I mean I just don't freakin understand why its not working.

    I sat there for 4 hours yesterday trying to get recognized by adb....

    I am savy with these things computers phones blah but I just can't figure this one out
  21. BigBalmer

    BigBalmer Member

    I am no tech guy thats for sure, but when you plug your phone to your cpu dont mount it set the phone settings to studio then start up cmd and make sure you got debugging on that did it for me. Since I got this thing rooted it has been great, so push on man it is really worth it
  22. meinstein1987

    meinstein1987 New Member

    I donot mount the question asked before was does it mount as in are the usb drivers working.. I said yes. And i know its worth it just cant get the behold to be recognized which is making me mad.

    I have downloaded the manual drivers still nothing. is there any information for any of the tech guys here that they need to see what the problem is.. DXdiag? phone version firmware version so on?
  23. dan0zone

    dan0zone Well-Known Member

    did you un_check mass storage , when you go to >about phone>additional settings ? that's the only other one there is , you can also press n hold the call button and say phone 'status' to get this menu . ...
  24. meinstein1987

    meinstein1987 New Member

    found the setting but now when i usb it only charges no connection ill try uninstalling drivers then reinstalling but well see
  25. WurrzMiKey

    WurrzMiKey Active Member

    if i'm reading correctly, my phone did the same thing (just charges and doesn't connect). Then i went into the notification bar (while plugged in), went into phone and USB settings. It was already set to PC Studio so i just pressed save and it reset the usb connection and adb recognized it.

Share This Page