How to unbrick A75 if bricked using recovery.

Last Updated:

  1. pkotenetwork

    pkotenetwork Well-Known Member

    ************ I Have unbricked my A75 that also without any service center support ************

    If u want to unbrick ur also please follow the procedure..

    1) We know that SPflashtool is detecting the USB but not Downloading (Flshing) anything then i Clicked to Format + Downloading as soon as we click it wont show the timer but get started as u push ur usb in the computer port..
    before please surely insert the scatter file...:D

    No matter which rom u select i Used Micromax a75 New version with root 4 rom (Rooting is Necessary for Further steps please use ninands ub-1 its really fast..:p)

    2) After Sucessful Completion of flashing it will show battery icon charging due to usb pluged in the computer port..

    3) Now u'll face the trouble as u format ur Phone ur NVram gets cleaned hence ur phone will be without any IMEI no...:(
    It always show Invalid IMEI at the top of Status bar.:(.

    (Dont worry guys :tomato:i found the solution for this problem we have to create a new file regarding IMEI no.. Its very simple but changing IMEI is a offence so please dont change ur IMEI take the IMEI as it was before U'll find ur original after removing ur battery please note it on a paper)

    4) Restore Imei

    You will need to do this if your task/status bar at the top of the phone says INVALID IMEI under the sim status.

    Note: device must be rooted!

    - Each phone needs its own unique file to be created - do not use the MP0B_001_NEW file on any phone except the one it is created for it is illegal.

    i) Extract files within IMEI folder (Download From Link:D) to \Windows\system on your computer

    ii) Open a command prompt
    -Press windows key + R
    -In the run box type in cmd
    -press enter
    -A black window will appear with writing

    -Enter the following text:
    imei.exe <15digit_IMEI_1> <15digit_IMEI_2>

    (eg: imei.exe 123456789111111 123456789111111)

    Press Enter

    - If both IMEI you gave are in correct format the file named MP0B_001_NEW will
    be created. Now you can put it on the sd and insert that in to the phone.

    3) Run root explorer and Copy the file
    copy it to: /data/nvram/md/NVRAM/NVD_IMEI/MP0B_001 (or similar)
    (system need r/w need to be on)


    1) Website from where i got IMEI restore information :

    2) file from XDA developers :

  2. varun.chitre15

    varun.chitre15 Well-Known Member Developer

    Superb work :) :)
    I have moved your post and made a thread of it :)
    bgvivek and pkotenetwork like this.
  3. kumar abhishek

    kumar abhishek Well-Known Member

    Wow!! We can resume our development now which had stopped for a while :) :)
  4. saivignesh

    saivignesh Well-Known Member

    superb work but I already have imei writer
    ninadchaudhari likes this.
  5. shreymehrotra

    shreymehrotra Active Member


    I tried the above method and left the phone for around 1/2 hr but nothing happened :mad:
    Thought that it will solve my problem but couldn't get through..
    now only option seems to be service center :eek::eek:

    BTW nice effort.. Hope it works for others :):rolleyes:
  6. shreymehrotra

    shreymehrotra Active Member

    Tried it again but now getting error


    [COM] Failed to open COM 17

    After clicking OK return back to SP tool :(
  7. rudrateja

    rudrateja Well-Known Member

    Here is the solution from Russian Forum (Translated using google translate and copy pasted)

    The semi-brick state for MT65x3:
    a) Phone does not turn on.
    b) Display when connecting is not charging the battery indicator shows.
    c) After the distortion of the battery and connect the phone to the cable-house computer's USB (better check for 2, 3), the computer detects the new device "USB \ Vid_0e8d & Pid_0003".
    That's only in this case, all the hardware health of the phone can be diagnosed non-functional preloader!!!

    How to recover your phone:
    The battery must be charged, the more the better. If in doubt, we charge the battery (rent, buy).
    Downloading firmware for FlashTool for your phone model. If there is no firmware, please make a co-owner of the dump ROM .
    If you are the sole owner of a unique device, the firmware, or ask the seller, or in extreme cases, order two and remove the dump. I do not ask dumps, firmware, and I have no dumps. What have been published on the forum.
    Take a preloader and dsp_bl from the archive as an attachment (While in theory there are two varieties for RAM = 256 and RAM = 512. Not interchangeable. Received confirmation for the A7272 +, Lenovo A60, "AT & T HD7s + T9299").

    If you do Backup-Format-Down ... in FlashTool, then take the file BinRegion.img (where to find the file is written just above the quote) and rename it to nvram.img.
    If you've been doing experiments to dump the ROM , then you already nvram.img be.
    nvram.img put in the root of the archive and an archive copy to the root of the SD-card.
    Downloading a modified recovery for your phone. If not, then please do.
    Look for at least 3 times instructions for the firmware on the sim . msxml framework.Net and looking to the Internet.
    In paragraph 2 of the firmware), replace PRELOADER, DSP_BL and RECOVERY from paragraph 3) and 6). In addition, tick LOGO, UBOOT, BOOT. Only this time include "Backup-Format-Download ...". Stitches FlashTool-st.
    Downloading any firmware as an for your phone.
    Go to the recovery.
    From the recovery firmware consistently stitches as and
    From the recovery do Wipe -> Wipe ALL data / factory reset.
    Load the machine and enjoy life.

    If the machine still stubbornly refuses to load it:
    Do not forget that the battery needs to be well charged. And while the firmware is not strange as it is discharged, even though the USB cable is connected to the phone!
    Try to remove the SD-card and the SIM-card.
    Try to Wipe out of recovery (if the phone can enter into it of course).
    Repeat steps 8-12.
    Try to ask for a dump from another person and another and another ... (Replacing the preloader and dsp_bl of investments and choosing sec_ro) Sometimes, even the same manufacturer for hardware changes (LCDs, sensors, motherboard entirely), the counting ROM. And the firmware on older hardware versions may not be suitable for a new one. The search will help you:
    Stickers under the battery (the color content), the location of SIM and SD.
    If you remember, the information that was in the "About phone" -> "Build Number".

    Link : Google Translate
    bgvivek likes this.
  8. shahabazas

    shahabazas ~*~ Android Addict ~*~

    I tried your method to unbrick my phone but i also got the error


    [COM] Failed to open COM 1

    i wanna know if i take it to the micromax service center as i have 9 months warranty left do they will help me and unbrick my phone or they will come to know that i have tried to root my phone and they will refuse to help.
  9. pkotenetwork

    pkotenetwork Well-Known Member

    I have seen the photos in facebook but I come to know that u have not clicked on format+download tab please first select to that tab then try..
    I am definitely sure it works..

    otherwise my phone would never works..
    even I am replying from my micromax a75.

    dont worry guys I am going to flash jetMod 3.0 again if I again bricked my phone i'll make a video of it how I unbricked my phone.

    if jetmod 3 installed sucessfully then u'll get a video of how to flash the jetmod..

    video will help to all of us. .

    thank u all guys..

    all this will happen after 3 june (uptil my papers will over)

    so sorry before this its not possible.

    But after that incident now I am damm sure Media Tech devices are impossible to kill..
    (I go with ninand choudhary) and its true...!!
    bgvivek likes this.
  10. pkotenetwork

    pkotenetwork Well-Known Member

    thank you varun..

    I am coming with videos..

    1) How to unbrick your A75 (bricked after flashing recovery)

    2) How to flash JetMOD 3.0 sucessfully on your A75...

    (I want that JETMOD 3.0 on my
    varun.chitre15 likes this.
  11. Amarghy

    Amarghy Well-Known Member

    @pkotenetwork I just got my phone back from the svc....but the imei no. cudnt be installed by them. I wanted to do it myself. Now the file cannot be downloaded!! error-file is gone. What to do? plz provide the link. Thanx
  12. Amarghy

    Amarghy Well-Known Member

    Lol...i surfed around got the file...did the thing! now i have a imei no, but the sim cant connect! i mean, it can be only detected :p guess, its back to the svc for me :p
  13. pkotenetwork

    pkotenetwork Well-Known Member

    Please go to website of xda developers I have given the links in above threat please u have to do it..
    its not difficult..

    if not possible for u please u send me ur imei no..
    i'll generate that file then u have to replace the original with this one using root explorer..

    (this is only if ur status displaying invalid imei)....
  14. Amarghy

    Amarghy Well-Known Member

    I had already fixed the imei problem :p now, the problem is, my phone cant connect to the network using my idea-sim no matter which slot i put it in. But it works for the reliance sim! :( i tried the idea-sim in other phoneS, and its working great btw :(
  15. Amarghy

    Amarghy Well-Known Member

    Wow. Its seems using imei.exe program from startools wont help you in getting a fixed network even though you may get the proper imei installed in nvram directory. Today at the mmx svc, they used the SN WRITE STATION TOOL to install my imei. This tool is strictly for mtk cpu's!! google inorder to download it. It has many functions other to the imei installation part.
    cell0ne and pkotenetwork like this.
  16. ninadchaudhari

    ninadchaudhari What's up !

    Cool!! If sn tool works with A75
  17. Amarghy

    Amarghy Well-Known Member

    Yup yup. I guess thats why many of the guys who tried by imei.exe method, cudnt make there phones to work by simply replacing the file in nvram folder. A proper tool for a75.
  18. Elavarasan

    Elavarasan Member


    I have installed your custom rom everything is working but, it shows Invalid IMEI and Sim card are not detecting, no network, kindly help..

    Thanks in Advance
  19. Amarghy

    Amarghy Well-Known Member

    Hi. I too bricked my phone earlier while using the recover.


    The procedure for me worked after like the 20th time of fiddling around. I am sure you can do it too buddy. :p

    But the only problem that remained was that IMEI no. didn't get installed/worked by that method. I tried too methods for the IMEI installation. Am giving the link:

    IMEI,write IMEI ,lost IMEI ,fastcardtech ,Android phone.
    Should work. If not, try step 2 :)

    You can find the download link here after a free
    MTK 6516 Flash Tool-IMEI Tool-Video Help

    The 2nd step was the one which actually worked for me. But feel free to ask, if it didn't work for you.

    P.S- By any chance, where you using MTK CPU TEST app from market?? :(

    Also the 2nd step needs to be done with a fresh system. So if you are gonna try pkotenetwork's method of imei replacement, please make a backup of the original file in the nvram directory. Copy it back into the original folder if replacing the file by pkotenetwork's method didn't work, before trying with the tools provided in my post. :)

    It helped me. Hope it helps you too. Good luck :D

    once its all over, backup the imei file to your computer for safekeeping :p
  20. Elavarasan

    Elavarasan Member


    I tried to install custom ROM for my Micromax dual sim Android MT6516 mobile, i installed properly, my phone is rooted and i have super user permissions. but now it shows Invalid IMEI and Sim card are not detecting, no network. Then i tried to use IMEI Writer, As soon as i connect my mobile to laptop, Pre Loader USB VCOM port5 is appearing in device manager and then vanishing. So, i couldn't connect to any COM port and write IMEI number. Kindly help me out of this.
  21. pkotenetwork

    pkotenetwork Well-Known Member

    Try IMEI.exe method as u already have the rooted rom u'll not require anything more..:D

    Generate a New IMEI file with your imei nos and replace it with the existing one..;)

    For Details see the original Post or First Post of this tread..;)

    Hope U'll able to fix ur Invalid IMEI..:p

    Incase having any problem with generating IMEI new file send your IMEI 1 and IMEI 2 nos to me i'll generate the file and give it to you so that u'll replace it with existing on using root explorer..:cool:
  22. Amarghy

    Amarghy Well-Known Member

  23. avinashmeena

    avinashmeena Well-Known Member

    My phone bricked by using mmx cwm recovery on gionee rom with gionee scatter file
  24. avinashmeena

    avinashmeena Well-Known Member

    I have got in very long time about 35 days

Share This Page