How to unbrick/flash your Optimus ME/LG P350


  1. Laudano

    Laudano Member

    I'm not sure if it's an all things root or a normal post, but I'm posting it here, anyway.

    Yesterday I made what every nOOb, like me, fears the most. Messing with the ROM Manager app, I made some mistake (not sure what it was, as I followed the instructions to the letter) and bricked my phone. It was stuck on the fastboot screen and responded to nothing.

    So I ransacked the Interwebz searching for the information I needed for a solution, which was scattered in a dozen different sites and forums and I'll try to gather it all here for future reference.

    Which is:

    1 - If you bricked your phone with ROM MANAGER (stuck in Fastboot mode screen), or any other root app, download the KDZ_FW_UPD.RAR LG flash utility to your Windows, the V10C_00.KDZ (latest LG P-350 firmware), and LG_United_Mobile_Driver. Turn off the handset and take off the SD Card.

    2 - Install the United Mobile driver from LG on Windows, then go to control panel and disable the modem driver. If you don't disable the LG modem driver, the damn thing will not work.

    3 - Unpack the KDZ_FW_UPD.RAR to a new directory and install, first of all, the msxml.msi program.

    4 - Make sure your battery have 100% load. If it doesn't, wait at least 2 hours before trying the following step and let the battery charge (keep it charging).

    5 - Take off the battery and the USB charger from the phone.

    6 - Plug the USB charger and keep pressing the PLUS AND MINUS VOLUME buttons. Making this will start the phone in a cheesy yellow screen with an "Emergency Mode!!" warning. Put the 100% loaded battery back on the phone.

    7 - Start the KDZ_FW_UPD.exe program on the PC.

    8 - Once KDZ_FW_UPD.EXE is running, chose the Type 3GQCT and PhoneMode Emergency on the respective drop down menus.

    9 - Chose the V10C_00.KDZ firmware image on the KDZ file option.

    10 - Click on the Launch Software Update button, hope for the best and go grab a cup of coffee or tea.

    11 - Fifteen to twenty minutes later, if the above procedure worked, an animation asking you to close the phone will appear: Your phone is saved. But don't close the phone yet.

    12 - Start the phone again. If you get stuck in a screen with an Android and an exclamation mark ("!") in a triangle, just unplug the USB cable and the battery. Plug the battery again and start the phone. It will take 2 to 5 minutes to reboot for the first time and the boot animation will be the stock LG (your carrier's stock animation is lost for good), but chances are your phone is intact, with all it's apps and configurations working the same as before the incident. When the boot finishes, turn off the phone again and put back the SD Card you took off on the first step.

    13 - Erase ROM MANAGER from your P350. :)

    There is probably a 100 easier ways to make this, but that's the only way it worked for my phone - and I tried hundreds of other things. As soon as I can post links on the forum, I'll put the links to this utilities and the firmware on this same thread.

    Cheers to all,

    Rico Ferrari

    EDIT: There are some slight differences between my original firmware and this (newer) one. There is a couple of new system apps from LG and the phone looks like a bit faster compared with the original firmware. And I forgot to mention that the root privileges go away, but it's possible to reroot the P350 again using gingerbreak.

    Advertisement
  2. adclix

    adclix New Member

    Thanks Dear you save my phone
  3. alinblue

    alinblue New Member

    Hei man, I need help please.I followed all the steps and when I enter in the lg united mobile and do what you said, after saying : unpack kdz . it says that there was no phone found.What should i do ???Please helpp meee
  4. Greek13

    Greek13 New Member

    I did everything you said but it shows an error!

    "Upgrade ERROR
    WParam: 100
    LParam: 2"

    Please help me!
  5. Nergalr

    Nergalr New Member

    I have the same problem , yesterday i saw a root apps int he torrent apps collection and rooted my device then it was all ok for more than 2 hrs but when i changed the fonts through fonts changer it requested reboot after that it just gone showing lg and black i was thinking to show it to a customer care but from these post i'll try it today.
  6. markie03

    markie03 New Member

    im new here why i cant see the download link of the files?
  7. jacksorter

    jacksorter New Member

    Thank you very much. my phone's back to its original state. :thumb:
  8. theo99ano

    theo99ano New Member

    my lgp350 before i do all this things you said it says "Fastboot mode started" and when i connect the usb cable it says "fastboot:processing commands". WHAT MUST I DO???? plsssssss answer as soon as you can
  9. Jackobob

    Jackobob New Member

    Same here PLEASE HELP ME OUT!!

    Thanks,
    jack
  10. kaleija

    kaleija New Member

    You have saved my life... TWICE !!!!!!!!!!!!!
  11. MrMarinac

    MrMarinac New Member

    At step 12 my phone starts booting up and after 2 hours it's still at the android logo...
  12. Ciulei George

    Ciulei George New Member

    cum dezactivez draiveru de modem?
    ,pe windows xp

Share This Page