Support how to uninstall android sdk from PC?

Discussion in 'Android Devices' started by chinkster, Jun 24, 2010.

  1. chinkster

    chinkster Well-Known Member
    38

    Feb 7, 2010
    316
    11
    38
    SF
    i was attempting to install the android sdk to my PC so i can push a file to my phone. i downloaded the android sdk from the website and unzipped it to my desktop. i ran the .exe setup from my desktop but i read somewhere that the folder was suppose to be put in the C: directory so i panic and cancelled the installation process so now i think it partially installed. i went to my control panel and tried to uninstall but i didn't see any android or sdk program installed. anywhere know where else to look?
     

    Advertisement
  2. mcapozzi

    mcapozzi Well-Known Member
    43

    Mar 17, 2010
    323
    35
    43
    Computer SuperGenius aka Systems Administrator
    Liverpool, NY
    The SDK Setup.exe file is not an installer but more of a configuration tool.

    The Android SDK does not have a real installer, just place it where you want to run it from.

    To uninstall it, all you have to do is delete it.

    -Mike
     
    chinkster likes this.
  3. chinkster

    chinkster Well-Known Member
    38

    Feb 7, 2010
    316
    11
    38
    SF
    cool thanks
     
  4. paul@kinzelman

    5

    Jan 17, 2011
    5
    0
    5
    To follow up, I'm on a Vista machine, and when I try to delete the folder, it takes a long time, and then due to UAC, a window pops up that says access denied, I need to confirm the operation. I confirm, then after a little while, it says access denied again, but this time there's no confirm button, only 'try again'. Again after awhile of not recycling any more items, it says access denied, try again - again. It seems to do that forever until I cancel, then it turns out it deleted nothing. How do get it deleted?
     
  5. DonB

    DonB ♡ Spidey Sense !! ♡ ™
    Moderator
    6,323

    Nov 30, 2009
    19,290
    7,916
    6,323
    Male
    18th Hole Of the Golf Course
    Make sure you are signed in as Administrator ;)


     
  6. paul@kinzelman

    5

    Jan 17, 2011
    5
    0
    5
    I'm already an administrator on the machine, which is why I can allow UAC access by programs.

    Are you saying I have to be logged in *as the Administrator* user? Why wouldn't having admin privs be sufficient?

    Thanks!
     
  7. paul@kinzelman

    5

    Jan 17, 2011
    5
    0
    5
    Hello? Anybody know the answer as to why I can't delete the tool tree even though I have admin privs?
    TIA!
     
  8. JB in AZ

    JB in AZ VIP Member
    VIP Member
    173

    Oct 27, 2009
    1,869
    267
    173
    Florida
    You might try logging into Windows in "safe mode"...then try to delete the files/folders in question.
     
  9. paul@kinzelman

    5

    Jan 17, 2011
    5
    0
    5
    I was able to delete it by logging in *as* administrator, but a login with admin privs can't delete the area. I didn't need safe mode, I had already enabled the administrator login normally so it's available from the normal login screen.

    BTW, anybody know what causes a file to require being logged in as administrator to manipulate it?
     
  10. afmob

    afmob New Member
    5

    May 13, 2010
    3
    0
    5
    disable ALL of your antivirus software then try again as the administrator.
     
  11. markland

    markland New Member
    5

    May 22, 2013
    1
    0
    5
    Thanks for thread, all good stuff! I'm using XP and if you need to subsequently re-install I have found that you also have to delete the '.android' and 'workspace' files in C:\Docs and Settings\Administrator for it not to call for password entry when unzipping a new ADT file. Also any error dialogs about 'File in Use', when they are not, can be avoided by restarting the machine and trying again.
     
Tags:

Share This Page

Loading...