HOW TO: Update SoftwareSupport


Last Updated: 2012-06-17 09:31:53
  1. sakebu

    sakebu Member

    I'm making this guide because it took a while for me to find how to update my phone.

    Go to this website. LG LGMS840 Support: Find Manuals & Warranty Info | LG USA

    Scroll down and under Manuals & Download click on the Software Update Tab.

    Download and Install the USB DRIVER and LG MOBILE SUPPORT TOOL.

    (Your install should go under "LG MOBILE SUPPORT TOOL". If you want to run the updater, run "LG MOBILE SUPPORT TOOL" NOT "LG MOBILE Software Updating Agent Program" )

    LG MOBILE SUPPORT TOOL without the phone plugged in:
    [​IMG]

    To make sure you have all of the USB DRIVERS installed, click on "Install USB Driver" Select MetroPCS as the Carrier. And DOUBLE CLICK on LGMS840.

    Once that downloads and installs, plug your phone in.

    MAKE SURE YOUR PHONE IS IN MASS STORAGE or INTERNET CONNECTION MODE. CHARGE ONLY MODE WILL NOT WORK. (If your phone is in charge only mode, slide the top bar and press USB connected. Then press Internet Connection and Done on the bottom.)

    When you plug your phone in, the drivers should start installing. You can check on the status by opening the Driver Software Installation in the task bar. It should look like this:
    [​IMG]

    The LG MOBILE Support Tool should now look like this:
    [​IMG]

    Since my phone is up to date, there is no need for an Update. If your phones needs it though, click on Start Updating. Follow the on screen instructions to complete the update.

    You need 50%+ battery in order to start the update. If you don't have enough, you'll need to charge your phone.

    NOTE: Software updates take off ROOT and can reinstall bloatware.

    Hope this helped!



    Advertisement
    zandersig likes this.
  2. akikhia

    akikhia Well-Known Member

    ya kinda useless guide for the majority of people with the newer connects unfortunately. make sure u explain that only the old connects can be updated with that tool
  3. myshkin

    myshkin Well-Known Member

    So, I just got my Connect yesterday & I just got a message that there was a software update for my phone. I clicked yes to install. I'm not sure what changes were made as I had not learned all about my phone yet. In the future, after I root, if I get one of those messages, if I click yes to install, it will take me back to stock?
  4. akikhia

    akikhia Well-Known Member

    it wont update if ur rooted i believe
  5. droidinmiami

    droidinmiami Well-Known Member

    Could you be a little bit more specific?

    I got the Connect 4G a few weeks back and tried the update tool which failed miserably as I cannot get all USB drivers properly installed for some screwed up reason (tried it on two different computers - same results).

    How are the "newer" phones updated then?

    Could you kindly elaborate?

    Thanks in advance.
  6. akikhia

    akikhia Well-Known Member

    idk what ur problem is. the new ones wont update for some reason they are recognized just say theyre up to date no matter what
  7. droidinmiami

    droidinmiami Well-Known Member

    Oh I see - thanks for clarifying.

    I don't know either why my USB drivers aren't working. I keep my systems clean and smooth running. I'm not installing lots of software etc. either.

    Just a bummer that I couldn't get it to recognize the phone.

    So far no problem though, everything is working fine :)
  8. ajfoucault

    ajfoucault Member

    Thanks for the guide! =)
  9. danielary29

    danielary29 Well-Known Member

    im having the same problems updating my phone bought it back in march have all the drivers installed every time i connect to phone i have to be in restart mode for the tool to connect then it just says i have the latest version and im still on stock MS840ZV8 i have also tried in internet mode and my phone does connect with out restart but same thing still cant find any updates for my phone even have tried a complete reset on my phone nothing
  10. flyballa

    flyballa Member

    ^^ mee too
  11. myshkin

    myshkin Well-Known Member

    Ok when I bought my phone on Sat the box says it's the ZV8. I guess that update message I got over the phone was to update to the ZVA because that is what I have now. I guess I need to get a better battery because this one gets hot! I can feel the heat coming off the back especially when charging & I always take my accessory cover off when charging.
    Anna
  12. THE W

    THE W Well-Known Member

    If you're on zv8 you should keep it. The only difference you'll have with the update is the inability to tether.
  13. myshkin

    myshkin Well-Known Member

    Wait, you are saying with the ZVA you can't tether? Why couldn't you? Anyone can tether easily if they are rooted. If not, there is pdaNet & opengarden via USB.
  14. sakebu

    sakebu Member

    ZVA has decreased my battery's operating temperature from 40
  15. brian1984

    brian1984 Well-Known Member

    The battery temperature difference was huge in my phone using zva!!!
    10
  16. brian1984

    brian1984 Well-Known Member

    can you tether on zva without root???
  17. myshkin

    myshkin Well-Known Member

    If you are able to download the drivers. I was working on a friend's computer, cleaning it up & I'm sure it's full of viruses (porn watcher). His Nortons expired & he kept watching his porn. I was just going to download Microsoft Security Essentials. We don't have internet here, no one wants to pay for it. When I replace my laptop screen I will get my own. Anyway, his laptop has Vista & without internet service it couldn't find my drivers. Now had I been online perhaps it could. Perhaps windows 7 automatically can without being online. I don't know. As long as you can install the drivers there shouldn't be any reason you can't tether unrooted. Try opengarden first. There are serval USB non tether . One click tether also. In case you didn't already know this, you will need use Firefox. Install the addon superuser agent. Then once you are connected, go to tools some people change to Android but that doesn't work for me. I have to go to robots & then I normally choose google.bot this is the only way I've been able to get past the metros TOS block. Firefox isn't my favorite browser, but it works. That was on my Admire, which was pointless because it was so slow & my asshat roommate has the Esteem & we use that. But, back to the original question, as long as you can get the drivers, then you can
  18. elbayames

    elbayames Well-Known Member

    My mother bought her connect two weeks ago how do you find out if you have old or new connect?
  19. THE W

    THE W Well-Known Member

    point me in the right direction because im rooted and havent been able to tether since i updated from zv8.
  20. myshkin

    myshkin Well-Known Member

    Do you have the proper drivers installed? You can't tether even via USB? When you turn your tether on is your computer even picking up the signal? Are you using Easy Tether for Root? If so does your speeds even show? Surely, there is someone here that has updated that can weigh in on this topic. Have you tried uninstalling your tether app & reinstalling?
    Anna
  21. THE W

    THE W Well-Known Member

    When I've tried it non usb my computer saw the phone the ad hoc showed up in the network list but when I would connect to it I got no data.

    I haven't tried usb yet. I'll see if that works.
  22. myshkin

    myshkin Well-Known Member

    Have you tried even just using a different tether app? Without having to USB? Oh, um what did I read the other day..... Oh do you have an antivirus running on your phone? If so, try turning that off
  23. THE W

    THE W Well-Known Member

    so have you been able to successfully tether consistently on ZVA?
  24. myshkin

    myshkin Well-Known Member

    Oh, I cracked my laptop screen so don't have wifi at home to get drivers. I just bought this phone (up from the admire =phonegasm) last sat. I don't remember if it was sun or Mon after that, I got a text saying we have software updates for your phone, do you want to install? I clicked yes. I wasn't sure at first if this was the update that was done & then I got my box out & looked. I was doing some clean up work on my friend's laptop & his Norton's had expired. I was just going to USB tether because I haven't had a chance to root. I wasn't able to connect but of course it wouldn't be able to install drivers on his vista OS offline. I think I have to go download them when I ready to root, correct?

    Anna
  25. myshkin

    myshkin Well-Known Member

    Since you have brought up the issue though, I am very curious to know if anyone else has tried to tether? As soon as I can I'm going to go to my friend's house & root & since I have to download drivers I'm going to try & see what happens. I just have to wait for him to have a day off.

Share This Page