How to upgrade/flash the Ainol Novo 7 Venus firmwareTips


Last Updated: 2014-09-14 10:10:13
  1. firtvid20

    firtvid20 Member

    Hi everyone. I have made a video tutorial on upgrading/flashing the Venus firmware. Hopefully this will help those having trouble with upgrading their firmware and they can understand the whole process much easier. I have also written up a guide on another forum which I can't be bothered pasting and formatting it here right now, so I'll link it further down this thread.

    Before you start
    DISCLAIMER: This guide is provided for information purposes. I am not responsible if anything goes wrong in the upgrade process, nor can I guarantee it will work for everyone. Make sure you follow each step correctly and you will be fine.

    Before you follow this guide, it is important to know that YOUR PERSONAL DATA WILL BE WIPED during the upgrade process. Please MAKE A BACKUP before attempting this procedure.

    I have tried this on Windows 8 (32-bit) and it has worked. It should work on Windows 7. I am not sure about Windows XP.

    Make a backup of all your files inside your tablet. The flash/upgrade process will format your tablet, deleting everything.

    Make sure your tablet is charged up fully (above 90%). You do not want your tablet shutting off during the flash/upgrade because it ran out of battery.

    Video tutorial


    Links

    FIRMWARE UPGRADE TOOL (Tablet Product Tool(Developer Edition) 1.02): http://bit.ly/XhA3gf

    LATEST STABLE FIRMWARE Jellybean 4.1.1 (0428): http://bit.ly/18ee5Oz

    OPTIONAL; BETA* FIRMWARE Jellybean 4.2.2 (0407): http://bit.ly/ZMlgWf
    * This is an optional download. This firmware is in BETA which means it is in its testing stages. You can download this firmware instead of the stable one. However expect some bugs, not everything will be perfect in this firmware.

    Link to written guide (includes previous firmwares and mirror links): Guide: Flashing/Upgrading the Ainol Novo 7 Venus firmware - Ainol Novo 7 Venus - ZZKKO Forum - THE Forum for Chinese Brands

    Hope this all helps!

    Advertisement
    mapaks and sdrawkcab25 like this.
  2. ensamb

    ensamb New Member

    Android 4.2.2 is nicer, but the firmware does not work on 1104 Mhz. never exceeds 948 Mhz. My advice is to use Android 4.1.1 firmware using the 28/03/2013
  3. firtvid20

    firtvid20 Member

    New firmware has been released by Actions (manufacturer) for the Venus. See Original Post for link.
  4. garuhhh

    garuhhh Member

    I tried the 0428 firmware, so far so good.

    My device is new, so haven't had a chance to explore a lot. 0428's performance seems a tad better than the original. I can't comment yet on battery life as i installed it only last night.
    One problem I notice: when scrolling on a list, it inadvertently taps an item on the list. I'm not sure whether this is only my device or is it a fault of the OS. I'll still do some testing tonight to verify.

    Anyone have this problem on their venus?
  5. firtvid20

    firtvid20 Member

    Yes. I think it's got to do with the sensitivity on the touchscreen. This has always happened to me since I had the tablet.
  6. emiliopecino

    emiliopecino New Member

    Hi, I from Spain. I have a tablet ainol novo venus with CPU ARM Cortex A7. Do I can update the firmware of your site?. Thank you very much.
  7. firtvid20

    firtvid20 Member

    Yeah you can use the firmware update I have put up on the site. Also I found a newer version so I will update it here once I've tested it out.
  8. ensamb

    ensamb New Member

    Android 4.2.2 is nicer, but the firmware does not work on 1104 Mhz. never exceeds 948 Mhz. My advice is to use Android 4.1.1 firmware using the 28/04/2013
  9. rissa458

    rissa458 New Member

    is the tool work on ainol novo fire?
  10. rui-no-onna

    rui-no-onna Well-Known Member

    Nope. Totally different CPU/chipset. On a side note, CyanogenMod, Paranoid Android and AOKP ROMs are available for the Venus/Myth. I've got a couple of these things so I think I'll try both CM and PA. :D
  11. mapaks

    mapaks New Member

    nice info thanks
  12. George_B

    George_B New Member

    I follow the steps, I connect the tablet to PC, I have the tablet product tool open, I have the 2 buttons pressed at the same time, but after releasing the power button - while keeping the volume + button pressed nothing happens ... the file transfer to the tablet doesnot start. Also I cannot install manually the driver, it says that "the selected .inf file does not support this installation method" ... any advice ?
  13. khankll

    khankll Member

    i installed 4.1.1 from above link and its speed is not going above 948 mhz..
    :p

    previously i had 4.1.1 27 03 (or 27 02 not sure) and it would hit 1100+mhz.

Share This Page