how to use my android tablet to control my macmini


  1. JujuFr

    JujuFr Member

    hi

    i bought a Xperia sony tablet
    i would like to control my macmini with it... (with my wifi)
    how can i do that?

    thanks

    juliette

    Advertisement
  2. Crashdamage

    Crashdamage Well-Known Member

    VNC

    Linux user #266351. Android since v1.0
  3. JujuFr

    JujuFr Member

    Hi

    i tried VNC already :
    i used the standard setup from my mac (server)
    i have installed android VNC, but think i had some issue with the "port" settings...
    (my ip is fine)
    error message : VNC connection failed! failed to connect to localhost/192.168.1.67 (port 5800): connect failed: ECONNREFUSED (Connection refused)
  4. Crashdamage

    Crashdamage Well-Known Member

    Check the port forwarding on your router. Make sure the default VNC port 5900 is available.

    VNC setup is normally very simple. Check the VNC website for help.

    Linux user #266351. Android since v1.0
  5. hstroph

    hstroph Well-Known Member

    Did you verify that VNCserver is running on the mac, and that firewall and router are configured to allow it on the ports it uses?
  6. JujuFr

    JujuFr Member

    how can i check that?
  7. lynnwilliam

    lynnwilliam Well-Known Member

    Gmote 2.0
  8. JujuFr

    JujuFr Member

    Hi

    i think vnc server is running as i can access to the mac mini screen via my macbook (with share screen apple functionality)
  9. Crashdamage

    Crashdamage Well-Known Member

    That's a different program, built into Mac OS.

    Just go to the VNC website. There's easy to follow instructions and trouble shooting tips there. For setup of the router see the manual.

    Linux user #266351. Android since v1.0
  10. JujuFr

    JujuFr Member

    Hi

    i already tried myself by reading and trying everyting i found on internet

    it does nor work... i just want to access to my mac mini with my android tablet with my wifi (i do not need to have access from the internet...)

    this is what i have done
    - updated my rooter by adding the permission for VNC for port 5900, attaching this to my mac mini and/or my android... (i do not know which one need to be on the rooter... the serveur or the client?)
    - checking the port on my mac (apparently port 5900 is open)
    - trying to use internal ip adresse or external ip adresse of my mac mini (on the vnc client)

    it does not work, i still have this message :
    when using port 5800 : VNC connection failed! failed to connect to localhost/192.168.1.67 (port 5800): connect failed: ECONNREFUSED (Connection refused)
    when using port 5900 : VNC connection failed! Null

    any idea?

    juliette
  11. Crashdamage

    Crashdamage Well-Known Member

    You were correct in adding VNC on port 5900.

    The MacMini will be the server. It can be connected to the router by either wire or WiFi. Make sure the VNC server is running on the Mac. It should be running as a service.

    You must determine the IP address of the MacMini to connect. For Windows the command is 'ipconfig' for Linux it's 'ifconfig'. I don't know what the command is for a Mac but it should be easy to find. It will be a number something like 192.168.1.101.

    On the tablet in VNC, enter the MacMini's address as 192.168.1.101:5900 (or whatever the actual IP is). Be ready with your WiFi password.

    Again, the VNC website should be helpful.

    Linux user #266351. Android since v1.0
  12. JujuFr

    JujuFr Member

    Hi

    I have done that already :
    ipconfig on my mac (that s why i am sure of my ip)

    i still have the sae error...
  13. hstroph

    hstroph Well-Known Member

    Can you open a command-line window on the mac?

    ps auxw | grep -i vnc

    ... if indeed the OS is Unix-like as I've heard. There are probably gui-based ways to get the same info, but I'm not familiar with them.
  14. hstroph

    hstroph Well-Known Member

    All right, it sounds like you have a command-line window, so let's start at the most fundamental level of network diagnostics. Please post your results so that we can see what you're seeing. "It doesn't work" won't qualify as an adequate response for being able to provide further help.

    You want to know the IP address and netmask of your tablet and the mac. Are they even on the same network segment? If so, then from the mac, "ping" the IP of the tablet. If you have success, then (optionally) "ping" the mac IP from the tablet if you have such rooted tools installed (e.g. Better Terminal Emulator Pro with BusyBox Pro). You may need to "su -" on either end to enable the necessary socket connections and path needed to "ping".

    Once you've verified that the machines can "see" and communicate with each other, it's time to see what ports are open on the mac that the tablet can see, so install NetAudit on the tablet and scan ports on the mac, from 1 to 7000 or so. This will provide some very useful information in general (especially if one has the patience to scan from 1 to 65535) but we're looking to see what ports the vnc server is actually listening on, which depends on the way you configured the vnc server.

    Once you can see those open vnc server ports, then make sure the client viewer you're using is addressing the correct port.
    Crashdamage likes this.
  15. Crashdamage

    Crashdamage Well-Known Member

    VNC uses port 5900 by default and the OP granted VNC permission on that port already. I get the vague idea the OP is not rooted, nor do they need to be for VNC.

    I have a feeling either VNC server is not running on the Mac or it's something else in the router setup.

    Linux user #266351. Android since v1.0
  16. hstroph

    hstroph Well-Known Member

    There several different vnc servers, and they don't all use the same default port(s).
  17. JujuFr

    JujuFr Member

    Hi
    AndroidVnc does not work BUT
    i installed 2 other clients :
    - realvnc
    - mocha vnc lite
    i can now see the login screen of my mac BUT i do not know why i cannot use my mouse (android) or my keyboard.. the signal does not seem to be sent to the mac mini ;-(

    juliette
  18. hstroph

    hstroph Well-Known Member

    You need to configure the vnc server to allow client input.
  19. Crashdamage

    Crashdamage Well-Known Member

    Sorry, I should have been more specific. I always use RealVNC.

    Linux user #266351. Android since v1.0
  20. JujuFr

    JujuFr Member

    Hi

    i just changed the port as 5900 was used (i suspect Mac's screenshare uses it already)

    it is fine!!!

    thanks
  21. hstroph

    hstroph Well-Known Member

    Glad to hear it. You would be providing a great service to others with the same issue if you would summarize the steps needed to successfully use VNC client/server and post them in this thread.

    Future generations (and many current ones) will thank you!
Loading...

Share This Page