HOWTO: Alternative Root method for Samsung Exhibit 2 II 4G with a Read-Only filesystem and no su


  1. merryjohn

    merryjohn Member

    OMG i FINALLY found a fix!!!!! i kept getting the "read-only file system" error with NO su installed/accessible. I couldnt find any forums or thread with a working solution. 98% of them recommended zergrushroot (and/or remount -rw), with about only half the users having successful roots. (if it's of any importance, i have the T679 model)


    Anyways, I didn't have SU installed and the file system was write protected. since i couldn't get root privileges, i couldnt remount, chmod or install su, and since i couldnt install or chmod, i couldnt root (vicious circle!)

    [​IMG]


    After trying 3120597 different zergrushroot versions and 335 other root methods, i decided to go back to the basics, with a little help from a few google searches. I figured the os itself was locking the filesystem, and must have some kind of hidden service preventing remount, or writing to system directories, especially since ADB wasnt even allowed to perform any root functions, even with the usb debug box checked, no screenlock/timeout, and the Samsung usb tether driver installed. that, or superuser wasnt even installed at all! therefore, i figured the only solution was to install it from outside the operating system, which was exactly what i did.

    ~~~~~~~~~~~~~~~~~
    Solution:
    i got busybox/su installer from HERE, then placed the zip on the root of my sd card in windows. then, i simply booted into clockwork/recovery (turn phone off, then hold volume button up, turn phone on while still holding the volume-up button) and installed the zip folder. (if you use the factory recovery mode instead of clockwork [or initially install clockwork with factory recovery] you will probably have to rename each .zip folder "update.zip") Voila! Fully rooted, and with busybox installed too!

    ~~~~~~~~~~~~~~~~~~
    Also, normal CWM doesnt work on the Galaxy Exhibit II, i believe. you have to use a customized one, found here: xda-developers - View Single Post - Samsung Galaxy Exhibit 4G


    *This fix does not risk getting viruses since you do not even need a pc, or only need it to download and transfer .zip's to the sd card on your phone. Also, zergrushroot and many other "root kits" (double entendre??) are marked as trojans by antiviruses, whether truly malware or not. both su- and busybox are known and trusted across the globe. the factory recovery mode is prebuilt into the phone, and the galaxy clockwork alternative is based on clockwork mod used on most rooted phones. the entire process takes less then 10 minutes on an experienced users first try. You don't have to flash or erase your ROM, so you can keep the customized factory android if you want, while receiving complete administrative permissions!
    also, btw im new. Hello AndroidForums members! I originally posted this in the galaxy exhibit forum, not realizing there was a separate forum for the Exhibit II.


    BUSYBOX/SU ZIP INSTALL DL: https://dl.dropbox.com/u/34053267/SU-Busybox-Installer.zip

    GALAXY CLOCKWORK ZIP INSTALL/INSTRUCTIONS: xda-developers - View Single Post - Samsung Galaxy Exhibit 4G

    Please let me know if anybody has success with this.

    Advertisement
    :
    JrossiX, FumbleFingers and zach30341 like this.
  2. DaisFlaque

    DaisFlaque Guides Guide

    Nice work-around! I see this as a good way to get that stubborn su in it's home. One little problem... what to do with no computer? it's quite simple to root with t679.zip from xda. and you can do all that w/o a computer just make the. zip with es file explorer and than flash like normal. thanks for your insight man glad your with us.
  3. merryjohn

    merryjohn Member

    yes, you can download the .zip files with the browser on the phone, and use a file manager such as es or astro to move it from the downloads folder to /mnt/sdcard, like you said.

    The command prompt posted was just to show the problem i was having with permissions and/or adb. like you stated, you dont need it at all.

    yes, other methods work just as well, but i like this one because it leaves the stock rom completely intact, except integrating su/bb


    UPDATE: DO NOT EXTRACT THE .ZIPs. Simply place them on the root of the sdcard.
    DaisFlaque likes this.
  4. zach30341

    zach30341 New Member

    I also have the Exhibit II 4g (T679) and have been unsuccessful getting the zergrush root to work. I was able to get root access using your method.

    Thanks!
  5. Gravelyill

    Gravelyill New Member

    I got Superuser to come up on my cell phone. Are we missing busybox? I don't see it. Not sure. However, I still don't have access to the apps, so I guess my phone isn't rooted. My husband and I followed the directions above. Thank you for them. Any suggestions? We downloaded the zipped file from your link to our computer, then copied the file directly to our SD card but were not able to open it on our phone. So we went back and unzipped the files on the computer and copied the individual files to the phone and tried again. Thanks for any support!
  6. merryjohn

    merryjohn Member

    @Gravelyill That's the only thing i could not figure out! the zip installs a bare-bones version of busybox, but not the full set of tools. When i tried using the installer, it would say my phone wasn't rooted, or it couldnt access the directory. Unfortunately, some of the more advanced apps requiring root NEED these basic linux commands...Eventually i got so fed up i simply reset with cwm9 (the last two builds, the last just released 9/28/12 is ACTUALLY VERY stable despite "beta"/"unofficial"...i wanted to avoid flashing but afterwards i was EXTREMELY glad i did! thanks jocola!; get it here)(official thread here)(you still need the custom clockwork from the first post).

    I've been very busy lately, but when i get some free time i will try to find a fix for this.
  7. merryjohn

    merryjohn Member

    UPDATE: I admit I still haven't spent much time or effort into finding a work around for complete busybox tools. However, I came across a thread at xda that might be of some use. I haven't test it yet, but you can try [at your own risk!) it.

    Please let us know if any of his methods work or not!

    http://forum.xda-developers.com/showthread.php?t=1686384
  8. tube517

    tube517 Well-Known Member Contributor

    If you are talking about Jocala, he is THE GUY for the Exhibit. Unfortunately, that forum won't make a separate section for our phone. So, you have to read through the whole thread. But, he is the primary dev. His ROM, Peach Sunrise, is a very good ROM for the Exhibit.
  9. merryjohn

    merryjohn Member

    Hell yes! i love his stuff! but the link i provided is actually for root only, i believe without flashing (other than clockwork).

    Im running his modified Cyanogenmod 9, and its actually running better then the official CGM did on my mytouch slide or G2!! I just wish he'd get the flashlight working, and 911 in case I evr OD and a friend doesnt have my password lol

    Anyways, i will try to make time sometime this week and test the method out. (ps the same thread also tells how to revert BACK to factory in the second post)
  10. genesplice

    genesplice Member

    I have spent the last hour trying this. I don't get what I'm doing wrong. I am trying to unzip the CWM download from XDA developers to the phone's SD card, but then when I boot into recovery mode and search for the .zip file, there's nothing there.

    The instructions keep saying to move the file to the phone's "Internal SD card." I don't have a removable SD card right now. If I need one, it would be nice if that were mentioned. I keep trying to move the .zip file to the drive F and the choosing "External SD card" because that's the only thing that makes sense. Rebooting in recovery mode shows nothing. I've tried moving the file into drive G, but that's empty and I'm pretty sure that's the designation for the removable SD card slot.

    What am I doing wrong?
  11. phillybirds

    phillybirds Active Member

    I've tried to get it to allow me to put su on my primary but the phone will NOT allow it. I'm ready to throw this thing out of the window lol.

    The error I get is

    E: Can't open/tmp/sideload/package.zip (bad) Installation aborted

    I get the exact same message when I try to put the cwm on it. Anyone know what the heck I'm doing wrong? ANY help would be awesome.
  12. XanTech

    XanTech Member

    Has anyone found how to actually use the external SD card for the files from apps? When you connect one to a PC or laptop, there is an internal ext2 partition on the phone that the apps keep linking to, which gets annoying because it is not as large as my external one, but I can't find how to link it to the external/purchased card.

    Scratch that...found it. SwapSD gets it done.
Loading...

Share This Page