HOWTO: Install Missing Android Market on XPERIA X10 MiniTips


  1. stynx

    stynx New Member

    I still can't use the Market. When I clicked the Market there is a second white screen and then straight go to the menu. What should I do? I got my phone with 2.1 on it. Anyone? I've cleared cache too. :rolleyes:
  2. shethiad

    shethiad New Member

    Thanks a lot. Great work. I was able to install market on xperia X8 with 2.1.
  3. asraf8

    asraf8 New Member

    thanks.. great tutorial...
    installed market on my x10i mini.2.1 2.0.A.0.504
  4. kim.k.mitch

    kim.k.mitch New Member

    i can't seem to find the vending apk, help! i dont know where to find it ,or where to go.
  5. asraf8

    asraf8 New Member


    its in attachment in the 1st post.. check again
  6. jrbmendes

    jrbmendes New Member

    1) Sorry if it is an obvious question, but where do I get the Vending.apk for X10i (not mini) for 2.0.2.A.0.24 ?

    2) As I said on (1) I made the mistake of upgrade to 2.0.2.A.0.24 on the hope that it would install Android Market on upgrade. It happened before I read this tread. Will the procedure work if I use SuperOneClick to root the device ? Other forum said that this aplication can root the 2.0.2.A.0.24

    3) Any special care I need to take now that I am with 2.0.2.A.0.24 ?
  7. mimsaabir

    mimsaabir New Member

    Hi It worked for me too... Thanks.
    But, I got stucked in step 5, I cannot download the file. Then I downloaded it to my PC and copied to SD card,
    Then downloaded SlideMe market place and installed file manager from that. then browse SD card and installed UniversalAndroot.
  8. Draken Mirage

    Draken Mirage New Member

    i have xperia x10 mini pro android version 2.1.1.A.0.6
    z4root didnt work so i used superoneclick and it said it was rooted but AndRootFile always lags after i say ok to use su command .
    i dont think it is really rooted cuz i still cant copy vending to system.
    any ideas??
    EDIT : problem solved :D
    if u have build 2.1.1.A.0.6
    just use superoneclick instead of z4root which can be found here
    http://forum.xda-developers.com/showthread.php?t=906742

    and use root explorer instead of AndRootFile which can be found here
    http://www.4shared.com/file/DHtj78rk/comspeedsoftwarerootexplorerv2.html

    and thanks for crazydip for his incredible guide
    lillalioness likes this.
  9. anakinlam95

    anakinlam95 New Member

    i just pushed it wif adb and succeeded
    using x10
  10. playerz

    playerz New Member

    sorry.. i rookie in android world.. :p
    i stuck at step 5..
    Build Number 2.0.A.0.504
    kernel version 2.6.29
    firmware ver 2.1-update1
    baseband version m76xx-tsncjloym-53404006

    pliz help me :-(
  11. ghazaaz

    ghazaaz New Member

    Are these steps work with Samsung Galaxy S Phones? Please help.
  12. burning21

    burning21 New Member

    Success!!!
    I had already installed the latest 2.1 update, so was having a heck of a time rooting... I know, I know... but I saw your warning way too late! :(

    HOWEVER! I found one that works!
    I used SuperOneClick here, and it worked like a charm: [APP]SuperOneClick v1.6.5 (Root, Unroot, Enable Non-Market App, Get UNLOCK code) - xda-developers
    Watch the video tutorial - the instructions make more sense after that.

    Good luck, everyone! :)



  13. anwardgr81

    anwardgr81 New Member

    I updated as per the instruction and i was successful but the thing is when i try to download any application it is getting closed
  14. sumeet_sageer

    sumeet_sageer New Member

    Thanks Crazydip. I have to say that after all the tries from different resources only your post I have had success with. Have a X10Mini with latest Android version. Below are the steps I did to finally get android market working.

    1) Backup data (Using restore or backup app)
    2) Download EZ file manager from Slideme (You need a file copier to copy Vending.apk to the Root folder)
    3) Download and run Superoneclick (I used v1.6.5) in administrator mode
    4) Connect the phone with USB Debugging mode
    5) Copy vending.apk to Phone card
    6) Use Superoneclick to root Phone
    7) Using File manager move Vending.apk to /system/app/ (Here where they will ask for root permission.)
    8) Run the vending.apk from /system/app/. Should install without any problems
    9) Use Superoneclick again to unroot your phone.
    10) Remove cable and uncheck USB debugging mode
    11) Turn of phone and turn it on again.
    At this point when you check in apps you should see the AM. But I had a problem here where android market starts but then closes with an error. I did a hard reset, which involved using companion suite to repair/update the phone. This unfortunalty deletes everything and you will have restore from the back up in step 1. Waiting for the update to finish and crossing my fingers it worked. Now a happy camper with android market. :)

    Thanks again
    Sumeet
    lillalioness likes this.
  15. sumeet_sageer

    sumeet_sageer New Member


    Had the same problem. I had to hard reset my phone and that fixed it. Best of luck.
  16. bazeewm.liby

    bazeewm.liby New Member

    finally...i downloaded market on my x10! but after i open it...&try 2download any-apk, it show me 'FORCE STOP', is that problem from da fone? or ders another guess.
    thnk u aloooot about ur help.
    frind from LIBYA
  17. suspect_1413

    suspect_1413 New Member

    my update is 2.1.1.A.0.6
    can I install android market in my x10 mini
  18. faregon

    faregon New Member

    Hi I was wondering do I have to go trough all the procedures every time when I do a hard reset ?
  19. lawrencegu

    lawrencegu New Member

    thaqnk u so much 4 sharing
  20. thehmanx

    thehmanx New Member

    wel...i tried it but when i try to copy it says copying failed??
  21. khd

    khd New Member

    Excellent man you are really great, you solved my big problem thanks alot. Everything works fine even afer upgrading to 2.1 also. Great job
  22. khd

    khd New Member

    Great man Craztdiop i could manage it very well. You solved my big problem, thanks alot for your great help.
  23. humvee998

    humvee998 New Member

    please help got stuck in step 5, couldn't launch the universal and root. I placed it in my SD together with the vending pack.

    quite frustrated here, any assistance will be highly appreciated. Thanks
  24. poleng

    poleng New Member

    sorry. i'm asking a noob-question but, how do you exactly "unroot"?
  25. alwatiq

    alwatiq New Member

    thanks bro..it's really worked on my xperia x10i v2.1..
Loading...

Share This Page