HOWTO: Partition Your SDCard for A2SD


Last Updated: 2012-09-12 13:00:16
  1. motorsport226

    motorsport226 Well-Known Member

    Is getting a class 10 card overkill?

    Advertisement
  2. jaytime

    jaytime New Member

    I'm having similar problems as others. I used ROM manager, which is using the latest CloworkMod recovery. I can tell that apps go to my SD car, and I can see the partition in my Disk Manager in Windows. However, I can't assign a drive letter to it there, so I can't browse on my computer. I don't see system\sd or sd-ext anywhere when browsing with Root Explorer. Using terminal emulator, I get the same '/system/sd: no such file or directory' message. And I don't see SD Card Secondary (or anything besides my SD card and internal phone storage) in my Settings>SD card & phone storage.

    How can I browse the partition on my phone? Where are these APKs going?

    I would prefer to stick with ROM Manager to do it. Something about AmonRA instructions didn't seem right to me. I could potentially use gParted as someone else suggested. However, that leads me to other questions, such as whether to put the new partition at the beginning of the drive (unlike ROM Manager, which put it at the end--and maybe that's why it isn't working). I could do it with Disk Manager on my computer too if I knew the answer to that question.

    On a Droid.

    Any help would be appreciated. Help focused on using ROM Manager would be preferred. Would flashing SPRecovery be better? I will likely try this next.
  3. dots

    dots Well-Known Member

    I'm not exactly sure how you would be able to view the ext partion on your phone. But with windows you cannot as it does not support the ext file system. You would need some 3rd party program to view ext partions in windows.

    But the APK's are being stored on the ext partion on your sdcard i can confirm this because linux is able to see the partion as linux uses the ext file system. That's how i checked to see if my app2sd was working.

    I doubt most of us here know what sprecovery is or anything droid related for that matter. But you never know.
  4. jaytime

    jaytime New Member

    Thanks for the reply. ROM Manager wouldn't perform the Partition SD Card function with SPRecovery anyway, so that's out.

    Shouldn't Root Explorer be able to view the partition? I can see the contents of the system folder, and no sd sub-directory.

    Also, it doesn't show in the SD card & phone storage as a SD Card Secondary or anything. Is yours showing that?
  5. dots

    dots Well-Known Member

    I have tried both Astro and OI file manager and they both show the /system/sd as empty.

    And yes SD card & Phone storage only shows my sdcard Total Space at 3.20gb which means its partitioned but maybe android only reads the fat32 partion and is not able to read ext partion and/or file systems? That's all i can assume. Just a thought dont have a definte answer.
  6. MrlnZ

    MrlnZ New Member

    Greetings all
  7. myfishbear

    myfishbear Well-Known Member

    i had a big problem with velo 3 with my stock sd. i upgraded from a class 4 4gb a class 10 8gb for 30$ and formatted it like in this post and and stopped crashing on me. my gf had a class 2 on he froyo droid. after the upgrade.... omg it was like greased lightning lolz
  8. lostlaker24

    lostlaker24 Well-Known Member

    Ok this might be a dumb question, I want to try remove the partition from my card. What simple common sense steps am I drawing a blank on here?
  9. swc2001

    swc2001 Well-Known Member

    Now maybe this has been covered and I just missed it.
    If so would someone mind pointing me in to a quote or a correct thread.

    How do you Properly do a backup with Drellisdee's recovery once you have apps 2 sd enabled on your phone.

    I love wiping my phone all the time and playing with different roms... So
    When I have apps 2 sd I have been doing a Nand back up the regular way. Now I flash to say Raptor.... BUT before I would do this I would Data factory wipe, cache wipe, dalvik wipe, and finally SD ext partition wipe.
    I then put on the ROM, play with it for a few hours and then want to go back to my main ROM. Now when I do this I wipe all of those same things again. I then put on my Nand back up that was done the regular way and poof almost all of my apps are gone. the only ones left are the ones that come stock with that ROM.

    So I am assuming that Drellisdees Recovery is not backing up the SD portion where my apps are now located thus when I put that Nandroid on there all of those apps are gone. I am sure there is some way of Backing it all up I just have missed that illusive step. Again guys sorry to be so Dumb. I sure do appreciate any help on the proper way of doing this.

    Thanks guys
    Steve:eek:

    p.s. you can PM too if that is easier.
  10. darkxsun

    darkxsun Well-Known Member

    I *believe* Clockwork does this but drellisdee's does not.
  11. swc2001

    swc2001 Well-Known Member

    Hmmm how can we find out for sure? I always have heard that drells recovery was way better.
    I am still inclined to think so.
    Can someone weigh in on this?
  12. dots

    dots Well-Known Member

    I'm not 100% sure but i believe that drellisdee's recovery has the backup nandroid+ext option. I've personally never used it if it's there. I will take a look ina couple of hours and see (its 4am)
  13. swc2001

    swc2001 Well-Known Member

    Oh my word.... so simple. I am so STUPID. I totally forgot about that option.
    Man I feel like a MORON. :rolleyes:

    Dots as Usual your the man!!!

    Ima try it right now.

    I Love this forum.

    p.s. I knew Drells Recovery was the best. LOL Dont need no stinking Clockwork... tewy
  14. swc2001

    swc2001 Well-Known Member

    Confirmed
    Dots that worked awesome.

    I am sure I am the only one that didnt know that though. LOL
  15. Groves

    Groves Member

    Need Help-

    So I have velocity 0.3 with Clockwork/ Rom manager. I had partitioned my card but when I looked for files under System/sd there was nothing there. I tried to partition again and my sd was wiped. All my apps were gone including market. My laptop power supply crapped on me and I am unable to backup my sd card. I ordered a new PS for the laptop, but may not be here for a few days.

    So my question is- Is there anyway to download the Market and just start from scratch?
  16. swc2001

    swc2001 Well-Known Member

    Ewww yikes!!!
    Yeah thats not cool.
    FYI everytime you Partition your your SD it Wipes the data.
    So you should back that up before the patitioning. Oh man I am really sorry. that hurts. Well I would advise putting on a old Nandroid back up if you have one. If not you should be able to wipe all your data and then push the Market onto your phone via the .apk file. Or if it were me I would just flash velocity again. That should bring it all back to stock Velocity.

    I highly reccomend using Drellisdee's Recovery over Clockwork.

    Good luck Bro!
  17. Groves

    Groves Member

    My SD is backed up on the laptop, but like I said, cannot pwr on laptop till i get the PS cord. I guess i can wait a few days till I get it and hopefully get my apps back. In the meantime, im glad I still have a browser and phone.
  18. dumbteentarget

    dumbteentarget Well-Known Member


    Well since you have a custom recovery on there now, you could download velocity from drellisdee's link and boot into recovery and flash the zip from sd card. Idk how drell has it packaged in the download but it might be worth a shot.

    [ROM] Velocity V0.3 | LG Ally | Fast | VZB | Android 2.1 | Stable
  19. Groves

    Groves Member

    Good news,

    Last night I received my PS cord and was able to power up my laptop.

    Just want to chronicle some steps that I had to take in order to get my Ally operational again.

    1. When I transfered the velocity0.3.zip info onto my SD, I had to clear cache in order to boot .zip file from SD in recovery mode.

    2. This did not bring back my google and market apps, it did however bring back ROM Manager, Astro and Spare Parts, etc. But everytime i opened these apps, I would get a force close after a few seconds.

    3. Tried my luck getting to my ROM Manager "Manage and restore backups"- before a force close and selected Stock Ally (my original Restore).

    4. It worked- phone flashed to Android stock. Got all my apps back!!

    5. Reflashed Velocity 0.3 and had to rebuild my Ally with my favorite apps.

    Thank You dumbteentarget and swc2001 for your response!!

    ALWAYS REMEMBER TO BACKUP YOUR SD CARD AND A GOOD WORKING ROM!!

    *Only complaint- phone is runnung sluggish now- I will search that in another thread.
  20. swc2001

    swc2001 Well-Known Member

    Well I have reflashed velocity and before even setting up my gmail I put on the Turbo4 zip. I wanted to over clock. Well Now everything works GREAT!!! except my apps2sd does not seem to be working.
    Before I had 74 MB Now I have the same apps and only 18MB

    What gives. How do I correct this?
    Can anyone help?
  21. swc2001

    swc2001 Well-Known Member

    Well nevermind I used Killertonez Apps2sd and it worked like a charm. Still dont know why Velocities didnt work but hey its all good now Thanks to KILLERTONEZ.
  22. EpicFailz

    EpicFailz Member

    ok so i followed the clock work steps outlined above. Phone rebooted all my apps where there but it didnt appear that anything had been moved to the sd card. so i rebooted the phone. it got stuck at the velocity screen (i let it sit there for 20 mins). I had to pop the battery out and hold the power button. then the phone rebooted but still no sd love. So i decided to repartition and start again. I reboot and now all my downloaded apps are gone. I have all the apps that came on the rom(Velocity V3) but none of my installed apps. If I go to market and try to download one of the apps I have it says Incompatible Update. Any ideas?
  23. Matt's 175

    Matt's 175 Well-Known Member

    Worked great for me I just followed the Clockworkmod instructions to the letter. Anyways, simple simple way to tell if it worked.... Remove the SD card and try to launch one of your apps. It will immediately "force close". Put the card back in and if the app works.... then it's on the card.
  24. kyle5434

    kyle5434 Well-Known Member

    I've had my Ally since early August, and the memory limitations (and occasional sluggishness) are finally prompting me into mustering the courage to try a different ROM.

    After rooting, I followed the ClockworkMod instructions, and can successfully reboot into recovery. I've also backed up my current ROM for safekeeping.

    However, when I try to partition my newly acquired class 6 SD card using Rom Manager, I always get the little droid character with the exclamation point, then a reboot.

    Any pointers?

    Thanks.
  25. flyinjoe13

    flyinjoe13 Well-Known Member

    Try going into the ClockWorkMod settings and put a checkmark in the Erase Recovery box. When I first installed CWM, I had a similar problem rebooting into recovery until someone suggested I try that and now it works everytime.

Share This Page