Hp TouchPad CM9 and CM7 Charging Problem *FIX*Tips


  1. Dgr8wun

    Dgr8wun New Member

    I dont know if this will help but I have a tp on the regular cm9 alpha 2. I have drained the battery before and charged it back up without a problem but last night it died and I left it on the charger, the battery charging picture showed up so I thought it was good. The next day I checked it and it was dead. So i tried it again and checked it a few minutes later. It booted to cm9 but the charge stayed at 0%. I left it for a few hours and it was dead again when checked it. So this time i waited so I can boot it to webos. On webos the charging went up to 2% in about one minute and is steadily charging. So i think it does have something to do with cm9. On a side note the oem usb cable is crap, It only works on certain positions.
  2. colchiro

    colchiro Well-Known Member

    If you had updated to a nightly build, you wouldn't have had this issue. This issue was fixed, along with a bunch of other issues.

    You should update your TP to a nightly build and you'll enjoy a (mostly) fixed microphone, wifi, and no reboots when it sleeps. We may have a fixed camera soon too. :D
  3. JALStudios

    JALStudios Well-Known Member

    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
    |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||




    This guy is 100% correct! The CM9 Nightly builds update small little bugs! You can also try and flash the CM9 Alpha 3! No camera yet :( But still great to have ICS on this device!


    I would suggest that you run CM7 until they have a more (Stable) version of ICS! Even though like he said they are fixing the bugs on the Nightlies!


    I hope this helped!
  4. colchiro

    colchiro Well-Known Member

    CM7? CM9A3? No way.

    CM9 will do circles around CM7 and it has progressed a LOT further than CM7.
    It sleeps without rebooting.
    Wifi is fixed.
    You can play music with the screen off.
    Microphone works and camera is getting there.
    Sdcard fix is included. (Check integrity of sdcard on each boot.)

    What advantage does CM7 have?

    CM9 is close to release candidate status. Maybe you want to check the CM7 changelog.
  5. JALStudios

    JALStudios Well-Known Member

    The only reason I suggested CM7 was because of the camera working! I use the camera a lot! And I do agree that ICS is WAYYYY better than Gingerbread! But I decided to just use CM7 until CM9 comes out with a camera fix!
  6. colchiro

    colchiro Well-Known Member

    Sorry, I did not know the camera worked with CM7.
  7. JALStudios

    JALStudios Well-Known Member

    Its ok... I think is was the CyanogenMod 7.1 Alpha 3 update that had the working camera!


    But I will FOR SURE switch back over to ICS whenever they have a working camera!
  8. yiddishmaffia

    yiddishmaffia New Member

    So first I was getting the HP logo and according to my research it said you had to webos doctor. I got the file and even figured you had to get the initial file, updated my java for that and blah blah blah.

    Then, to make my life harder, the damn thing stopped taking a charge. I did ALL of the recommended fix. Playing piano beats with the buttons to a certain tune, twisting the charger block that came with it, tried different usb 2.0 cords, different outlets, etc etc etc
    I don't get any feedback such icons or lighting up. Nothing.

    so now what?
  9. colchiro

    colchiro Well-Known Member

    So what rom are you running? Cm7? Cm9? Something else?

    What version?

    A nightly build of cm9, (at least July 7 preferred), would have everything working except the camera (which might not ever be fixed). This includes any charging fixes.
  10. JALStudios

    JALStudios Well-Known Member

    Yea this is kinda outdated! But i left it up for people to use if they are running a earlier ROM such as CM7 or MIUI!
  11. colchiro

    colchiro Well-Known Member

    [deleted] wrong thread. :D
  12. yiddishmaffia

    yiddishmaffia New Member

    It has CM9...but there is no life in this tablet at all. It does not charge and is simply lifeless.
  13. chats102

    chats102 New Member

    Dead touchpad for me too running CM9 nightly 19th September. TP normally drained prior to charging (used by my kids for android apps & they don't stop until the screen goes black!) it now won't reboot - left on usb charge on laptop for a couple of hours, no joy yet - will leave on overnight & see in the morning.

    I've flashed about 20 of the nightlies & this is the 1st time i've had this issue - posting this to ensure people still aware there can be issues with charging after June nightlies (even if it is a bad flash)
  14. colchiro

    colchiro Well-Known Member

    If there's a chance there's a charge left, then you want to hold the power + home buttons pressed for at least 30 seconds to make sure there's isn't an app preventing it from shutting down, then throw the charger on it.

    Thread to check out:
    Touchpad won't charge or boot - HP Touchpad - RootzWiki

    Otherwise, if it's completely dead and you can't resolve it by charging with the stock charger and stock cable or USB and you've checked the charger on a different device and you know it works, then the only recourse may be to open it up and charge the battery directly (best left to an expert).

    The stock charge is rated at 2 amps so you really need to be using a charger rated at 2 amps. :D
  15. chats102

    chats102 New Member

    Thank the lord for internet forums! After leaving connected to usb port overnight - eagerly woke to find...nothing. Left charging in usb 2.0 port all day whilst at work, eagerly checked when came back home...nothing. Symptoms at this point were the same:
    1. Holding down any combination of button did not work - most common sight was the battery with volt symbol & red line, followed by plug symbol.
    2. Reconnecting to laptop netted the battery/volt/red line symbol, followed by use the correct charger screen.
    3. Connecting to the mains charger - resulted in nothing.

    Then the miracle occurred, the sequence of events being (in the space of 2 hours) although most steps are superfluous - i've kept them in to show the method (however mad it seems)

    1. Disconnected from usb port to plug into mains - no change
    2. All combinations of button presses - no change
    3. Reconnect back to usb port - no change
    4. Disconnect & reconnect to mains charger - continuous battery/volt/red line symbol
    5. Left on this screen (because it was something i hadn't seen)
    6. After 20 -30 mins in booted to moboot (which i was really lucky to catch with 2 seconds to go until ICS boot) when i put into WebOS and now charging.

    Upshot is that i think the trickle charge via usb for circa 24 hours followed by quick top up at mains got it enough charge to reboot.

    Hope this rambling helps anyone else suffering the pain!
    colchiro likes this.
  16. colchiro

    colchiro Well-Known Member

  17. Nevada

    Nevada Member

    Same issue here with charging. Running CM9 latest nightly. (0923 I think). TP charges w/o issues in WebOS, but flakes out in CM. Indicator shows battery charging, but level still drops until it goes into sleep-of-death.

    Always have to finesse it out of SOD and charge it in WebOS.

    Is there still no fix for this? Otherwise CM9 is pretty solid IMO.
  18. colchiro

    colchiro Well-Known Member

    I'd create a backup in recovery and Titanium Backup, then wipe data, both caches and flash a good version, like the nightly for July 7th and gApps. (Sounds like some of the recent nightly builds have wifi problems.)

    See if that has issues. If it's no better, then restore your backup in recovery and nothing lost.

    I found that my TP was better after a wipe. A year of upgrades (apps and rom) had apparently caused some little issues here and there that a fresh install fixed.

    If the new build is better, open TIBU, and batch restore and choose "restore missing apps with data". Do not restore any green or red items since that can cause issues.
  19. Nevada

    Nevada Member

    I see an 0930 nightly is out, I'm going to try that first. If my senses are working, I seem to think the charging issue had gone away until the 0923 nightly. I could be imagining it, but I'm going to try the 0930 then go back to the 0909 which I used without issue.

    If no-go on any of those I'l wipe and reflash. This TP is almost useful now, but the charging is an issue.

    ...ok, 0930 nightly is installed, let's see how it goes.
  20. colchiro

    colchiro Well-Known Member

    You didn't say it started with a certain nightly.... :D

    I agree. Don't you create a backup before updating? Restoring a backup is so much easier than a clean install. :D
  21. Nevada

    Nevada Member

    yes. i do a backup. and yes i agree that after multiple installs and tweaks, etc sometimes its good to get rid of the clutter.
    I'm pretty certain the charge was OK up to nightly 0909. I can also see right now the charge is looking OK. I'll know more after a couple of days.
  22. colchiro

    colchiro Well-Known Member

  23. Nevada

    Nevada Member

    I'm back. Same charge issue with 0930 nightly. I'm having trouble finding the problem here... not sure what to try next, or if I missed some secret fix out there for this issue.
  24. colchiro

    colchiro Well-Known Member

    From a feature standpoint, there's no big benefit to any build after 7-7 nightly, but there may be differences in battery use (gain or loss) when sleeping or degradation in wifi usability. If you have a working backup, I'd stick with it, o/w if you hope to report a bug, Rootzwiki would be a better forum for that. As you can see, it's nearly a ghost town here. :D
  25. jupiter2012

    jupiter2012 Well-Known Member

    good luck with everything
Loading...

Share This Page