HTC Desire can't save a phone/google contact number


Last Updated:

  1. smouda

    smouda New Member This Topic's Starter

    Joined:
    Jul 14, 2010
    Messages:
    2
    Likes Received:
    0
    Hi people.
    I just purchased my new HTC desire and i have a problem :
    1) Adding a new contact number to either phone or Google account. Name/surname are saved but the phone number doesn't get saved; so when editing the contact, no phone number appears....
    Then, when gonig under Phone and typing the letters of the name just added, i can find it in the drop list of "guessed names" with the number right under the name...
    I want to be able to view my contact and see the phone number from the application People; and that's impossible now because of this problem...

    Any HELP please...?
    I went to my provider's store and the guy said it may be a fault with the software and he's never seen that...
     

    Advertisement
  2. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,419
    Likes Received:
    172
    Do you have this contact in facebook as well?
     
  3. smouda

    smouda New Member This Topic's Starter

    Joined:
    Jul 14, 2010
    Messages:
    2
    Likes Received:
    0
    Not necessarily, it may be just a new added contact phone number
     
  4. dndxn

    dndxn Member

    Joined:
    May 6, 2010
    Messages:
    7
    Likes Received:
    3
    Hi,
    Yeah i had a very similar issue to this but just with google contacts crop up totally out of the blue a few days back.
    Basically any new contacts added wouldnt show up in "People" but typing the name or number into the phone made it show. Looking at the number of contacts in the "View" option also showed it had added an additional contact.

    When then checking the contacts through the gmail account shows that the correct number of contact was under "All Contacts", but "My contacts" showed one contact less. Selecting all contacts and adding them to my contacts group then sync and showed the new contact on my phone as normal in "People".

    This pointed me to the "group" option on the phone when adding a new contact.
    All new contacts are grouped by default to "None", leaving it in this group makes it now visible in "people" (this wasnt always the case). So i went to change this and noticed that it had a "null" group which i had never seen before, so i placed the contact in this group and low and behold it then showed the contact in "People".
    Now this is were things get a little weird, through trial and error i added the contact to each group in turn, vip,family e.t.c. and the contact is only shown in "People" for some of the groups its added to. Removing it from all groups makes it disappear again.....

    God knows why this is the case it just started out of the blue, no app installs updates or anything, but in now occurs with all new contacts.

    Anyone who has any ideas about this i welcome them....


    As for you "Phone" contacts, are you sure you have the viewing of phone contacts enabled through the "view" option within "People"?
     
  5. vincentieo

    vincentieo Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    "Comment 22 by matthewtoy, Jul 11, 2010
    Solution on HTC Desire for getting phone contacts into google contacts:

    1. From "people", menu -> import/export -> export to SD card -> Phone (or SIM for that matter).

    2. menu -> import/export -> import from SD card -> Google.

    Then delete your phone or sim contacts if you wish (there is an app or you could unlink your google account and then factory reset before relinking)."

    This work around is not the best UI experience but it does work perfectly well.

    Issue 4236 - android - add functionality to move contact from phone to server or otherwise - Project Hosting on Google Code - full list of people experiencing similar
     
  6. vincentieo

    vincentieo Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    opps, this is not really what you were talking about...sorry.

    I blame skim reading, tiredness and thinking this was another thread
     

Share This Page

Loading...