1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

HTC desire dropping wifi (really weird circumstances)Support


  1. nicksdarkroom

    nicksdarkroom Active Member

    Hi, I have an HTC Desire and with it a really odd WiFi problem. When using either mobile internet or any other wireless router there are no problems whatsoever. When at home using our echolife520s on TalkTalk I sometimes lose the connection when turing the Desire off and back on. It still receives emails but cannot connect to tinternet, Facebook etc, even though my wifi indicator at the top of the page tells me i am connected. If i turn the desire's wifi off and on again all fine, but this is obviously a bit of a pain. Even more frustratingly approximately 50% of the time it is okay and will connect!! So i never know whether or not i'm gonna have to turn the desires wifi off and on!!

    Ive checked and my desires wifi isn't set to go to sleep, and as far as i can find there is no firmware update for the router (although i have changed the TSS/MSS settings on the advice of another site that indicated there may be a problem with them, this appears to have made no difference).

    I am at the point of thinking i may have to replace the router, although i don't really want to as everything else that connects to it is fine (iPhone, iPod touch, laptop, netbook, blackberry, Wii, desktop pc) so I'm thinking it must just be the way my desire is communicating with it.

    Can anyone offer any advice please as its driving me insane!!!

    Thanks

    Nick

    Advertisement
  2. nx1977

    nx1977 Well-Known Member

    Get the app WiFi analyzer. Sounds like you need to change your WiFi channel
  3. nicksdarkroom

    nicksdarkroom Active Member

    Thanks, I've tried that, I'll give it a while and if i have any problems I'll come back and ask again. By the way just for the record, the HTC Desire, RULES!!!!!
  4. oleras

    oleras Member

    I have the same issues with mine. posted on another forum before finding this one.

    nx1977, when you say change channels, how is that done ?
  5. nx1977

    nx1977 Well-Known Member

    Log into your routers admin pages and do it there. The app I mentioned will tell you the best one to use
  6. nicksdarkroom

    nicksdarkroom Active Member

    Okay changed to a fixed channel, the one I was on was free, but slightly overlapped by others so I'll see how this one goes for a bit. oleras, your problems sound even worse than mine! At least when scanning I have a nice strong signal that is consistent. I'm sure its something to do with the way my HTC re establishes communication with the router when its been off as everything else has no problems. The frustrating thing is I have no idea what settings to change on the router, hopefully this channel change will help! I'll let you know if it fixes it.
  7. oleras

    oleras Member

    When i ran the analyser it showed the graph and a arc from 1-3. Phone said it was connected through channel 1. My router was set to channel 7, i changed this to channel 11. Does it make any difference is the phone is on channel 1, does my router need to be on this channel also ?

    I will let the phone sleep and toggle the power for a while and see can it keep the connection. Seems ok so far, fingers crossed !!
  8. nx1977

    nx1977 Well-Known Member

    Are you sure it wasn't suggesting you use channel 1?
    The screen with the stars tells you the best to use
  9. oleras

    oleras Member

    Well that didnt last long, second time it went to sleep it lost it. I will change the router to 1 now and test it.

    edit: under the channel select there is an "auto selecting "option, choices are continious, startup (selected choice) and off-use default. Do you know which one i should be using ?
  10. oleras

    oleras Member

    Same issues using channel 1.

    i will just return it i think, must be a fault somewhere.

    Thanks very much for all the help, really appreciate it.
  11. nx1977

    nx1977 Well-Known Member

    What channel does the app say to use
  12. oleras

    oleras Member

    It doesnt tell me, the screen with the channel list has all 13 channels with full green stars. The screen with a graph of channel and db has the arc/line going from the start to channel 3.

    Head is fried...going to set the router to channel 3 and try again.

    same on channel 3, even when i go into the wifi settings on the phone it hangs up and gives an not responding error and to force close the program.
  13. nicksdarkroom

    nicksdarkroom Active Member

    Well changing the channel didn't work for me, still the same issues, i dont know whether I'll be connected or not when I switch on. There must be a setting I can change on the router that I can change but how the hell do I find out which one?! This is beyond frustrating!
  14. oleras

    oleras Member

    I am going to bring mine back today, i think i have tried everything possible and it must be an issue with the phone. Will keep you updated.
  15. nicksdarkroom

    nicksdarkroom Active Member

    Cool, I'd be interested to know I've ruled that out with mine as it works on other routers but I'd be keen to know if there an established fix.
  16. nicksdarkroom

    nicksdarkroom Active Member

    So, I've been talking to our IT guys at work, one of whom has an HTC magic, the same router as me (echolife from talktalk) and had exactly the same issue, a year or so ago. He tried all the same things as suggested here with no success. The only way he solved the issue in the end was with a new router. So it looks like I'm buying a new router then!
  17. nicksdarkroom

    nicksdarkroom Active Member

    Well I bit the bullet and bought a new router (netgear) and its solved the problem straight away. So I guess if you have an echolife router from talktalk and an HTC then youre knackered!
  18. DannyVandal

    DannyVandal Active Member

    This is happening to me, well, my internet connection has stopped even though the phone says it is connected to my network. I can see that the phone isn't connected by looking at the list of connected devices but the phone insists it has an IP of 192.168.1.207. Router is a Speedtouch 585 and I really don't see why I should replace it when everything else (2 iPhones, 3 laptops, 1 iMac, 1 Humax Freesat box) is working fine on it!
  19. nx1977

    nx1977 Well-Known Member

    First thing to try is another channel on the router.
  20. drbell

    drbell Member

    Same thing happens to me. I've recently discovered that the wifi appears to connect in the day but not at night (another test coming tonight). However, I wonder if this is something to do with when i have set my exchange and e-mail to sync? Just a theory. Either way, I'm going to get the wi fi app and see if that helps. O2, Talk Talk, Belkin and HTC could not help with the issue.
  21. Geryatrix

    Geryatrix Well-Known Member

    If you are only having problems in the evening, I would try changing channels as it could be caused when someone living near comes home and switches on their equipment, and you get a channel overlap.
  22. smallclone

    smallclone Well-Known Member

    I have had this problem today. Very annoying, and must severly drain battery.

    I have force closed an app called GREEN POWER that was monitoring my wi-fi and I have changed my wifi channel via the router.

    It seems to have worked. For now
  23. yenrod

    yenrod Well-Known Member

    I have this prob occasionally..I reckon its to do with the latest 405 update...
  24. smallclone

    smallclone Well-Known Member

    Hi, what does this mean?

    I am at my wits end with this phone and this problem.

    Wif- Scanning...conected...disconnect...scanning...connected..disconnect

    it is insane.
  25. mrleelee

    mrleelee New Member

    Sorry for dragging up an oldish post....

    But my blood ran cold when I read this...

    I have exactly the same router and I have been having exactly the same problems with my HTC Desire for the last year!

    I put it down to software problems, router channels, even launchers my phone was using, never ever thought the problem would be the make of my router!

    Guess I will have to shell out for a decent router...

Share This Page