HTC Desire EMAIL INBOX DELETES OVERNIGHT


Last Updated:

  1. booboyz

    booboyz New Member This Topic's Starter

    Joined:
    May 21, 2010
    Messages:
    3
    Likes Received:
    0
    Hi, first time on here and new to android phones. I have a HTC Desire on Orange and set up my email acount with no problem.... or so i thought. My service provider is Virgin Media. I dont get that many important emails but i got one a few days back and went to return to it to record a phone number and it was gone. Recd 5 yesterday, read 3 & left 2 unread, charged phone from 11pm last night until 7 this morning, you guessed it - no trace of emails.... PLEASE HELP. I am no a techy and am probably need to change some settings, i have looked & looked and cant find anything relevant. Chuffed with phone, other than quiet ring tones, luckily i have large minute allowance as i miss a lot of calls and now make a lot more return calls.
     

    Advertisement
  2. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,418
    Likes Received:
    172
    How many days have you asked the phone to sync?
     
  3. phyre21

    phyre21 New Member

    Joined:
    Oct 8, 2010
    Messages:
    3
    Likes Received:
    1
    I got the HTC desire 2.2 phone recently and I am experiencing the same thing. I set up my mail account to use my gmail address so even though the phone deletes the inbox, all the messages are still in the gmail account if I access it from a computer.

    Have you figured out what is happening?
     
  4. Griff_LI

    Griff_LI Well-Known Member

    Joined:
    Jul 11, 2010
    Messages:
    371
    Likes Received:
    52
    Go to Menu->More->Settings->Send & Receive from within the email app list (white background)

    In there is the Download Options which is the length of time mails will stay resident. It does this to save memory on the phone. AFAIR the default was 3 days. This means that mails older than 3 days will be deleted from the phone. You can set it to Never if you want...
     
  5. Eris Ed

    Eris Ed Well-Known Member

    Joined:
    Jul 20, 2010
    Messages:
    982
    Likes Received:
    248
    Try this:

    Open Mail > Menu > More > Settings > Send & Receive > Download past mail

    Chances are you have this set to 1 day, therefore mail older than 1 day are removed from your phone (but NOT from the server of your email provider). To keep messages on your phone longer, change the setting (options are: 1 day, 3 days, 7 days, 14 days, 30 days and All).

    Messages can also vanish from your phone depending on the type of email protocol you use. Exchange ActiveSync will sync your email account so it you read or delete a message on your phone OR on the mail server, the changes will be copied to the other device. POP email accounts stay on the email server even if you delete it on your phone, but collecting email from your PC (thereby deleting it from the email server when it downloads to your PC) will also remove it from your phone.

    EDIT: @Griff_Li - posted at the same time ;)
     
  6. Eris Ed

    Eris Ed Well-Known Member

    Joined:
    Jul 20, 2010
    Messages:
    982
    Likes Received:
    248
    Are you using the Gmail app or another email client?

    If using the Gmail app: Email comes to your Gmail address on Googles server, and the server syncs with your phone. Messages remain on the mail server until you delete them from there. Your phone only shows messages that are on the server, for the period of time you set in the Settings menu:

    Open Gmail > Menu > More > Settings > Labels > Number of days to sync

    This setting is 4 days by default, so Gmail messages older that 4 days will be removed from your phone (but not from the Gmail server). You can change this setting to any number of days you wish. You can also set a sync period for each individual folder on your Gmail account, if you wish.
     

Share This Page

Loading...