HTC DESIRE ROOTED BUT STILL S-ON unrEVOked WITH LINUX


  1. LivingDead

    LivingDead Member

    Hello all,

    I am a new comer.

    My hardware is:

    MODEL
    DESIRE (french operator Orange)
    BRAVO PVT3 SHIP S-ON

    HBOOT
    0.93.0001

    RADIO
    5.11.05.27

    Android Version
    2.2

    Baseband Version
    32.49.00.32U_5.11.05.27

    Kernel Version
    2.6.32.15-ge2c73db
    htc-kernel@and18-2#1

    Build number
    2.22.73.6 CL283825 release-keys

    Software number
    2.22.73.6

    Browser version
    Webkit 3.1

    I ran Unrevoked3 (latest 32 version) on my ubuntu Linux 10.04. Everything seems ok but the famous message
    "Error: failed to get root. Is your firmware too new?"

    came up at the end.

    Second thing abnormal: I verified the S-ON is still there

    But I get root 'su' command is successful.
    I tried as the faq suggested to factory reset but clockworkmod doesn't work either
    Each selection in the clockworkmod gives me a black screen with nothing done. And I could not go back in HBOOT. I was obliged to remove the battery load to reboot.
    So I am stuck. I retried to choose a recovery from the custom recovery menu item but it did not give me this ability (still grayed out item).
    What should I do except living like a dead

    According to Xtremedays, It seems that it might have rooted your rom but failed to get s-off and flash a custom recovery.

    I get at the 2 reboots an error in my linux terminal:
    "ERROR n=-1 errno 19 (no such device type)"
    Meaning (errno 19) a device path was not found according to my developer knowledge.

    Full log:

    sudo ./reflash
    [sudo] password for karim:
    unrEVOked recovery reflash tool
    git version: 8b5c9e4
    Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so
    ERROR: n = -1, errno = 19 (No such device)
    ERROR: n = -1, errno = 19 (No such device)

    Regards

    Advertisement
  2. kewlbuddy

    kewlbuddy Well-Known Member

    for s-off, visit alpharev.nl
    LivingDead likes this.
  3. SUroot

    SUroot Well-Known Member Developer

    1 - Black screen in clockwork means you are using the power button to select. Power button turns off the screen. Use trackball to select.

    2 - if you have superuser app in app drawer and can send a request for root shell "su" then yes, you're rooted.

    3 - Like KB said above, GSM desires are not S-off'd by unrevoked. Only alpharev does this.
    LivingDead likes this.
  4. nafpez

    nafpez Well-Known Member

    PMSL I did that so many times when I first rooted, couldn't understand why nothing would happen. Anyhoo, +1 for that, exactly what I was gunna suggest.
    LivingDead likes this.
  5. SUroot

    SUroot Well-Known Member Developer

    Its quite common as you load recovery from Hboot using power. Only Hboot uses power to select :)
    LivingDead likes this.
  6. sookster54

    sookster54 Well-Known Member

    First you need to know what S-OFF is, if you don't, then you don't want to bother. I personally prefer to stay S-ON.
    LivingDead likes this.
  7. LivingDead

    LivingDead Member

    Thanks all, I will retry when back from work.

    The problem is in the menu file of unrEVOked3 the "Disable Security on Phone" item is set by default. This is not the same as S-OFF and S-ON ?!

    I mixed it up...

    Regards
  8. LivingDead

    LivingDead Member

    In fact, S-ON is an additional security to not be able to write on /system.
    Is it correct ?
    Or I loose a bigger concept?

    Regards
  9. sookster54

    sookster54 Well-Known Member

    S-OFF allows you to write to system yes, but also allows you to change the partition table (you see those Nexus One, Oxygen & Cyanogen tables). I flash different roms from time to time so I prefer S-ON so I don't have to deal with fragmentation of different setups, but there's more and more data++ roms popping up.
    LivingDead likes this.
  10. LivingDead

    LivingDead Member

    In fact I've just tried with clockworkmod from MoDaCo r2 at work with my DHD.
    The power button works for selection that's why I did the same with the one
    from unrevoked...
    Little trap!
    I will check tonight

    Regards
  11. GingaB

    GingaB Well-Known Member

    LivingDead likes this.
  12. SUroot

    SUroot Well-Known Member Developer

    We don't really need to be discussing s-off yet as the op may not even need it.

    Let's check everything is working after the root process and revisit s-off when and if needed
    LivingDead likes this.
  13. LivingDead

    LivingDead Member

    Hello; this is madnesssssssssssssssssssssssssssssssssss!

    It works.

    I was dumb to mix up MoDaCo clockworkmod (the first I knew) GUI use with unrEVOked. And before I S-OFF with MoDaCo my DHD.

    So, I factory reset to start over and see if the 'failed to get root' still appears as adviced before in faq.

    I will then install cyanogen 7 zip ROM.

    Thanks to all!
    Regards
  14. LivingDead

    LivingDead Member

    Ok everything is ok after the factory reset. I get "Done instead of "failed to get root..."

    And Cyanogen 7 looks pretty!

    One more time thanks all folks!

    Regards

Share This Page