HTC Desire - SMS app default setting


Last Updated:

  1. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Out of curiosity could anyone with a Desire let me know if their SMS app settings are the same as mine?

    Unbranded Desire on the Orange network.

    In 'Manage Applications' if I look at the stock HTC SMS app (Messages) the 'Launch by default' section is greyed out and says 'No defaults set'.

    Same thing when I look at the 'Application info' for Handcent.

    The problem this is causing me is that I can't set a 'default' SMS app in the GOTO lock screen app. A pop up should launch in the GOTO app asking me to set a default but it doesn't and so I can only use the stock SMS app with the GOTO lockscreen.

    Spoke to the developer about it and he thinks it's an issue specific to the Desire so out of curiosity I'm keen to know if other Desires have the same default settings as mine mentioned above.

    Any info would be cool.

    Cheers!
     

    Advertisement
  2. hanimal

    hanimal Member

    Joined:
    Jun 20, 2010
    Messages:
    16
    Likes Received:
    1
    mine is greyed out as well.. thats as far as i can help you as i dont use no other message apps.
     
  3. Archphoto

    Archphoto Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    94
    Likes Received:
    8
    Mine also states "No defaults set".

    I have tried Handcent and I remember having to change the default setting so that only Handcent would alert me to messages and be my default.

    Don't have installed anymore - I'm happy with the stock HTC messages, so I can't check any further for for you either.
     
  4. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Nice one, thanks for taking the time to check.

    :cool:
     
  5. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Anyone else? Just need a couple more people to let me know so I can get a rough average of how many Desire users have the same settings as me.
     
  6. Inno

    Inno Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    157
    Likes Received:
    13
    Messages app says No defaults set, but Handcent is set as default app, with an option to clear defaults.
     
  7. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Interesting. This is how I need mine to be set but no matter what I do I can't get Handcent to show as being set as default.

    If anyone has any ideas as to how I get Handcent to show this setting I'd be very greatful.
     
  8. Inno

    Inno Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    157
    Likes Received:
    13
    When I started using Handcent, I got the pop up window asking me which app to use, and just checked the always use this option for Handcent. Dunno if that helps or not, sorry!
     
  9. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    I never got that pop up, at least I can't remember seeing it. I'll try a fresh install of Handcent, I've done this a couple of times already but used the back up file on my SD card to install via Astro. I'll delete everything and download a fresh from the market.
     
  10. Inno

    Inno Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    157
    Likes Received:
    13
    Hopefully it'll work out this time then!
     
  11. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Nope, didn't do anything this time either! :eek:

    No pop up asking me which SMS app I want to use as default.

    It's not the end of the world but it is a bit annoying knowing that other users have had this option and yet I don't seem to be getting any joy. Also means for the time being I can't set Handcent as the default SMS app for the GOTO lockscreen.
     
  12. Inno

    Inno Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    157
    Likes Received:
    13
    Gah! Hopefully someone with more knowledge might be able to help, I'm an end user of very little brain :)
     
  13. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    No probs, thanks for helping all the same. :)
     
  14. psyxologos

    psyxologos Well-Known Member

    Joined:
    Jul 8, 2010
    Messages:
    237
    Likes Received:
    20
    Home settings>Applications>manage applications

    Just did mine!
     
  15. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    And what did it say? Was the 'Set Default' greyed out? Or was the stock app set as default and allowed you to alter the settings?
     
  16. psyxologos

    psyxologos Well-Known Member

    Joined:
    Jul 8, 2010
    Messages:
    237
    Likes Received:
    20
    No, it was not greyed out. i could choose whichever I wanted. I chose Handcent for now.
     
  17. Mushhushshu

    Mushhushshu Well-Known Member

    Joined:
    Jun 13, 2010
    Messages:
    119
    Likes Received:
    24
    Try going into phone/people, long press contact, click "send text message".

    BAM!

    Well it worked for me anyway.
     
    scooby_r likes this.
  18. Rotor

    Rotor Well-Known Member This Topic's Starter

    Joined:
    May 1, 2010
    Messages:
    97
    Likes Received:
    16
    Nice one! It woked for me too. First time I've had the pop up asking me to set default SMS.

    Thanks a million!
     
  19. scooby-bloo

    scooby-bloo New Member

    Joined:
    Jul 4, 2010
    Messages:
    2
    Likes Received:
    0
    What I just done as mine was greyed out too was to go to the home page where I had the standard messages app on that page, delete that to the rubbish bin by dragging it and then added the handcent app by going to the + sign, app, find the handcent in the list, select that and it just replaced it, seemed to work for me :D
     

Share This Page

Loading...