1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

HTC Desire - USB Device not reconized errorSupport

Last Updated:

  1. nekromantik

    nekromantik Well-Known Member

    Hello people
    My Desire was connecting fine to my PC yesterday and I could access the SD card but now when I try it says device not recognized. I tried reinstallin HTC sync and driver but same problem. Im on Windows 7 64bit.

  2. Dromineer

    Dromineer Active Member

    Usually the first step you should do is go to Device Manager, via the Control Panel, and click on Universal Serial Bus controller, you should see something there (a yellow icon). Just double click it and you will see a window. Try following the suggestion in that Window.

    If that doesnt work shut down your computer, and unplug the PC from the power outlet, unplug the USB, and if you are on a laptop, removing the battery. Give it some time and then reconnect the power suppy, etc, and power up.

    Fingers crossed
  3. nekromantik

    nekromantik Well-Known Member

    It just says cant install driver even tho I had installed and reinstalled. Will try the shut down and power outlet thing and let you know,
  4. b0ng0

    b0ng0 Well-Known Member

    Make sure you don't have another USB device (apart from keyboard, mouse) plugged in at the same time - I have found that on Windows 7 if I plug my Desire and iPod in at the same time, whichever is plugged in second does not work properly. Must be a driver clash.
  5. nekromantik

    nekromantik Well-Known Member

    Nope no other devices connected and after I left PC off and unplugged all night im still getting that error.

    This sucks, I love the fone and its only 2 days old and I got a problem ha ha
  6. brad-short

    brad-short Well-Known Member

    I also have this error. Am certainly not a PC novice. Have tried installing the HTC Sync app several times to no avail. . . will keep looking.
  7. dannymccann

    dannymccann Member

    I had this same problem. I solved it by only using the same USB port on my computer as I used the first time I linked the phone to the PC :)
  8. brad-short

    brad-short Well-Known Member

    Solved. It appears that i had managed to get a conflict with another USB devise i was using for Readyboost.

    I right clicked Computer, Manage and selected Device Manager and selected Universal Serial Bus controllers

    Find the Device with the exclamation mark on it and right click and uninstall.

    Remove any USB Pens from the PC and disconnect the Phone.

    Restarted PC then moved the USB for the phone to a new USB port, selected disk drive and it worked!

    Then i put in USBkey, it reassigned a letter correctly and hey presto i can browse my phone.

    Hope this helps.
  9. mikeyc_123

    mikeyc_123 Member

    I have this same issue.. but with Vista.. I dont have an exclamation marks next to the usb devices... really annoying as the phone does not come with any decent sounds for a message tone so I want my collection transfered over. Any other ideas guys?


  10. danny2001k

    danny2001k Member

    any updates on these? Sometimes it works sometimes it doesnt ...

    My brother has a Nokia 5800 and we are using the same data cable ... only works sometimes have no idea why... Help.
  11. youre1m

    youre1m New Member

    FIX For Data Is Invalid Error win2K / winXP

    When I attempted the driver install using the HTC Sync 2.0.33 drivers for my Desire I was getting a message that the data was invalid and the driver failed to install (XP SP3). I followed the instructions to change the security permissions on certain registry keys (much safer than deleting keys as per some other fixes I found). It worked, there were several device installations so I had to keep going back to the registry and finding the next device but after about 5 devices it worked fine and I can sync my phone or browse the SD card or install apps via HTC sync. The link talks about PCI devices so where it says "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\PCI " you should go to USB rather than PCI. I also had to do this fix for a storage device at the end which there is another folder for. To view your device description find it in device manager and go to properties (double click) and then click the details tab.You should see the device instance ID in the registry under the appropriate section (usb, Storage etc).

    I can't see why this would be any different for Vista or windows 7, my Window 7 netbook installed the drivers without any issues but if you have the same problem I would expect the above to work for any Microsoft OS from 2000 onwards.

    As for "If that doesnt work shut down your computer, and unplug the PC from the power outlet, unplug the USB, and if you are on a laptop, removing the battery. Give it some time and then reconnect the power suppy, etc, and power up.", don't waste your time, unplugging batteries and leaving off for some time - hilarious. You need to fix your Operating system, not save on your electricity bill.
  12. anoniemouse

    anoniemouse Well-Known Member

    I got the same os as you all i did was try a different usb port & that worked.
  13. Freakz_

    Freakz_ New Member

    I noticed that when i tried to use one of my usb extension cables i gave me the same error.
    Just connecting the cable directly in to the computer solved the issue for me.
  14. william.l.west

    william.l.west New Member

    Hi have been trying to get HTCSync to recognize my Evo Shift for weeks, and finally broke down and called HTC tech support... but that just generated a lot of useless reboots and downloads of different versions of HTC Sync, and trying different USB ports. They don't seem to know why HTC Sync doesn't see HTC phones, and neither do I. Just buggy software I guess. :(
  15. Usta

    Usta Well-Known Member

    If the reactions here and HTC Customer support can't help you, then either you should try HTC Sync on another PC or indeed give up using that.

    There are other ways to sync your data. My preferred way is phone <-> Google, and PC <-> Google.
    If you insist on direct phone to PC sync, you can also try MyPhoneExplorer. It works very nicely for me. You can connect via USB or Wifi.
  16. birentamang

    birentamang New Member

    my htc desire don't show usb option anymore when connected to the computer.it happened after i unamounted my sd card once..is there any solution for this please?
  17. Usta

    Usta Well-Known Member

    When connected, can you pull down the notification area on phone? There you should see USB connectivity options.
  18. SkinJob

    SkinJob Well-Known Member

    I realize this is an old thread; but when I was not able to get HTC Sync to work recently, it is old threads like this that I relied on to get help. Unforunately, none of them worked for me!.... (and I am using the more reliable Winddows XP). I tried everything I could think of..... Including the latest and various previous versions of HTC Sync (including the Euro version that's supposed to work well with the Desire). Including going into settings and switching on all the needed options (ie. usb debugging, etc). Including installing the program on various laptops.

    Like some here that have wrestled with this issue of getting HTC Sync to communicate with their phone, I was on the verge of giving up and deciding it must be the USB cable. Somehow, the original HTC USB cable became inoperative, when one of the internal pins on the micro side broke off. I've been using a Samsung micro USB since, and having read that for some people, HTC Sync only started working when they changed the cable, that's what led me to this conclusion. But that wasn't it either...

    Turns out the solution is to have more than 15mb of free space on the internal memory chip. (14.92mb didn't do it!)
    . After ensuring that I did, HTC Sync finally synced with the phone on both computers, no problem.... I did not see anyone suggesting this solution for HTC Sync, so I am posting it in case it helps someone in the future, from throwing their phone off a bridge. Or worse, switching to the iPhone. :eek:

    Ironically, the only reason I presently needed HTC Sync to work was to create more space on the internal memory. Because as everyone now knows, Froyo's promise of fixing the stupid HTC problem of cramming most everything into the internal RAM, regardless of how big an SD card you happen to have, is nothing but a Crayola crayon band aid solution. Pure "amateur hour" at HTC headquarters. :mad: We're well into what... Gingerbread now?? And they still haven't solved this dilemna, preferring to pass the buck on to software app developers. (rant off)

    And the only reason I really needed HTC Sync, was not to use the program itself, but to get the adb shell to talk to the phone via the sync process. I used the adb commands (in another article) to get the Desire to always automatically install software to the SD card (so obviously, HTC could have built this in if they wanted to! Instead of making people spend days trying to find a hack for their phone!! :mad: -rant off again). (link: How to Install Apps to Your SD Card on Android Froyo | Gadget News)

    All that was enough to fix the internal memory issue, but unlike for some, it wasn't enough to fix GMail not syncing, pushing or updating. There too I tried everything I could find or think of. The solution for that, came from a solution here in another thread, of installing Power Controls widget, and hitting the Auto-Sync button a couple of times. This, despite the fact that I had already gone into settings, and updated the synching for Gmail and all other synching accounts on the phone (as well as refreshing the synch in the Gmail app). (link: Gmail no longer sync-ing (solution))

    Pardon the ambling rant, hope this helps. :cool:
    5ynic likes this.
  19. Qcn0xa

    Qcn0xa New Member

    I wonder if the charger plug causes these problems.. I have this problem that when i plug my phone to my PC, it's like nothing have happened.. my PC doesn't react in any way, and now after i've used the plug to charge my iPod in normal socket in wall, my PC doesn't recognize it either.. in any way.. It shows that my iPod is charging, but nothing else happens. I can find it in some place where it shows all the USB-devices plugged, but i can't do anything with it.. So i can't browse my phone or my iPod, after using the plug you use for charging in a socket.. :confused:
  20. citizenpips

    citizenpips New Member

    HTC Sensation
    1 Uninstalled Reinstalled Windows X64 bit Sensation driver setup_3.0.5579.exe many times.
    2 Copied HTC files to phone.
    3 Unpluging all USB devices from PC.
    4 Reinstalling diver - said was already using latest version but did not show as HTC device.
    5 Uninstalling all USB Root Hubs ... stopped mouse and keyboard ... had to power off/on.
    6 Reboot PC.
    7 Reboot HTC.
    8 Tried different USB ports.
    9 TopBarDragdown QuickSettings AllSettings ConnectToPC DefaultConnectionType Diskdrive.
    10 etc etc
    But still got "device not recognized" and no sync possible.

    Eventually tried a different micro HTC USB cable as someone suggested ...
    Its now working !!!

    Couldn't believe it could have been USB cable since the one I was using was new off Amazon.
    The one that worked was the original HTC cable - with the HTC sticker ... would like to know what the differences are since its only wires and you wouldn't think there could be that may ways to configure it differently ... obviously not ... !!!
    Its great its now working ... but boy ... what a total waste of my time ... and many others.

    Signed up to post this since I really appreciate all those who have given their time up to help me and others fathom this one out ... thanks to all.
    Hope this helps someone else ... Andy.
  21. coolbareeze

    coolbareeze New Member

    I was getting the same error from the last two days even installed the HTC sync as well but same thing. Just got an Idea today to change the USB port, plugged off the keyboard and plugged in the HTD desire and its connected to the PC now.

  22. 5ynic

    5ynic New Member

    SkinJob's answer solved my issue (free up minimum 15MB in phone RAM,then connect.

    I've had this problem multiple times however, and it's been different causes.

    Current troubleshooting steps:
    1. reboot everything
    2. remove micro SD & battery, replace, go again
    3. ensure 15MB free on phone (Menu>>settings>>Applications>>Running Services, and kill some stuff).
    4. Try a different USB port (sometimes only the USB ports at the back of a PC allow mount-as-disk - different amperage).
    5. Try a different cable

Share This Page