HTC Desire Will Not Boot


  1. CJ0206

    CJ0206 Active Member

    Hi

    My brother has dropped his Desire in water and it will only enter HBoot and Fastboot but you can not move the selection or click on anything. His phone is not rooted or anything but using a computer and Fastboot his phone will boot normally by using a comandline on the computer "fastboot reboot" or "fastboot OEM boot".

    I have tried setting the newest recovery, attempt files and everything in the latest RUU through fastboot and even installed the RUU normally from the HTC Dec site.

    Any ideas how I can try to repair the phone? It works fine until it dies or the battery is removed and then it needs booting from the computer again.

    Thanks in advance
    CJ

    Advertisement
    :
  2. Tyseyh

    Tyseyh Well-Known Member

    Well, that is tricky, i was always under the impression that water damage will just bugger the electronics, not the software.. if you get me.
    What error does it say if you use the RUU?
  3. CJ0206

    CJ0206 Active Member

    No error it runs completely but the phone still only boots through Fastboot, have to put all my data and settings back so I know its worked (plus I've used it on my desire a few times before I rooted it). The software all works except the boot sequence. Surely using the reboot command shouldn't enable it to boot if the phones broken? Must be recoverable somehow...
  4. Hadron

    Hadron Well-Known Member Contributor

    All buttons work when you do boot it?

    Water damage is hardware, not software. Booting into fastboot would normally mean that the back button was stuck on, which is a possible result of water damage, but I'd think you'd notice it wasn't working after forcing a boot via fastboot. So this is an odd one.
  5. CJ0206

    CJ0206 Active Member

    The search and back button do not work, the volume and power work once booted but not in the HBoot or Fastboot menus. Could it be one of these buttons is faulty now?
  6. Hadron

    Hadron Well-Known Member Contributor

    If the back button is stuck on it could well stop other buttons working when in hboot mode.

    I'm focussing on "back" because with an undamaged desire booting while pressing the back button takes you straight to fastboot, which is what you are seeing. If in addition that key doesn't work when booted I strongly suspect that is the problem.
  7. CJ0206

    CJ0206 Active Member

    I shall take apart the phone and get back to you. Thanks for your help so far!
Loading...

Share This Page