Htc Dev unlock problems

Last Updated:

  1. HVACguy

    HVACguy Member

    Guys I just got my hands on a New Inc dated 9/2011.

    I followed ZergRush to the T and I am no longer on 2.3.4 and I am now 2.2.The issue is I have a big pink bar with LOCKED inside it.I have gone through Zerg 3 times and each time its the same and Unrevoked says internal error unable to nand.

    I have been reading for so many hours that Im spent.

    Any advice? Go back to 2.3.4 and start from there? Shoot the phone with my new AR10?

  2. sdrawkcab25

    sdrawkcab25 Well-Known Member

    If you are on 2.2, you are done with the instructions here.
    Where are you seing this bar with "locked" in it?
  3. HVACguy

    HVACguy Member

    First let me say thank you so very much for responding.

    When I pull the battery and volume down plus power to move into bootloader mode at the top above where is says S-on there is a pink box which says LOCKED inside it.

    I have tried so many different ways to remove the s-on and locked but nothing worked and not one app that requires SU from the market sees me as having SU.

    If I could I would post a pic of it but my new account will not allow me to.I swear it to you that now my A.V. is 2.2,my baseband reads,kernel is now,build is now 3.26.605.1,PRI 1.28_002 and PRL 58005.

  4. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Sounds like you followed the htcdev unlock instructions, correct? (although that shouldnt of left you with 2.2) If you did you need to complete the directions found on their website: no one has tested to see if you can still achieve s-off with the htcdev unlocked bootloader.

    What is your hboot version (seen in the same screen where you see s-on).

    Need to know every step you took to get to this point.
  5. HVACguy

    HVACguy Member

    You are correct when I went to the HTC dev site it updated my phone.After it updated my phone to another version of the same it just kept telling me I needed to update to the new version and wouldnt allow me to go any farther in the unlock process.Once it kept telling to update after I had done the update I was getting nervous that there was a problem with HTCdev site.

    My Hboot version is:1.02.0000

  6. sdrawkcab25

    sdrawkcab25 Well-Known Member

    What android version were you running when you attempted the htcdev unlock

    Ps... I'm going to move this to its own thread as your issue is unrelated to the main topic of the 2.3.4 root process thread.
  7. HVACguy

    HVACguy Member

    I was on 2.3.4 when it locked it.I then followed the Zerg method and it put me from 2.3.4 locked to 2.2 locked.

    Thank you for moving it and maybe this will result in helping others that have an odd instance such as this occur.

  8. sdrawkcab25

    sdrawkcab25 Well-Known Member

    I am assuming you don't have clockwork recovery? If you did we might have some more options.

    So you get errors when you try to run the latest unrevoked? (3.32)? What errors exactly, the best scenario would be to get root and clockwork with your current set up so you can achieve s-off.
    However, your only option may be to attempt to upgrade back to gingerbread so you can complete the unlock process. You can find the RUU here:
    Stock Images | PvilleComp's
  9. HVACguy

    HVACguy Member

    Before HTC dev updated to the 2.3.4 they had on the site there was no pink bar at the top.I had the shipped 2.3.4,the it updated to the new 2.3.4 with the HTC unlock option built into it im guessing and that is why it now states LOCKED with the option to say unlocked.
  10. HVACguy

    HVACguy Member

    I was thinking that also.Now the phone is offering the update OTA and I am guessing that will remove the lock from it.Ill do what you suggest and try the RU if you think that is the best option.

  11. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Yeah, the htcdev site changes your bootloader into a unlockable/relockable bootloader, hence the lock message at the top. When the htcdev process is completed it will say unlocked. But that process is different than achieving s-off. Even if you can't achieve s-off, if you can unlock the bootloader, you will still be able to have root access, just not the complete root access that comes with having s-off.
    HVACguy likes this.
  12. sdrawkcab25

    sdrawkcab25 Well-Known Member

    I'd try running the latest unrevoked first and see what happens. (the new hboot may prevent it from working though).

    Ideally you want to get root access without having to go back to 2.3.4
  13. scotty85

    scotty85 Guides Guide

    hmm... so you successfully downgraded firmware and the locked hboot is still standing tall.

    did you htcdev unlock before downgrading? if so,you may be able to unlock with your original unlock token. if not,then i think your best course of action is to either OTA,or run the RUU(doesnt really matter wich) to gingerbread so youll have a compatible baseband for htcdev unlock to work.

    -htcdev unlock(make sure to save your unlock token!)
    -reroot and downgrade
    -htcdev unlock again on 2.2
    -fastboot flash a recovery
    -recovery flash zuperuser
    -try flashing unrevoked "forever" patch from recovery

    hopefully being unlocked and flashing the .zip from recovery instead of running unnrevoked will turn the secure flag off.

    also i must point out that this is EXACTLY why ive strongly reccomended against htcdev unlock unless youre allready s-off. the evo3d and rezound have not found ways to downgrade the hboot or radio,its a tough bugger.

    if the above doesnt work,im afraid you may be stuck with it.:(
  14. HVACguy

    HVACguy Member

    I did just that.I used the unrevoked 3.22 and 3 with the same internal error unable to nand unlock

    I just allowed the OTA 2.3.4 update and will check tonight and holler back at you tomorrow with my findings and or results.

    I appreciate your time very much!

    See you all tomorrow
  15. scotty85

    scotty85 Guides Guide

    ok so i had a thot. 2.2 and 2.3 are both using the .92 hboot,so maybe it does make some sense that it didnt change from 1.02 to .92.

    i think maybe you may be able to dowgrade to 2.1,well just have to find a ruu/PB31IMG that uses the .77 hboot and have you downgrade to that(may need a new misc image,but that shouldnt be a deal). hopefully it will donwegrade you to the .77 hboot and matching 2.1 firmware,so all youll have to do is run the 2.2 ruu/PB31IMG to get back to unrevok-able firmware :)

    if you have an amoled incredible,this will be no big deal at all. if you have a slcd inc,it will be a lil scary,as you wont be able to see anything on the screen until you upgrade back to 2.2

    call me crazy,but i think it just may work :D
  16. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Would of been curious to see if it was successful in putting clockwork onto the phone though. With clockwork, you may have been able to flash the s-off file. Scotty's idea is also definitely plausible.
  17. HVACguy

    HVACguy Member

    I did the OTA and its back on 2.3.4 with the LOCKED still in place.HBOOT is still the same.Interesting,im learning here.
    Point me in the direction and I will run what you advice and w can give it a run to see what comes out of it.If it trashes the phone I can buy another,no biggie.

    Tell me what you feel I should do I and Ill do it then let you know if it works.
  18. HVACguy

    HVACguy Member

    I tried clock work and no dice.Said I didnt have SU.I also tried the other method in the corner of the unrevoked and the CW5 and it gave me the same thing as before with the internal error unable to nand unlock.

    This HTCdev this seems to be a pain and something to stay away from and might be my only hope at this point?
  19. sdrawkcab25

    sdrawkcab25 Well-Known Member

    ... Well guess its too late now, but if you had clockwork, you might have been able to install super user to get root access.... But anyway, it's up to you what you want to do next....

    The safest thing to do would be to just proceed with the instructions on the htcdev site to get your unlock token and unlock the bootloader, then you can install clockwork and install superuser....

    ***guinea pig option***
    Other option would be to unlock the bootloader using the htcdev instructions just like above, but after that, do the zergrush method again to get back to 2.2, then try to get clockwork back on the phone using unrevoked again and see if we can get s-off through clockwork, or we could attempt to try what Scotty suggested and get you all the way back to 2.1
    scotty85 likes this.
  20. scotty85

    scotty85 Guides Guide

    i think the 1st guinea pig option has a good chance of working. id unlock,re-downgrade,and then unlock again and see if we can flash supueruser and s-off in recovery. i am 99% sure the unlock will work on froyo with the original token. its just a question of the s-off poatch working.

    failing that we can try guinea pig option 2 :)
  21. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Then of course there is always your new AR10....
  22. scotty85

    scotty85 Guides Guide

    only option for root with my newly aquired rezound is htcdev. its certainly better than nothing,but i would much prefer an actual s-off

    some disadvantages:
    -cant flash radios
    -cant flsh hboots
    -cant go backwards in firmware with RUUs(unless you trick it with a new misc imge)
    -cant write kernels from recovery,so kernels have to be applied by flashing the the boot.img in hboot or fastboot. this also means you have to have a computer to restore a backup :mad:

    i would make every effort to get s-off. ;)
  23. HVACguy

    HVACguy Member

    OK well it will only take a few minutes and make the 4th time today so lets give it another shot.1st little piggie option is happening in 2 minutes.Ill report something back in about 10.
  24. HVACguy

    HVACguy Member

    Ok guys,I know its late and im sure you are all gone but We are now back on 2.2 and it is locked with big pink bar,S-on.

    Sorry it took so long I have a 4 month old Shepard-Pitt bull mix and he decided when I took him out for the last time tonight to take off around the front yard.The yard is 2.5 acres and he wanted someone to chase him and play and he is so fast that I had to just go back and sit on the porch and wait till he got tired of running around like a wild man.

    Anyway,we can pick this up tomorrow at some point.

    Thanks Gents
  25. HVACguy

    HVACguy Member


    I think this just might work.Lets round up the needed files and see what can be had.

    Talk with you later in the A.M.

Share This Page