Root HTC EVO Design 4G - All Carriers - Root guide

Discussion in 'Android Devices' started by Savage Shadows, Aug 23, 2012.

  1. ElensarMcLaine

    ElensarMcLaine New Member
    6

    Sep 28, 2012
    4
    2
    6
    Does a rooted boost mobile, HTC EVO Design still work with HTC Sync?
     

    Advertisement

  2. Rally 517

    Rally 517 Well-Known Member
    143

    Jul 27, 2011
    1,048
    112
    143
    michigan
  3. Savage Shadows

    Savage Shadows Well-Known Member
    68

    Jun 22, 2012
    354
    140
    68
    Male
    Phoenix, AZ
    Hey thanks Rally for responding so quickly to that. I wouldn't have even known the answer myself unless I tried it out.
     
  4. ycs5

    ycs5 Member
    16

    Jun 28, 2012
    13
    1
    16
    what happened to 2fastroms website?
     
  5. rpdrizzy

    rpdrizzy Well-Known Member
    38

    Feb 19, 2012
    92
    17
    38
    Male
    Student
    New Jersey
    The link for CWM no longer works. Fix Please :D
     
  6. mxtime

    mxtime Member
    5

    Apr 20, 2012
    7
    0
    5
    This is a great step by step guide. It is easy to follow and works great! But I am pretty sure that you will not want to install Boost updates once you have rooted your phone or it could end up like the LG Marque disaster of earlier this year.
     
  7. Savage Shadows

    Savage Shadows Well-Known Member
    68

    Jun 22, 2012
    354
    140
    68
    Male
    Phoenix, AZ
    Sorry guys, the website at which all of 2fast4u88's work is temporarily down. Cookiefrog, a partner of his in some of the work on his website, has stated the website will be back up shortly. I will muster up a link in my dropbox of an unaltered version of whatever you need, just PM me.
     
  8. maverickdt83

    maverickdt83 New Member
    5

    Oct 4, 2012
    1
    0
    5
    I had this problem too. I disconnected the usb cable then reconnected, re ran fastboot and everything worked fine.

     
  9. kman119

    kman119 New Member
    5

    Oct 5, 2012
    1
    0
    5
    hey savage shadow. do you think you can send me all the necessary files to root the htc design 4g. 2fast4u88 page is down and i have no way of obtaining the files. also did you guys ever figured out if the root works after the ics update on sprint?
     
  10. ematias

    ematias New Member
    5

    Oct 8, 2012
    1
    0
    5
    Male
    Does the root work with Ice cream sandwich for evo design for sprint?
     
  11. rhino323

    rhino323 Member
    25

    Sep 25, 2012
    7
    0
    25
    Thanks Savage Shadows. For the great info. I was able to root my phone, but can't go any further. can't install clockwork.
     
  12. HuyHoof404

    HuyHoof404 New Member
    5

    Oct 11, 2012
    1
    0
    5
    HELP.

    CID incorrect!
    Update fail!
    Press <Power> to reboot.

    I am on step root. with PH44IMG.ZIP.

    Thanks
     
  13. pancho32392

    pancho32392 Well-Known Member
    38

    May 3, 2012
    395
    13
    38
    can some one help me i get stuck at step 5 on unlocking the bootloader
     
  14. braxton355

    braxton355 Well-Known Member
    43

    Sep 24, 2012
    406
    29
    43
    I was trying to use 2fast kingdom utility , and every time I do a command such as pull token it always says something about cannot find specific path. On everything I do. Can someone explain that for me ?
     
  15. richardjas4444

    richardjas4444 New Member
    5

    Oct 16, 2012
    4
    0
    5
    i have the evo design sprint....i unlocked it! do i go straight to cwm or what? lol. and if so do i still delete the ph44img?
     
  16. Savage Shadows

    Savage Shadows Well-Known Member
    68

    Jun 22, 2012
    354
    140
    68
    Male
    Phoenix, AZ
    richardjas4444 - If you want to flash custom ROMs and create back ups of your phone, go straight to CWM.

    braxton355 - I still have not gotten around to messing around with the utility from 2fast. If you're having issues with it, and have made sure you followed any directions to the letter, try unlocking through the HTC site.

    pancho32392 - Don't have time to look through the HTC site right now, just quickly answering a few questions. What is the main gist of step 5?
     
  17. richardjas4444

    richardjas4444 New Member
    5

    Oct 16, 2012
    4
    0
    5
    my phone is sprint....can i go ahead and use the chapter where it say for boost mobile only if i only want to root my phone?
     
  18. richardjas4444

    richardjas4444 New Member
    5

    Oct 16, 2012
    4
    0
    5
    my phone is sprint....can i go ahead and use the chapter where it say for boost mobile only if i only want to root my phone?
     
  19. aloharover

    aloharover New Member
    5

    Sep 29, 2011
    1
    0
    5
    I have both zip files on my phone.
    I repower and go to recovery and am in CWM
    I have done all the wipe stuff.
    I select "install zip from sdcard"
    Select "choose zip from sd"
    scroll to the zip file, select it, hit the power button.
    Screen says installing update...

    then

    installation aborted.

    I am stumped.
     
  20. Savage Shadows

    Savage Shadows Well-Known Member
    68

    Jun 22, 2012
    354
    140
    68
    Male
    Phoenix, AZ
    richardjas4444 - I sent you a pm

    aloharover - any chance you re-locked your bootloader after flashing ClockWorkMod? I don't know if it affects it, but that could be your problem. Really not sure. I'm not a dev, so I might suggest either presenting your issue in the appropriate section on the 2fastroms.com webstie (on that site our device is referred to as the Hero S), or sending a message to 2fast4u88.
     
  21. richardjas4444

    richardjas4444 New Member
    5

    Oct 16, 2012
    4
    0
    5
    i keep getting an error that says...incorrect cid update fail!! my phone is unlocked...at least thats what it says!?!? anyone know why?
     
  22. Kariasmike

    Kariasmike New Member
    5

    Oct 19, 2012
    2
    0
    5
    So I'm running version 3.14.651.0.710RD, sprint, ICS 4.0.3. I unlocked the boot loader - however none of the other steps mentioned appear to work.
     
  23. Savage Shadows

    Savage Shadows Well-Known Member
    68

    Jun 22, 2012
    354
    140
    68
    Male
    Phoenix, AZ
    I'll try to help you guys out with your issues in a minute. Just wanted to update that I'll probably not be as active in this device's forums for a while. Phone got stolen yesterday, and I was the phone rooting dumbass who decided they wouldn't be paying for protection on their $300 phone. Haven't lost or broken a phone in over five years, guess I was just due to get that bad luck again.
     
  24. Kariasmike

    Kariasmike New Member
    5

    Oct 19, 2012
    2
    0
    5
    That's very unfortunate to hear man. Yeah keep me and the others with questions posted I'm very interested in rooting my phone. I like what you guys are all trying to do here!
     
  25. braxton355

    braxton355 Well-Known Member
    43

    Sep 24, 2012
    406
    29
    43
    I have tried that guide the only problem I have is after downloading the SDK files needed (SDK tools, etc) there where two I believe. And I have searched high and low trying to find them because I need three other files from those (fastboot, etc). But I can't find the two I downloaded on SDK manager it says there installed but doesn't let me browse the downloaded files. I tried for three or so days and gave up and tried your 2fast tool but that always says "couldn't find specific path".
     

Share This Page

Loading...