HTC EVO Shift 4G Root Help?


  1. montero23

    montero23 Active Member

    ok im trying to root my evo shift on 2.3.4, i looked at a few vids and they say i have downgrade to 2.2 for S-Off, i tryed downgrading with the RUU but it gets stuck on 13% Checking Headers. so i unplugged it and tryed and still stuck, but i did manage to unlock the bootloard. since i couldnt try any of that i tryed these steps from XDA, ihave everything but i got stuck on step 6 placing the file in platform tools, i didnt understand anything, please help!! Also is there a 2.3.5 for the shift bcuz my regular Evo has it just wondering? 1 more thing, when im using internet pass through, it looses connection, and i have to keep refreshing everytime, even on the regular evo it does the same, and i have good connection, this all started a few days ago


    1) Install HTC Sync and Android SDK with platform tools so you have adb!

    Android SDK available HERE:
    Android SDK | Android Developers

    INSTALL PLATFORM-TOOLS ONLY!


    HTC Sync available HERE (only needed on windows):
    http://dl4.htc.com/setup_3.0.5557.exe

    DOWNLOAD THE Shift rootkit here EVERYONE NEEDS THIS:

    Goo-inside.me Downloads - Downloading shift-rootkit.rar

    2) Check your phone's Android version. If 2.2 skip to rooting Android 2.2 section. If 2.3.4 continue to the next step. If 2.3.3 skip to 2.3.3 section.

    WARNING: THIS VOIDS YOUR WARRANTY AND YOU WILL LOSE ALL DATA IN UNLOCKING THE BOOTLOADER

    ===============================================

    ROOTING ANDROID 2.3.4:


    3) Be running stock 2.3.4 latest OTA update from HTC

    4) Register at htcdev.com

    5) Unlock the bootloader by choosing HTC Evo 3D for Sprint and follow instructions

    6) Once you have unlocked bootloader flash clockwork recovery by downloading the following file:

    http://download.clockworkmod.com/rec...2.0-speedy.img

    Place file in adb "platform-tools" folder.

    From the adb folder run "fastboot flash recovery recovery-clockwork-5.0.2.0-speedy.img"

    7) adb reboot recovery

    8) You will see the beautiful clockwork recovery screen.

    9) Goto mounts/storage, mount usb storage

    10) Download su from the following location:

    http://downloads.androidsu.com/super...ghi-signed.zip

    11) Go back, install zip from sdcard, choose the superuser zip.

    12) Reboot, open market, search for super user and install it.

    13) Open superuser app go to preferences and choose update su binary.

    14) Download terminal emulator and run "su" to test if you have root. $ should turn to #.

    15) Place misc.img and PG06IMG.zip on sdcard using windows explorer or "adb push /sdcard/file.xxx" via usb. Again, please note that PG06IMG.zip is case sensitive.

    16) Unplug the phone from USB.

    17) Remove the battery cover and flash misc.img using the following command via terminal emulator or you can use adb shell with the phone hooked up via USB. Personally I feel more comfortable running this from terminal emulator on the phone:

    Code:
    dd if=/sdcard/misc.img of=/dev/block/mmcblk0p17
    and press enter.

    18) REMOVE THE BATTERY WITHOUT SHUTTING DOWN THE PHONE as soon as you run the misc.img command. DO NOT SHUTDOWN OR POWER OFF.

    19) Hold volume down button and hold the power button for one second and release while still holding the volume down button.

    Phone should find PG06IMG.zip and RUU to Android 2.2. From here you can flash engineering s-off bootloader. For instructions on flashing the engineering s-off bootloader skip to the rooting Android 2.2 section.


    Again before you ask, make sure you have a freshly formatted FAT32 microSD card. If your phone can't find the zip, you are doing something wrong, your SD card isn't formatted in FAT32, you aren't using CWM, or you need to try another SD card.

    You will have to manually upgrade to the new cellular radio after obtaining s-off and downgrading to Froyo again.

    Advertisement
    :
    prboy1969 and unbrkshft like this.
  2. gzetski

    gzetski Member

    I just spent 3 days researching this issue, finally got it fixed. Same thing that happened to you. I am assuming your bootloader is unlocked but S-ON.

    Tings you will need:

    Android SDK
    HTC Drivers
    7-zip
    RUU_Speedy_Sprint_WWE_1.17.651.1_Radio_1.07.00.1129_NV_SPCS_1.52_1103_release_160079_signed.exe

    On your computer, search for ROM.ZIP. Include system locations and hidden files.

    Delete any instances of it that you may find.

    Take the SD card out of the phone.

    Put your Shift into fastboot (vol/down + power)

    Run the RUU, let it get stuck.

    On your computer, run a search for ROM.ZIP while the RUU is running. Its gonna show up in some temp folder.

    Copy it to your desktop.

    Use 7zip to extract it (for whatever reasons Windows can't extract it).

    Open the extracted rom.zip folder.

    Copy all files and place them in your SDKs platform tools folder.

    Shut down the RUU, reboot the phone into recovery (vol/down + power).

    Run CMD and change directories to your platform tools folder.

    Type the command "fastboot flash recovery recovery.img" (without the quotes) - this gets rid of any custom recovery like Clockwork, etc.

    Reboot the phone into recovery again, you should have a triangle with an ! next to it on black background.

    Go back to CMD and your platform tools, and start flashing the following:

    fastboot flash boot boot.img
    fastboot flash dzdata dzdata.img
    fastboot flash partition partition.img
    fastboot flash radio radio.img
    fastboot flash recovery recovery.img
    fastboot flash system system.img

    Reboot the phone.

    After 30 seconds of white HTC screen, your phone should boot up fine and you will be in Android 2.2.

    Let me know if it worked out for you, I just fixed mine less than an hour before writing this up.

    Also, if anyone out there sees anything redundant, or can help me clean this process up a bit, I welcome your input.
    prboy1969, unbrkshft and 330D like this.
  3. montero23

    montero23 Active Member

    sounds legit, but wen i open the cmd to platform tools or to flash the recovery, it doesnt recognize or something with the Path
  4. gzetski

    gzetski Member

    move your patform tools folder to C: using windows

    then when you run cmd, you should be able to get in by typing cd c:\platform-tools
  5. montero23

    montero23 Active Member

    holy shit thanks bro, the cmd came thru, i was testing it with out the phone connected and it worked, i just have to find the rom.zip file u said for i could downgrade to 2.2 and S-Off, then i will upgrade back to 2.3.4 and root again
  6. unbrkshft

    unbrkshft Member

    I am having the exact same issue but am not able to locate the rom.zip file. I am searching for it in Windows Explorer while RUU is running (hangs at 13%), but nothing comes up. Any advice as to where to look?

    Thanks in advance!

    Nevermind -- looks like I just had to do the search within my %appdata% folder. Hopefully this helps someone else down the line. Back to trying to unbrick my shift...
  7. unbrkshft

    unbrkshft Member

    I made it to 2.2 -- thank you gzetski and montero23!
  8. montero23

    montero23 Active Member

    if u want to find the rom.zip, u have to open the RUU and let it run, once open, dont press the next button when u are on where the pictue of the evo is, go to start run and type %temp% it might be the first file, with a bunch of numbers, keep clicking till u see the rom.zip take it and copy it everything in the file, do it once cuz the file keep changing everytime u open the ruu....but anyways if u on 2.3.4 why dont u just root, mine is rooted perm, and i havent had no problem, running Warm Synergy, and if u go to 2.2 to do S-Off soon as u update S-On again not really worth it
  9. unbrkshft

    unbrkshft Member

    My end goal is to get Cyanogenmod on this phone. I'm working on rooting 2.2 at the moment, with no luck following the instructions on the Cyanogenmod wiki (everything works until step 10 of temp root) or ShiftRR (I get an error message telling me not to turn off my phone). Any thoughts on what I should do? Sorry if this is getting too off topic.
  10. montero23

    montero23 Active Member

    go here for the 2.2 root and temp root, but u could get Cyanogen on 2.3.4 just saying
    http://forum.xda-developers.com/showthread.php?t=1357157
  11. unbrkshft

    unbrkshft Member

    Thanks. I'm still unable to root 2.2 or get S-Off. I think a big issue is that my HBOOT is at version 0.99. Any ideas of how I can get to 0.93? I'm currently running Android 2.2.
  12. montero23

    montero23 Active Member

    lol, im telling u use the link i gave u, update to 2.3.4 and then reroot and u will be able to go to 2.2 and perm root it would be easier thats what i did, now im just having trouble instaling the ICS rom it keeps getting stuck in the HTC screen idk why but my synergy is good
  13. crump

    crump Well-Known Member

    You are on Android 2.2 with the .99 Hboot? Did you just flash a 2.2 ROM? If you RUU'ed down to froyo, your Hboot should be .93..
    prboy1969 likes this.
  14. unbrkshft

    unbrkshft Member

    I tried updating the phone to 2.3.4 via the system updates. The install hung (froze at the screen with the yellow exclamation in the triangle). I'm thinking that it did not take because the phone is rooted in some form. How did you get 2.3.4 back?
  15. unbrkshft

    unbrkshft Member

    RUU froze for me, so I had to manually downgrade using gzetski's method above. It brought me to 2.2 but left the hboot at 0.99. I tried running RUU again just now, but it hung again at 13% (I left it along for about 40 minutes just to make sure)... I have the image file for the 0.93 hboot on my hard drive, is there anyway to manually flash it?
  16. montero23

    montero23 Active Member

    do it again, theres more then 1 download on the OTA theres like 3 or 2
  17. gzetski

    gzetski Member

    Yeah, he prolly is on the .99 radio, so am I. My method is for a brick fix, not a legit downgrade. The phone needs to be RUU to the latest version, then rerooted. There is a radio/rom version mismatch here, hence the BS to get anything working right.
  18. crump

    crump Well-Known Member

    I would agree, your guide is more for brick situation. It's definitely not typical to have to manually flash every partition...And IMO should be a last resort.

    AFAIK You would have to somehow exploit the .99 Hboot before you would be able to overide it. Can you run the latest 2.3.4 or 2.3.3 RUU? If not I would suggest trying to take the updates all the way up to 2.3.4. Once you have everything back in order root following the guide someone posted earlier in this thread.

    Edit: I missed where you said you've already tried taking the OTA. Is your bootloader unlocked via the HTC tool?
    prboy1969 likes this.
  19. gzetski

    gzetski Member

  20. unbrkshft

    unbrkshft Member

    Yes, the bootloader is unlocked via the HTC tool. Last night this phone was in a soft brick situation, gzetski's method thankfully got me out of it. I appreciate any help you can offer.
  21. gzetski

    gzetski Member

    If you're gonna unlock bootloaders, use HTCdev.com, less shady IMHO.
  22. unbrkshft

    unbrkshft Member

    I apologize, I did in fact use the HTCdev.com method.
  23. gzetski

    gzetski Member

    I have 6 other warranties to void, so no time right now to mess with the Shift

    However, the first one of you guys to get perm root and S-OFF from this will get a cookie :)

    I don't mean to sound redundant, but follow this once you get to 2.3.4. I think this is the only way to go with manually rebuilt libraries and who knows what radios... Update to the latest and the greatest, then downgrade from there.
    [VIDEO GUIDE] FULL S-OFF ROOT for Evo SHIFT. Froyo (2.2) + Gingerbread (2.3.3+2.3.4) - xda-developers
  24. unbrkshft

    unbrkshft Member

    Is your thought that once we have this file available, we just run the exe file and hope for the best, or should we do it manually as we did with 2.2?
  25. gzetski

    gzetski Member

    Pretty much, yes. File is up, try it.
Loading...

Share This Page