HTC EVO will not turn onSupport


Last Updated:

  1. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    Anyone else having a problem with not being able to turn the Evo on after it's on standby?

    I have to take the battery out and put it back in to get it working again.
     

    Advertisement
  2. Bek

    Bek Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    908
    Likes Received:
    485
    Nope - can you provide any further detail as to what might have been running on in the background? Was your battery close to being dead?
     
  3. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    No, the battery was never close to being dead. Actually, the same problem happened when the phone was plugged in. When it was plugged in the yellow light was still on, indicating that was fully charged, and I had to remove the battery and the power plug. I then hit the power button and it restarted fine.

    This problem has happened at least twice daily for the past 5 days.
     
  4. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    Also, nothing out of the ordinary was running in the background.
     
  5. Bek

    Bek Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    908
    Likes Received:
    485
    Puzzling - I haven't had any similar experience.

    Have you tried calling the Google IO Tech line, to see what they have to say? Seems to be advanced tech support, not some script reading flunkie, so they may be able to help?
     
  6. Dutch54

    Dutch54 Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    110
    Likes Received:
    6
    Excuse me for jumping in here...the Google IO Tech line will answer questions, even the most basic, like how do I input the phone number when I hit the Internet icon when no keypad pops up?..I searched for that, couldnt find it...I can go to Youtube and Google though

    thanx in advance for any help...im completely new to smartphones...my god this evo is badass
     
  7. MisterEd

    MisterEd Well-Known Member

    Joined:
    Apr 15, 2010
    Messages:
    773
    Likes Received:
    117
    I had the same problem the first couple times but since that time it has worked flawlessly. No idea what the problem was but it's OK now.
     
  8. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    I'm still having the same problem. Please post if you are experiencing this problem too.
     
  9. vangko05

    vangko05 New Member

    Joined:
    Jun 6, 2010
    Messages:
    1
    Likes Received:
    0
    Just got my phone the day it premiered and it did exactly what you said. It was in standby mode and at about 75% batter life. I went away for a couple hours, came back and couldn't turn it on. At least, not until I removed the battery and reinstalled it did it turn on.
     
  10. bobcatseaweed

    bobcatseaweed Member

    Joined:
    Jun 6, 2010
    Messages:
    6
    Likes Received:
    0
    This happened to me as well. I had the phone charging and it was done..green led, so i hit the power button and nothing. I could not get it to turn on until i removed the battery and replaced it it turned on fine.
     
  11. bck9900

    bck9900 Well-Known Member

    Joined:
    May 29, 2010
    Messages:
    172
    Likes Received:
    13
    New release bugs anybody? Has anyone tried hitting the volume switch and the power button at the same time? This essentially gives advanced boot options as far as I understand.
     
  12. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    I tried rebooting by taking the battery out, putting it back in and then holding down the down volume button and the power button, and then doing the erase. Still experienced the same problem of not being able to turn the phone on after it's on standby.

    I've been experimenting... when I turn off the 4g I've had better luck. But it's still too soon to tell if this works. It sucks though... having to turn off 4g to get the phone to work properly.

    Anyone have the same problem with 4g turned off?
     
  13. denise1768

    denise1768 Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    152
    Likes Received:
    37
    Hi,

    I just experienced something weird myself. I also replied to another post with this information. My screen went blank. I plugged it into my car charger for the first time, made a call. Hung up. Then, I went to go do something and the screen just went black. I did notice that the LED light was on so i figured the power was on.

    Using the car blue tooth , I was able to place a call so I believe only the screen went dead. After taking out the battery, it was back to normal.
     
  14. teky

    teky Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    433
    Likes Received:
    120
    You folks may want to try doing a hard reset if nothing else works. It will restore the phone to factory defaults (all your apps and settings go away), but I seen it fix a lot of weird issues reported here.
     
  15. Jacks' Frank

    Jacks' Frank Member This Topic's Starter

    Joined:
    Jun 1, 2010
    Messages:
    10
    Likes Received:
    0
    I think it definitely has something to do with 4G. I had 4G off for almost two days now and the phone did not freeze. With 4G on, my phone freezes twice a day. I hit the on button and nothing happens and then have to take the battery out and restart the phone. I had to make a call the other day when this happened and had to wait a few minutes for the phone to restart just to place a call. This problem is very disappointing.

    I'm thinking about returning this phone.
     
  16. NYCJAV

    NYCJAV New Member

    Joined:
    Jun 11, 2010
    Messages:
    1
    Likes Received:
    0
    Any updates??? I just got my phone earlier this week and then when I woke up this morning I am unable to turn on my EVO....:mad:
     
  17. swagner53

    swagner53 Well-Known Member

    Joined:
    Dec 4, 2009
    Messages:
    291
    Likes Received:
    62
    I have had this happen twice so far in my first 3 days. I have 4g off as I am not in a 4g area. I am rooted via unrevoked. the screen would not come on but after looking more closely the back light on the screen was on ... the screen was just black.
     
  18. PrO1210

    PrO1210 Well-Known Member

    Joined:
    Jan 24, 2010
    Messages:
    94
    Likes Received:
    2
    I do not have an Evo,yet, but I've had this same exact problem with my old HTC diamond. I unfortunately don't remember the fix but maybe you'll find it in a forum about the diamond... I'll look as should you.
     
  19. erkme73

    erkme73 Active Member

    Joined:
    Jun 11, 2010
    Messages:
    26
    Likes Received:
    5
    Got my Evo on Tuesday (6/8/10) and right away started experiencing lock ups - at least once per day.

    The green message notification LED continues to blink, and the phone will ring if called. But the screen is dark. Only fix is to pull battery.

    I'm in FL and there is no 4G, so I've never had mine on.

    It does seem to be related to charging - as I've noticed it's dark when I take it off the charger (PC or wall).

    Stumped.

    On the upside, calls do come through.
     
  20. denise1768

    denise1768 Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    152
    Likes Received:
    37
    Was yours on the car charger or usb? Mine happened with the car.
     
  21. Painkillaz

    Painkillaz Well-Known Member

    Joined:
    May 8, 2010
    Messages:
    190
    Likes Received:
    15
    I have a problem similar to that...i will try to explain it to the best of my ability:

    June 4th 6AM:
    Radio Shack employee activating my Evo, turns it off to do a reset, will not turn back on, no charging light when plugged in, tried taking out battery few times and still would not turn on or charge. There was also a sprint employee there both were stumped so they called tech support, while on hold with tech support the RS employee tried to pull the battery and put it back in and it finally turned on...shouldve just gotten a different handset then...

    From then to 6/10/2010:
    Never turned it off, everything working perfectly...never dropped the phone, mishandled, got any water on...basically Perfect in box condition, also bought a screen protector so no scratches or anything...

    Today 6/11/2010:
    Decided to turn it off just 'cuz, same issue occurred again as when I first got the phone, after about 10 minutes of taking out the battery/putting it back in again it Finally turned on...got past the "HTC Evo 4g" screen, played the Sprint video....but then got stuck in an infinite loop of playing the Sprint video...kept doing that no matter how many times i did a battery pull and replace...finally called Sprint and did a hard reset...finally fixed the looping issue...I called the Radio Shack I originally purchased to see if I could get my phone replaced as defective...the person I talked to said she would call her supervisor and find out the procedure for that and then call me back...

    and that is where i am now

    anybody have this issue? I'm hoping RS will just replace it
     
  22. erkme73

    erkme73 Active Member

    Joined:
    Jun 11, 2010
    Messages:
    26
    Likes Received:
    5

    I only have the 120V wall charger to USB cable that came with the phone. Have not accessorized yet :)

    Went happened today, it was while on the computer (usb charge only).

    Maybe it's that effing micro usb connector? It just feels so cheap - like it could go in upside down, or at a very bad angle. It's not nearly as nice as the original mini USB. Why on earth did they change? 90% of my personal electronics runs on mini. Now I have order a bunch of new cables, and worry about compatibility... Sorry for the rant.
     
  23. ddegennaro

    ddegennaro New Member

    Joined:
    Jun 12, 2010
    Messages:
    1
    Likes Received:
    0
    I got my EVO on June 4th and haven't had any problems until today. I was shopping with my grandson and let him access the internet to see if he could find any information about a fire that was blocking traffic in our area. After he gave me the phone back, I put it in my purse. A while later I got my phone out to try to use it and the screen was dark. I tried repeatedly to turn it on - to no avail. My only thought was that maybe he had left an app running that drained the battery. I plugged the phone in on the car charger but I could never get the screen to 'wake up'. When I got home I put the phone on the house charger. Later I went back and the phone had a green light showing it was charged. I realized then that it wasn't that the battery was dead. I received a phone call but was unable to answer it because the screen was blank. I'm glad I googled the problem and found this forum. I am going to take the battery out and try to restart. My cell is my only phone so I can't call Sprint for help and their chat function on their website is 'unavailable at this time'. How disappointing. I sure didn't expect problems this early on. :(
     
  24. Mike Fitz

    Mike Fitz Member

    Joined:
    Jun 12, 2010
    Messages:
    12
    Likes Received:
    0
    Have you tried holding the power button down for a couple seconds to power it on? Mine works if I do that, but if I just press and let up it nothing happens. Doesn't explain why it powered off in the first place though.
     
  25. tarkin86

    tarkin86 Member

    Joined:
    May 26, 2010
    Messages:
    5
    Likes Received:
    0
    I had the same problem, I uninstalled the htc battery widgit and it has been working great since then.
     

Share This Page

Loading...