HTC HERO, problems with wifi, WPA2 an AESSupport


  1. Perfk

    Perfk New Member

    Hey all. Just bought my new HTC hero, and loving it :)

    But i cant connect to my home wifi, heres the problem

    Its a hidden network, WPA2 Personal, and AES. but on my phone, i cant choose AES. does anyone know how i can fix this? would love to connect to my home wifi.

    OH and, sorry. i couldnt find a better place to put this. if this is wrong, please move it to the right supforum.

    Advertisement
    :
  2. briankwest

    briankwest Member

  3. briankwest

    briankwest Member

    Also I confirmed this bug is in the Hero kernel source HTC released yesterday.

    /b
  4. headcase

    headcase Active Member

    Try turning the SSID on the router from hidden to visible, and then do the actual set up on the phone. I'm using a router with WPA2 and AES (visible), and when I set up the connection on my Hero, the phone recognized the wireless settings just fine with this configuration.

    Then try turning your WiFi back to hidden, if you really want to (btw, that has nothing to do with increased security -- I work at Cisco, and our engineers have long joked about how hiding your SSID has no real impact on slowing down hackers).
  5. marctronixx

    marctronixx Moderator Moderator

    head case is right... just allow only certain MAC addresses on your system and that helps more than hiding your SSID.

    also try "open" on your router. im using an 610N router mixed mode and have no issues with the PRO2 or the Hero...
  6. HTCDroid

    HTCDroid Member

    It won't connect to my Belkin N router no matter what settings I use, works on some other networks I've tried. I'm disappointed but at least I have good signal in my apartment so it's not a huge issue.
  7. briankwest

    briankwest Member

    If you take note of the network connections you'll notice I suspect most that it doesn't work on get connections via PPPoE/PPPoA or if its cable and it won't work its the router... the issues is the busted TCP stack.

    /b
  8. marctronixx

    marctronixx Moderator Moderator

    did you disable all security and have it set to "open" to see if it will sniff and connect that way?

  9. briankwest

    briankwest Member

    Doesn't matter if its wide open or not the HTC Hero on Sprint is BUSTED badly. Stop trying and start yelling at HTC and Sprint... I have provided proof to both its busted and even spoke with the ceo's team at sprint (dan@) and they are oblivious to what the hell is going on nobody gets it. Their is a slim chance it will connect and if it does some websites will not work due to the busted TCP stack.

    blah!

    /b
  10. Dylan

    Dylan Member

    False. I turned the security off on my home wifi (WPA/AES) and the Hero connects and uses it just fine. It's a problem with the WPA/AES encryption, not wifi in general.
  11. briankwest

    briankwest Member

    Which router do you have?

    /b
  12. Dylan

    Dylan Member

  13. marctronixx

    marctronixx Moderator Moderator

    i have a linksys wrt 610N router running N and G. i use WEP but only allow mac addresses on the network. hero works without a hitch...
  14. nyx528

    nyx528 Active Member

    So I am unable to connect to my wifi as well. I've had problems in the past, but it usually resolved itself once I remembered the full wep key. With my Hero I can't even connect to open wifi networks. Is there a setting that I'm missing? I tried to set my home wifi to open, but I don't know how to do that. Any help would be greatly appreciated.
  15. GlennT

    GlennT Member

    I had the same problem with my Belkin N router. The Hero didn't ever detect it when I tried to scan for wifi.
    I finally changed the router settings to G only and disabled mobile network to get it to detect my home wireless network. Entered the key and connected OK. Then enabled the mobile network. It now connects to the wireless automatically when I'm in range at home. I think the problem is with the Belkin "N" apparently.
  16. so1ution

    so1ution New Member

    I just figured out how to connect my hero to my linksys n-router. I had to go into the settings for the router, and then change the encryption code from WPA2 TKIP/AES to WPA2 AES. Before I did this, my hero couldn't find my network. Now it works fine. Hope this helps.
  17. dca860

    dca860 Well-Known Member

    How can it be?
    I have my Netgear WPN824v2 router set to WEP & b/g and it connects fine at 54Mb but no data seems to transfer. Unless in addition to WPA/AES encryption the WEP encryption is busted too?
  18. creglenn

    creglenn Well-Known Member

    The hero have a problem detecting certain WPA2 networks like WPA2 enterprise. It seems like a hardware thing to me seeing as I have 2.1 on my hero and the problem still exists with my router. But my Samsung moment detects it just fine.



    Sent from my HERO200 using Tapatalk
  19. sdeforke

    sdeforke Member

    I too am having wifi connectivity issues. I am rooted and on fresh 2.1.1. My router is a linksys E2000, my wifi settings are hidden ssid, wpa/wpa 2 mixed mode with a passphrase. I enter all the info on the hero but it wont connect to the network. Also, when I go back into the wifi settings on the hero, the security is set to auto, even though I change it to wpa/wpa 2 psk, it always reverts back to auto. I appreciate anyones input towards a resolution.
  20. sdeforke

    sdeforke Member

    ok, apparently it doesnt like the ssid to be hidden, when I broadcast it, it connects just fine. Hopefully the Evo will overcome this issue.
  21. Thefoodman52

    Thefoodman52 Well-Known Member

    How do you find the MAC address of the phone?

    -EDIT-

    Nevermind, found it in the settings. Didn't think to look under Hardware information. Lol.
  22. brandonpaz

    brandonpaz Well-Known Member

  23. asalus

    asalus New Member

    i have a hero and im having wifi issues. my wireless router is using pppoe connection. my hero can connect to it get an ipadress but once i start browsing the connection drops. i cant browse or use internet related apps with my home wifi. but in public hotspots i can use my wifi:(

    anyone have sloution?
  24. Finnbjerke

    Finnbjerke Member

    BElkin tell me they are "incompatible with HTC phones" I have an expensive Belkin Wireless N1 Router.. Router is wireless and Phone is useless bad combo.. NOT good enough, they dont connect, other routers work fine it seems.
  25. Finnbjerke

    Finnbjerke Member

    GOOD NEWS: Using Static IP number helped.

    HTC desire Z now connects to Belkin Wireless N and also The phone now connects to other routers like "Gigabyte Aircruiser Ultra N" Here is what Belkin Support Email wrote me:

    p { margin-bottom: 0.21cm; }----------------------------------------------------------------------------------------------------------
    Thank you for contacting Belkin Technical Support.

    I understand that you are trying to connect HTC desire smartphone via Belkin router and I will be happy to assist you with the same.

    Well, any DHCP enabled device that has the capability of taking the IP address assigned by the router will work with router with no issues.

    To isolate the issue, you can assign a Static IP on the phone in the Belkin range say 192.168.2.50 i.e:

    IP address : 192.168.2.50
    Subnet Mask: 255.255.255.0
    Default Gateway : 192.168.2.1

    Primary DNS : 4.2.2.2
    Alternate DNS : 4.2.2.1



    ----------------------------------------------------------------------------------------------------------
    How to set up static IP on your HTC phone:

    • Hit the hard menu button on your phone and then choose Settings
    • From there, browse to the Wireless controls section and then choose Wi-Fi Settings
    • Whilst in the Wi-Fi Settings section, push the hard menu button again and select Advanced
    • Press Use static IP to put a check in the box and then enter the network settings as per your own network
Loading...

Share This Page