HTC Incredible S falling apart!Support


  1. nfsmw95

    nfsmw95 Member

    Like a halfyear ago my phone got wet a little bit from the inside. The first few days it worked perfectly well but after a few days I couldn't:
    - Charge my phone on the normal way
    - Use HTC Sync
    - Or anything else that has to make contact with my micro USB input
    The weird thing is when I connect the micro USB cable with my phone and put pressure on the right spot it shows me the charging flashlight for a few seconds.
    The waterproof stickers in the inside of the phone are discolored, so the water touched the battery and all the hardware inside. But the battery works perfectly well.

    Another problem happened to me year ago when I accidentally cracked my Incredible S by droppin my it and fixed it at a phonehouse. When I got it back it worked perfectly. But lately its getting vertical and horizontal dead spots. At the beginning it wasn't a big problem but now I'm having a hard time unlockin my phone.. When i need to type something I need to turn it (when it is already 90 degrees turned) 180 degrees just to type the good character. I think the last last big update has something to do with these problems, because right after it finished it started to become slower and showed some small "dead spots".

    I'd really appreciate if I get a fix for these problems:)
    (I'm new here so I hope I picked the good place to put this)

    Advertisement
    :
  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    This probably isn't going to be the answer you want, but your phone sounds like it's on its way out. :(

    It can take a while to see the full effects of water damage and its been dropped too, I think out might be time to call your insurance company (if your phone is insured), sorry.
  3. nfsmw95

    nfsmw95 Member

    Thanks El Presidente, but the weird thing is when I go to Settings, Language & Keyboard, Text Input and then Calibration Tool it works, not always as perfect as it should be, but still. Normally when i try to type at "normal stance" it doesn't even want to do anything... So can it be the problem of the software? Because as I already said after the update it started with problems
Loading...

Share This Page