HTC Legend and Enterprise Wifi


  1. MacNeil

    MacNeil Member

    Hi everyone,

    So this if my first post and not sure if someone already asked it. I have searched under HTC since the UI would be the same and I couldn't find anything. So, sorry if the answer is already out there.

    I have an HTC Legend with Android 2.1 from Bell. I can't connect it to my university's network. I go to uOttawa and the network is a WPA authenticated with PEAP and MSCHAPv2. The network information is here (WPA Client). I have tried to setup the network and when it is all done the problem comes up that it won't connect to the network or I get a message saying network not within range.

    Thank for the help,

    MacNeil

    Advertisement
    :
  2. TastyBiscuit

    TastyBiscuit New Member

    *Bump*.. I'm in the exact situation, HTC Legend and can't use the uOttawa's internet... it accepts all the information and then it just doesn't connect... Could it have to do with the Certificate?.. Have you figured it out MacNeil?
  3. marclh

    marclh Member

    My HTC Legend works fine at Algonquin College with the WPA-EAP security network there, check at the IT help desk if there is one, they should be able to get it working from there.
  4. JF_android

    JF_android New Member

    I have Samsung Galaxy S Vibrant from Bell. I succeeded in connecting to UOttawa-Wpa... The only problem is that it lasts 30 minutes then I have to ''Forget Network'' and reconfigure again to make it work again.

    Here's how I did:
    1- Go to the Thawte root certificate download page and download ''Thawte Premium Server CA''
    2- Go to RealmB's Android Certificate Installer and upload it (you can try the .cer and .pem) they are supposed to work even if not officially supported?
    3- Configure UOttawa-WPA with 802.1x, PEAP, ''MschapV2'', Certificate should be there if you used step 2 and Identification = Student Number + Wireless password = Infoweb password in CAPS LOCK

    I think on some smartphones the certificates are supposed to be downloaded automatically. Indeeds not on Android for now.

    I also tried to convert my certificate on my windows 7 computer to convert the certificate using ''certmgr.msc'' in the run (type in to the indexed search bar in start menu). However it doesn't le me choose the option to select the official format supported by android.

    Now I downloaded ''Wifi Advanced Configuration'' for free on the android market and I'll try to figure out something with that soon.

    I'll keep you posted and let me know too

    Also need help with my configuration.
  5. TastyBiscuit

    TastyBiscuit New Member

    Just wondering if there are any updates on this... I'm also in Ottawa U with an HTC Legend and haven't been able to connect. Have you guys figured it out? Does that solution that JF_Android work?
  6. baracuda1121

    baracuda1121 Member

  7. sindh1963

    sindh1963 Member

Loading...

Share This Page