HTC Legend VodafoneUK simlock trouble


Last Updated:

  1. Mr. Thomas

    Mr. Thomas New Member This Topic's Starter

    Joined:
    Nov 23, 2010
    Messages:
    2
    Likes Received:
    0
    Hello all,

    Avid user of this forum, first time poster.

    Been looking for a thread on this for over 2 months now and haven't found one.

    I've had the HTC Legend for around 3 months, bought it from a personal seller on eBay, who also provided me with a NUC (Network unlock code). It came branded and I assumed "simlocked".

    When I entered my o2 PAYG Simplicity sim, I could send texts and make calls no problem, however my problem is getting mobile internet and receiving MMS.

    I have manually entered the APN settings etc. and still had no luck with receiving and sending MMS or gaining access to my mobile internet.

    Is there a way to access the settings to enter the Network Unlock Code? (I have tried other sims, contract and PAYG) or am I being completely dense and it isn't simlocked and there's something else wrong...?

    Sorry for the long post, just thought I'd give all the details so you all know what a predicament I'm in!

    Thanks a bunch!

    Mr. Thomas
     

    Advertisement
  2. OObatz

    OObatz Member

    Joined:
    Apr 3, 2010
    Messages:
    23
    Likes Received:
    3
    The phone must be unlocked as you were able to use an o2 sim, if you need the settings try these..or call o2

    For Data
    APN: mobile(or possibly wap).o2.co.uk
    username: vertigo
    password: password

    For mms
    apn: wap: o2.co.uk
    username: vertigo
    password: password
    MMSC: http://mmsc.mms.o2.co.uk:8002
    mms proxy: 193.113.200.195:8080
     
  3. Mr. Thomas

    Mr. Thomas New Member This Topic's Starter

    Joined:
    Nov 23, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply

    I have tried all different kinds of settings for the APNs that I have been given from forums and phone calls including o2 and other HTC Legend forums but none of them work, hense why I thought I'd put up a post!

    Any other idea's as to what may be the problem?
     
  4. OObatz

    OObatz Member

    Joined:
    Apr 3, 2010
    Messages:
    23
    Likes Received:
    3
    Maybe a hard reset would help? Then try the official settings from o2.
     

Share This Page

Loading...