HTC Mail and Gmail syncSupport


Last Updated:

  1. SnoopyWG

    SnoopyWG Member This Topic's Starter

    Joined:
    Dec 23, 2009
    Messages:
    11
    Likes Received:
    0
    I have a weird problem in that I can get the GMail app on my HTC Hero to sync properly, but the same gmail account set up in the HTC mail app stopped syncing about a day ago and I can't get it to update itself. Sending works fine from the HTC mail app, so I believe it's configured properly... I just can receive any more... This was working just fine yesterday and nothing has been changed in my settings...

    Also, the HTC mail widget doesn't display the emails properly (but they used too).

    Any ideas about what's going on?

    w
     

    Advertisement
  2. treborcj

    treborcj Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    646
    Likes Received:
    33
    I have not had this problem since I use the gmail app for my gmail. I use the mail app for other accounts. Just stick with the gmail app. But if you really want to use the mail app then try a factory reset.
     
  3. Syphon

    Syphon Well-Known Member

    Joined:
    Oct 27, 2009
    Messages:
    142
    Likes Received:
    2
    Snoopy,

    Mine stopped working also about the same time it seems yours did. I am wondering if its a bigger issue. I find it funny that on a Google OS that the only email I have issues with getting consistently is email from Google's email platform. Its odd because this has happened in the past and then it just starts working again. Its been more and more frequent though in the past 2 weeks.

    Treborcj,

    Factory reset is not really a solution. That may fix if for the time being but it will just happen again. My understanding is a factory reset will reset everything and I will have to resetup everything on my phone. Just not a true solutions but rather an easy way out lol.
     
  4. SnoopyWG

    SnoopyWG Member This Topic's Starter

    Joined:
    Dec 23, 2009
    Messages:
    11
    Likes Received:
    0
    Thanks for the responses... i do use the gmail app for my gmail account, but I like some of the options the HTC app offers...

    I tried deleting the account and then re-creating it in the HTC app and it did update this morning then stopped again... weird...
     
  5. BSki

    BSki Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    249
    Likes Received:
    2
    I think they are two entirely different email systems. The GMail app, is push, where the HTC is a Pull.

    I have mine only setup for the gmail app as I feel that is going to consume less power as it does not have to check email at every interval.

    Certain things I like about the HTC app that I would like to use, but I find the gmail app to be the most like gmail mobile.
     
  6. SnoopyWG

    SnoopyWG Member This Topic's Starter

    Joined:
    Dec 23, 2009
    Messages:
    11
    Likes Received:
    0
    It's still weird... even when I do a refresh of my gmail in HTC mail, I don't get any new emails since when I initially set it up in HTC mail... Maybe there's some tag that makes the client think it already pulled those emails down? It's current in the Gmail app, but it would be great to have it in both since the HTC client offers some functionality that the Gmail client doesn't (like saving attachments).

    Definitely a work in progress...
     
  7. Slovak

    Slovak Well-Known Member

    Joined:
    Nov 20, 2009
    Messages:
    51
    Likes Received:
    1
    I had an issue with gmail too on my hero, the gmail app just stopped working completely downloading new emails, unless i manually hit refresh, I got now emails at all. Took it to a sprint repair center, they couldn't figure it out and said they only saw this once before. They exchanged the phone and now it works again.
     
  8. SnoopyWG

    SnoopyWG Member This Topic's Starter

    Joined:
    Dec 23, 2009
    Messages:
    11
    Likes Received:
    0
    I have a hard time believing it's a hardware problem so I'll just see if it corrects itself... I've been experimenting with other settings, but nothing yet...
     
  9. salpiche

    salpiche Well-Known Member

    Joined:
    Nov 4, 2009
    Messages:
    216
    Likes Received:
    24
    I had the same issue till I did a factory reset and instead of using the HTC email app I stated using the gmail app. No more sync issues ever since. It isn't a hardware issue however it is a software conflict issue as far as I can tell.
     
  10. SnoopyWG

    SnoopyWG Member This Topic's Starter

    Joined:
    Dec 23, 2009
    Messages:
    11
    Likes Received:
    0
    That's what I'm thinking... shame since the HTC app has some nice features...
     
  11. triman0

    triman0 New Member

    Joined:
    Jan 1, 2010
    Messages:
    2
    Likes Received:
    0
    I have a very similar issue. I've had my Hero two weeks, now for the third time, I have stopped receiving email. The Exchange ActiveSync says that it synced, but the new mail isn't on the phone. I can send without any issues. The first two times, I removed the account and recreated it, and all works fine. But three times in two weeks is a little crazy.

    Any thoughts to the cause?
     
  12. The Dark Knight

    The Dark Knight Active Member

    Joined:
    Dec 1, 2009
    Messages:
    44
    Likes Received:
    0
    I am currently having the same issue as well. I synced my MSN account twice, and both times the downloads worked as set. However, a day or two after the initial set-up, it always ceases to work again. I get a Force Close everytime I attempt too many manual updates in a row as well.
     
  13. Snarky30

    Snarky30 Member

    Joined:
    Dec 29, 2009
    Messages:
    22
    Likes Received:
    2
    I get the same issue here with my HTC mail app and my work Exchange Email. Mine always seems to stop after I power cycle my phone. Then if I go into settings->Data Sync-> and Exchange ActiveSync, I get the same security certificate pop up several times in a row. I keep hitting "Continue" but the same message pops up over and over again. But when I hit "Cancel", my email sync starts working again. I guess HTC's android email app isn't perfect with Exchange yet.
     
  14. The Dark Knight

    The Dark Knight Active Member

    Joined:
    Dec 1, 2009
    Messages:
    44
    Likes Received:
    0
    This is definitely sounding like an issue with the app., as opposed to user error. I sincerely hope that a fix is issued soon (Maybe with Android OS 2.1?).
     
  15. MorningThief581

    MorningThief581 Member

    Joined:
    Jan 9, 2010
    Messages:
    9
    Likes Received:
    0
    I also have this issue. I use gmail for business and personal mail, so I have the GMail app sync'd to my personal account and the HTC app sync'd to my business account. My personal account has worked flawlessly since day 1. But I can't even count the number of times I've needed to delete the business account and recreate it. Like others have said, the HTC app will just stop fetching new mail at some point. It actually goes through the sync operation and it says the inbox is current, but no new mail will arrive. Very frustrating.
     
  16. triman0

    triman0 New Member

    Joined:
    Jan 1, 2010
    Messages:
    2
    Likes Received:
    0
    I ended up switching my gmail from ActiveSync to imap a few weeks ago, and mine has worked flawlessly since. In fact it now brings all of my calendars in, instead of just the default.
     
  17. honker123

    honker123 New Member

    Joined:
    Oct 7, 2010
    Messages:
    1
    Likes Received:
    0
    Ok i found the solution for this issue with my phone. I have the 4g EVo and its rooted as well with new update. So i remember starting to have that issue when i downloaded the update on the market for gmail. As soon as I uninstalled the update for gmail then i could preview and open attachments. YES! it was horrible not being able to use it for work. I'm over there showing off my phone and my email doesn't even work. ;) hope this help people!!
     
  18. JB in AZ

    JB in AZ VIP Member VIP Member

    Joined:
    Oct 27, 2009
    Messages:
    1,869
    Likes Received:
    267
    honker123, thanks for the info! And welcome to the forum!

    As this was an older thread, I will move it to the Support and Troubleshooting sub forum, where it might be easier for someone looking for an answer to this issue to find it.
     

Share This Page

Loading...