HTC MyTouch 3G Bluetooth not working and Bluetooth Share Disconnects phone from network


Last Updated: 2013-01-06 19:45:09
  1. redmoonx

    redmoonx New Member

    Hello,



    I have a HTC MyTouch 3G (Not Slide) phone which is having problem with the Bluetooth feature, it doesn't turn on. I've read around the web of people having a similar issue and in most cases it has been identified as a hardware problem but I just found something strange with the problem I'm having.


    When I try to turn on the Bluetooth option under Settings -> Wireless & Network -> Bluetooth, It's always OFF and when I press to turn it on, it stays on "Turning On" for a few seconds and then does nothing, it just stays OFF.


    I was looking around under Settings -> Applications -> Manage Application -> Running, and I see the Bluetooth Share App is running and to see if I could troubleshoot the App, I decided to turn it OFF but going in the App and Pressing "Force Stop" and then the odd thing happened, I lost my Service Signal, it just kicked me out of the network and it took about 30 seconds for my phone to reconnect to the network again.


    I thought it was odd so I tried to stop the "Bluetooth Share" app again and it disconnected the phone again and again and again.
    I want to reinstall the Bluetooth app but I can't find the .apk and .obex files anywhere to download them. My phone is currently rooted and I wouldn't have a problem doing it.


    I'd like to know if anyone has experienced a similar problem and also if it's possible to reinstall the Bluetooth app.


    My phone is running Android 2.3


    Thank you

    Advertisement
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    welcome to the forums!!!!!!!!!!!

    i moved you to the my touch 3g root forums, since you are rooted.

    i do not have your device, but have you tried to wipe dalvik cache and cache? sometimes that usually fixes the issue.

    what rom are you on? maybe try and re-flash your rom.
  3. redmoonx

    redmoonx New Member

    Thanks,

    I haven't tried that yet but I will give it a shot once I get Clockwork recovery installed.
  4. redmoonx

    redmoonx New Member

    I installed clockwork recovery mode, booted, cleared the dalvik cache and the cache itself and it still didn't work. The Bluetooth option won't turn on and when I try to force stop the bluetooth share app which is always running, it doesn't stop and yet it still disconnects my phone from the network.

    I'm trying to avoid resetting the phone.

Share This Page