HTC one s recovery issue


Last Updated: 2013-04-25 23:10:10
  1. Jkatorza

    Jkatorza Member

    Hi,

    I tried to root my HTC one S but after I unlocked the bootloader (boot loader is now UnLocked) , I couldn't run the SuperSu zip file because When I open the recovery it shows a red message saying:

    "this build is for development purposes only do not distribute outside htc with out htc write permission failure to comply my lead to legal action ."

    does any one know what to do to repair this and go throw with the rooting?

    I tried with all four recoveries on the "All in one Kit - Hasoon 2000's":
    CWM 5.8.2.7 touch
    Doom Recovery B1
    Interim
    Stock

    all of them showed the same error message (above) when I tried to open them after installation.


    Thanks,
    Jasmine.

    Advertisement
  2. AntimonyER

    AntimonyER AF Addict VIP Member

    Welcome to AF, Jasmine!

    I moved your thread into the All Things Root section, to hopefully get you a better answer. Thanks for signing up! :)
  3. agentc13

    agentc13 Daleks Über Alles VIP Member

    That's not an error. If you have an unlocked bootloader from HTCdev it will say that when booting.

    As far as recoveries go, I recommend TWRP2.2. There is a link for it in the how to root sticky.
  4. dermoe

    dermoe New Member

    Hi,

    I have the exact same problem as Jkatorza.
    I have done eveything as explained in the "how to root sticky" and it all worked until the last step. But when I try to get into recovery Mode I get the

    "this build is for development purposes only do not distribute outside htc with out htc write permission failure to comply my lead to legal action ."

    message and it doesn't do anything anymore.

    So to clarify: I cannot run the Superuser.zip because there is no way to get into recovery mode in the first place. I am simply stuck at point 5 in the "Rooting your Phone"-section of the tutorial (which works great until that point btw).

    If anyone has a solution for this it would be great. Thanks a lot!


    Edit: got it to work but only using the twrp recovery that goomanager downloaded as explained by tomybarda in this thread:

    http://forum.xda-developers.com/showthread.php?t=1719911&page=14

    Thanks anyway ;)
    scotty85 likes this.
  5. agentc13

    agentc13 Daleks Über Alles VIP Member

    It's because you have the S3 version and flashed the recovery for the S4 version. There is only a TWRP2 recovery for that version.

    I wrote the guide before they put out the S3 version. Thanks for bringing it to my attention. I did link the post saying not to flash the wrong versions recovery/ROM at the beginning of the guide, but I will make sure to link the download and make a better note when I get a chance so that others don't have the same issue.
    scotty85 likes this.
  6. Jkatorza

    Jkatorza Member

    Thanks! it worked!
    scotty85 likes this.
  7. theghost75

    theghost75 New Member


    Hi,
    I have the same problem as Jkatorza,
    the bootloader is unlocked.
    My andriod version is 4.0.4.
    version of Htc sense 4.1.

    have you a solution please??

    Thanks.
  8. melissa8313

    melissa8313 New Member

    someone please help me...i got that message twice this week and i did not root my phone as i do not know how to do that....i also get that screen where it says that my phone is compromised and locked with a date of nov 26th, 2012. please i beg of anyone who knows anything....im having such a hard time getting my phone repaired and i didnt do anything to it in regards to rooting it....all my phone does is reboot all the time. i have a htc one x and got it dec 8th, 2012..problems started in january 2013. ive done 2 factory resets on the device and still nothing. please help.. @melissa8313 on twitter.
  9. scotty85

    scotty85 Guides Guide

    this is actually the one s forum,not the one x. did you just get this device? sounds like maybe you have a blacklisted phone that has locked your sim card.

    if you bought the phone new,id contact your carrier,it may be some sort of hardware failure.
  10. razvan06

    razvan06 Well-Known Member

    I would try to do a factory reset again and run a RUU, that will 90% fix your issue ! [had it at some point]

Share This Page