1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

HTC One X wifi problems on BT Home Hub since jelly bean updateSupport


  1. Kevin1911

    Kevin1911 New Member

    Evening all! My wife and I both have HTC One X phones, and both updated the firmware to jelly bean over Christmas. Ever since the update, we've both been having the same problem with wifi access at home. The phones connect to the home hub wirelessly fine, and work well for either a few minutes or a few hours. But after a while the phones seem to lose connectivity. The phones show they're still connected wirelessly, but all apps report that they're not connected to the Internet.

    So far, I've changed the wifi channel, checked for interference from other wifi routers, replaced the home hub, removed and re-added the password, but the connection still keeps dropping out. It kicks back in as soon as you turn wifi off and then back on.

    I've emailed HTC and they want me to send the phone back, without asking any further questions, which seems a bit odd to me.

    Anyone else had this issue or something similar? If so, how did you fix it?

    Advertisement
  2. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Moved to the HTC One X/XL section. Have you tried a factory reset?
  3. Kevin1911

    Kevin1911 New Member

    I haven't actually. Maybe worth a try.
  4. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    That usually fixes bugs associated with OTA updates. It might fix your problem. Just make sure to back your things up before doing it or you'll lose it. :)
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    There's been a few folk with similar issues since the update, have you tried assigning yourself a static IP? That has been known to sort things.
  6. GuitarG20

    GuitarG20 Clueless Senior Member Contributor

    I've also heard a lot of people reporting issues with the HOX and BT Home Hubs, so perhaps it's an issue with that combo? I'm gonna go look through those threads and see if there was any conclusive solution, but you're welcome to if you want to as well, OP. Maybe it was assigning a static IP? I'm gonna go check.
    El Presidente likes this.
  7. shackfan

    shackfan Active Member

    Having the same problem. Turn your WiFi off then on. Seems to work for a while. Bloody pain though.
  8. franners

    franners Well-Known Member

    Static IP worked for me. Still a little slow to rejoin wifi but does join it. Prior to that only wifi off/on would trigger connect.
  9. tobyjuggler

    tobyjuggler Well-Known Member

    I posted the following in another JB WiFi thread:

  10. Jessy Saint

    Jessy Saint New Member

    This solution found on another forum seems to have solved the issue for me on my HTC One S:

    To resolve this we can try wiping the cache partition. This will remove any temporary files that may be causing the issues.
    Kevin: Disable Fastboot

    1. Open Settings.
    2. Tap Power.
    3. Untick Fastboot.

    Clear the Cache Partition

    1. Turn the device off.
    2. Press and hold the Volume Down Key.
    3. With the volume key held press and release the power key.
    4. Use the volume keys to highlight Recovery.
    5. Press the Power button to select Recovery.
    6. Wait until the phone reaches a screen with a red warning triangle.
    7. At the same time press both the volume up and power buttons.
    8. Use the volume keys to select Wipe cache partition.
    9. Press power to select Wipe cache partition.
    10. Once the process is complete press the power button to reboot the phone.


    Good Luck.

    Jessy
  11. Jessy Saint

    Jessy Saint New Member

    Well, false hope. The problem is still present at home on my Linksys E3000. How strange!!!! I'm pretty upset right now!!!

    I also tried a static IP, to no avail.

    I won't change the security of my router.... it is WPA2 and will remain like that. I prefer not using the wifi than changing the security!
  12. Jessy Saint

    Jessy Saint New Member

    A phone reset (HTC One S on Bell Mobility) has finally solved the problem for me. But still, I don't think this should have happened in the first place.

Share This Page