HTC One X


  1. evelynbeer

    evelynbeer Member

    Hi,can anyone give me any advice please?I have just bought an HTC ONE X phone off ebay to replace my Galaxy mini.It has Jelly bean installed. My problem is that it seems to have a lot of stuff missing or unavailable.For instance I can't change my key board layout.No FM radio.The manual i downloaded doesn't seem to match wat is actually on the phone.I tried to change the keyboard and the manual says to go to settings,language&keyboard but on the phone it says language&input but it has only got the Android keyboard default AOSP.when I tap on this to set up input method is comes up-unfortunately settings has stopped.I had better from my mini.Do you think it is jelly bean causing the problem.HTC on-line chat advised me to send the phone back as they can't help me.

    Advertisement
  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Welcome to the forums evelynbeer :)

    Sometimes buying off eBay can be unreliable, just so you know, otherwise though, have you tried performing a factory reset on the device?

    Lastly, this keyboard issue...so have you tried installing a new keyboard and you couldn't change it from the default one?

    Thanks for joining :)
  3. LilBit

    LilBit Well-Known Member Contributor

  4. El Presidente

    El Presidente Beware The Milky Pirate! VIP Member

    It sounds like you've a custom, JellyBean ROM installed like AOKP or CM10? If you head to settings -> About Phone, what software version do you see?
  5. evelynbeer

    evelynbeer Member

    I have gone to settings and about phone what i see is this:Android version4.1.2/Kernel version2.6.39.4-cyanogenmod/cyanogenmod version10-20121108-nightly-endeavour/baseband version 2.1204.127.19.Is this any help to you.Sorry I am a bit of a novice.
  6. evelynbeer

    evelynbeer Member

    Hi,no I haven't tried a factory re-set yet as I am a bit of a novice where smartphones are concerned so haven't been that brave yet and no,I haven't tried to download a keyboard-have you gat any recommendations for one?
  7. Digital Controller

    Digital Controller The Real Bass Creator Guide

    If you are into typing..try Swiftkey, otherwise if you want to venture into Slide typing or Swiping you can try Swype or SlideIT

    Swype isn't available on the Google Play store but you can sign up for the Beta and download it onto your device pretty easily.
    evelynbeer likes this.
  8. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Yeah your device is unlocked on a CyanogenMod 10 Nightly, which means this is an unstable version of Jelly Bean, potentially unstable...which might be causing all these errors.

    If you want we could teach you how to flash a Stable version of CM10 onto your device?
    evelynbeer likes this.
  9. evelynbeer

    evelynbeer Member

    Do you think that is the right way to go or should I do a factory reset.Could you give me some idea what the pitfalls are of a factory reset and if I follow your instructions for the flash how easy am I going to find it?Thanks for your comments.
  10. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Since you are on a nightly the only thing you would need to do is install the next version of CM, which should be pretty simple...

    Otherwise, with factory resets, the only downfall is it will delete everything on your phone.
  11. evelynbeer

    evelynbeer Member

    As I have only had the phone a few days there probably isn't much to lose as long as I save my contacts to my sim card I suppose.
  12. evelynbeer

    evelynbeer Member

    Hi I have just downloaded free version of swiftkey but when I get to step 2 to enable swiftkey I get the message -unfortunately settings has stopped-which is the same message when I try to access the keyboard that is already installed on the phone.I have no idea what this means.
  13. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Sorry i just got into work. Hmm, yeah it sounds like something is definitely wrong with that ROM, otherwise you could try performing a factory reset just to make sure. If that fails we can go the other, more difficult, route.
    evelynbeer likes this.

Share This Page