HTC Rezound: Root


Last Updated:

  1. AllusiveGold

    AllusiveGold Member

    In the process of trying to root my Rezound, I've ran into an issue and am hoping to resolve it.

    I've made it to the step where you flash the custom recovery image, but when I go to do so, I keep getting a "signature failed."

    Any help with this issue would be greatly appreciated! Thank you!

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    make sure youre trying to flash an .img file,and not a .zip or something else.

    beyond that,a copy of your cmd window,and a screenshot of your adb/fastboot folder(miniadb_vigor if youre using the guide here) will help. :)
  3. AllusiveGold

    AllusiveGold Member

    Thank you so much! I will get that very shortly!
  4. AllusiveGold

    AllusiveGold Member

    [​IMG]

    [​IMG]

    Hope this will suffice
  5. scotty85

    scotty85 Guides Guide

    Looks like that should be working. Might redownload recovery and check the md5.

    Is your hboot displaying unlocked ?
  6. AllusiveGold

    AllusiveGold Member

    No it is saying locked. What the heck. I must have missed something? I had no trouble rooting the Incredible 2, this is silly, lol.
  7. scotty85

    scotty85 Guides Guide

    ooooh,yes that definately explains it,lol. anything you flash must have an approved,htc signiture when youre s-on and locked

    i could see your unlock_code.bin in the above screenie,so i assumed it had been flashed :eek:

    once you flash your unlock_code,and get an unlocked bootloader,then your recovery flash should go without issue.

    fastboot flash unlocktoken Unlock_code.bin is the command you need to unlock. even tho youre almost there,there may still be some other useful links and info in the root guide: http://androidforums.com/rezound-al...ys-noob-friendly-root-guide-start-finish.html

    :)
  8. AllusiveGold

    AllusiveGold Member

    Yeah, I'm going to have to make an excuse for myself. I had done this already, but I'm assuming either it relocked itself or I never fully completed the process (I read something that said it was possible for it to relock, I don't remember where.) Anyhow, it was a bad idea for me to do it when I did as I was falling asleep and have been almost every time I put forth an effort. A result from working 70+ hours a week and every day at that :(

    I went through and did everything all over again and now it works fine. This isn't rocket science so I didn't think it would be that big of a deal, lol. So sorry to have bothered you! I feel so stupid, lol *sigh*
  9. scotty85

    scotty85 Guides Guide

  10. AllusiveGold

    AllusiveGold Member

    OK, so now I have a new issue. I have achieved S-OFF and everything appears to be in working order. But I think I'm missing something. I go to update the binary in superuser and when it goes to gain root access, it fails. None of the other apps work either. On my Incredible 2(things seemed so much simpler on this phone), this was never an issue. However, on my Rezound I also notice that even though it says S-OFF and unlocked, right above that it says tampered. Wtf? Could this be my problem? And if so, is there anything I can do about that?

    Again, any help would be greatly appreciated, thanks in advance!
  11. scotty85

    scotty85 Guides Guide

    The s off process seems to confuse the phone a bit. What I would recomend is to run the ruu for 4.03.605.2 to get yourself on the newest firmware. Then,with the stock recovery still on the phone,chose the "clear storage" option in hboot. This should elimiate potential flakey data and other wierd issues.

    After you've cleared storage,reinstall your recovery,and reflash superuser(or reflash your custom rom)
  12. AllusiveGold

    AllusiveGold Member

    Thank you for your quick response. I'm trying to assess the damage at the moment and I am really unsure to be honest. I had flashed CWM 5.8.1.4 (I did have Amon Ra) but it seems broken! Anytime I select something, it just goes away. So I tried to flash back to Amon Ra, but I keep getting:

    [​IMG]

    I don't know if I have messed this phone up for good or what. I feel as if I have accomplished both something and nothing at all. Silly question, how do I run the RUU?? Also, when I go to clear storage, it takes me into CWM, and from there I can do nothing :(

    Sorry to bother you with all of this. This should be simple, and it probably is, but I'm a little bit lost. Thank you for any and all help.
  13. scotty85

    scotty85 Guides Guide

    sounds like you are back on a locked or relocked stock hboot. you need to unlock,or run the jpbear hboot,in order to use fastboot commmands like fastboot flash and fastboot boot

    the alternative,is to flash recovery as a PH98IMG file,wich ill link in a second. but for now,i dont think its really neccessary,as you need to flash the ruu first. not sure if your cw is really broken,or youre just not using it correctly. cw on other devices can cause confusion(especially the original incredible :eek:) try selecting with either the home or search softkey,assuming youre trying to select with the power button

    correct,with cw in place you cant use the clear storage or factory reset options in hboot,they will just take you to your custom recovery. thats why we need to run the ruu and do that option with the stock recovery in place.

    download the newes ruu from here: Shipped ROMs

    rename it PH98IMG and place it on your FAT32 formatted sd card. boot to hboot,and it should find PH98IMG,check it,and ask you to update. allow the update. make sure youre charged to 100% prior to starting,as the phone will not charge in hboot or fastboot.

    once the update as completed,reboot. immediately remove PH98IMG from the sd. you can then boot back to hboot and you can perform the clear storage.

    once youre done with that,you can reinstall the recovery. download from here: PH98IMG-amon-3.15.zip

    ad flash just as you did above.(rename PH98IMG,place on sd)

    hope that helps clear it up :)
    AllusiveGold likes this.
  14. AllusiveGold

    AllusiveGold Member

    I had only flashed to CWM because I'm quite familiar with it on the Dinc2. Is it not possible for me to use it on the Rezound? Whenever I select something, it just highlights the image in the middle and all the options go away until I hit the power button again.

    Also, thank you very much for taking the time to help me with this. I feel kind of silly and all. I guess it's been so long since the process with my Dinc2, I seem to have forgotten a lot of this. Thanks again! I'll update soon!

    P.S. Is PH98IMG_ICS_4.03.605.2.zip stock? (just curious)
  15. AllusiveGold

    AllusiveGold Member

    CWM works fine... I guess the keys are just not the same (as I assumed they would be) as they are on the Dinc2, fml, lol..
  16. AllusiveGold

    AllusiveGold Member

    What I cannot seem to understand is, after following all of your directions closely, I still do not have full access to the phone. I don't know how accurate this app "root checker" on Google Play is, but even it says that the phone is not properly rooted. The phone says unlocked and s-off, and I cannot do anything. Do I HAVE to flash to a different ROM to be able to change anything?? I don't recall this being the case with the Dinc2, but I also realize they are two different phones. This is just not making any sense to me.

    Anything requiring any kind of root access through an app, whether it be AdAway, Rom Manager, SuperUser or SuperSU, it always "fails" or says that it cannot gain root access.

    I am positive that I have not missed any steps this go round. I'm about ready to give up :( I've done everything but change the ROM.
  17. scotty85

    scotty85 Guides Guide

    no,you defaintely do not have to change the rom. make sure you are flashing supersu in recovery. the link is in the original post here: http://androidforums.com/rezound-al...ys-noob-friendly-root-guide-start-finish.html

    if you are under the impression that being s-off,in itself gives root access,then that is not the case.

    also,if you are simply downloading superuser or supersu from the market,that does not give you root access either.

    supersu is up to v99. i went ahead and copied the important part from the linked thread above. here you go,download supersu from here:
    place that zip on your sd card,boot to recovery,wipe cache and dalvik cache,and flash the zip file. make note of wether or not any errors pop up. if you use the correct zip get no errors,i promise you it will give you root access. ive used supersu to root almost more stock roms on various phones than i can count,and lots of folks have used it here,on the rezound. hang in there,your almost there :)
    AllusiveGold likes this.
  18. AllusiveGold

    AllusiveGold Member

    Again, thank you for your patience and your help. I suppose I was under the impression that by being unlocked and s-off I would be rooted especially after having superuser and su. Unless there were steps I forgot when rooting the Dinc2, it seemed it was just that simple. I also was under the assumption that being an HTC phone, there would be a lot of similarities, LMFAO, boy was I wrong!

    Well, here I go! I'm deeply interested in how a lot of this stuff works, which was why I had decided to attempt rooting the Dinc2. Then, when I recently got my Rezound, I figured it would have only been a matter of time before I rooted it. But, before I got to that point, being on a stock phone, I realized VERY quickly that there would be no possible way for me to keep it that way and manage to do everything that I do. So this is very necessary for me! And I'm sure I may find some interesting roms in the future as well!

    Thanks again!
  19. scotty85

    scotty85 Guides Guide

    Your welcome! Glad you are now sorted :) enjoy your rooted phone!

Share This Page