1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

HTC Rhyme New Root Method


  1. dossa002

    dossa002 Member

    **NOTE**: I TAKE NO RESPONSIBILITY FOR ANY DAMAGE DONE TO YOUR DEVICE BY FOLLOWING THIS PROCESS. DO THIS AT YOUR OWN RISK!

    I also take no credit for this. After failing multiple times at using zergRush, I turned to a remote rooting service as a last resort. The representative that I worked with performed the following for me and got me rooted. Note that I have only tried this on my phone. I don't have another Rhyme to test with. But, this has given me perm root:

    First, unlock your bootloader at http://www.htcdev.com/

    Download this file: http://goo.gl/Fay2k
    Then unzip the file to any folder, then run the following commands:

    adb reboot bootloader
    fastboot flash recovery htc_rhyme_vzw_unofficial_clockworkmod_recovery_v5.0.2.8.img

    adb shell mount /system
    adb push su /system/bin/su
    adb shell chmod 06755 /system/bin/su
    adb push Superuser.apk /system/app/Superuser.apk
    adb shell chmod 644 /system/app/Superuser.apk

    Reboot to system and you should be rooted! Stock recovery is included in the zip in case something goes wrong with flashing CWM. Enjoy!

    My phone when I rooted:
    SW: 2.20.605.3 710RD (Android 2.3.4)
    hboot: 1.32.0011
    radio: 1.23.00.0224

    Advertisement
    :
    Crouchy Aus and IzelTokatl like this.
  2. IzelTokatl

    IzelTokatl Well-Known Member

    Has anyone else attempted this method?
  3. lotddragon

    lotddragon New Member

    I have attempted it and CWM does work, but when I try to mount the system to push su, this is what I get:

    C:\Android>adb shell mount /system
    Usage: mount [-r] [-w] [-o options] [-t type] device directory
  4. lotddragon

    lotddragon New Member

    First, unlock your bootloader at http://www.htcdev.com/

    Download this file: rhymeroot.zip - 4shared.com - online file sharing and storage - download - Andrew Dos Santos and this file: http://xda3.androidrevolution.nl/db...ns/Android_Revolution_HD_Root_and_BusyBox.zip

    Unzip the first file to any folder and place the ARHD root zip in the root directory of your sd card, then run the following commands:

    adb reboot bootloader fastboot flash recoveryhtc_rhyme_vzw_unofficial_clockworkmod_recovery_v5. 0.2.8.img

    After you have recovery up, go to flash zip from SD and flash the ARHD file. Once finished, you'll have root on 2.3.4.

    I do not take credit for any of this, the ARHD file was supplied by mike1986 on XDA. This was the method that worked for me and I'm not responsible if you brick your device.
    imjarhed, dossa002 and IzelTokatl like this.
  5. imjarhed

    imjarhed New Member

    Finally, something that actually worked!!!
    dossa002 likes this.
  6. IzelTokatl

    IzelTokatl Well-Known Member

    SUCCESS! I did something similar, I'm to lazy to setup ADB and do all the commands at this point. But, I have a rezound and flash the crap out of the bootloader and recover. if you check out the Rezound forum: http://forum.xda-developers.com/showthread.php?t=1504824 you'll find a great windows tool. DO NOT USE IT TO FLASH the installed recoveries. Only use it for the custom recovery function. I extracted the above recovery renamed it recovery.img and flash it.

    [​IMG]

    Then I flash a custom file, similar to above SU and binaries, and full root was achieved.

    [​IMG]
  7. dossa002

    dossa002 Member

    I would really like to reccomend that you get over your laziness. Using programs not intended for your phone can really bork it but glad to hear you finally got it taken care of! :)
  8. ChosenHero

    ChosenHero Member

    can someone give me step by step instructions on unlocking bootloader? I don't understand on htcdev when I have to create the folder and that process.
  9. ChosenHero

    ChosenHero Member

    I am typing in >adb reboot bootloader and I first got this:
    C:\Android>adb reboot bootloader
    adb server is out of date. killing...
    * daemon started successfully *
    error: device not found

    keep getting this:
    error:device not found

    What can fix this and what did I do wrong?
  10. AndyKK

    AndyKK New Member

    Maybe should close HTC Sync, or uninstall it.
  11. molofi

    molofi New Member

    did you root it with out any Issues? I have the same cellphone and Iwant to roo mine?
  12. fatcatt

    fatcatt New Member

    yea unstall HTC Sync it then the adb can work then with the2.3.4 rhyme u have to get the
    Super user whitelist app it will keep the su open because s-on note i want to know how do i get s-off any one ?
  13. tonyskte

    tonyskte New Member

    I have the same problem as fatcatt
  14. tonyskte

    tonyskte New Member

    how i can get s-off?

    Attached Files:

  15. hTC2013

    hTC2013 New Member

    I recently Purchased one hTC Rhyme phone.
    I updated its 2.3.5 Android with build number: software number: 1.31.707.6 to 4.0.3 with build number: 2.14.401.2 with this RUU: RUU_Bliss_ICS_35_S_HTC_Europe_2.14.401.2_Radio_20.72.30.0833U_3831.17.00.17_M_release_276226_signed
    well, Now I have some questions!
    1) I only want to change Farsi (Persian) font but I cann't. They said to me you must root it and so on. I do not Know how to root! Be notice I don't want to install custom Rom. For rooting, Do It need to Unlock boot loader via htcdev.com? What is best Program for root and unroot? how is the way of root? and what is last versin of Supersu apk?

    2) I want to know what is recovery.img? Do I must need to install it? Is recovery file defferent with other htc Phone recovery file?

    3) How to downgrade to android 2.3.5 if I want once?

    4) Does need to s-off? tell me way of s-off
  16. jhayden16

    jhayden16 New Member

    My phone when I attempted Root:
    SW: 2.20.605.3 710RD (Android 2.3.4)
    hboot: 1.32.0011
    radio: 1.23.00.0224

    Successfully UNLOCKED.

    Steps "adb reboot bootloader" and "fastboot flash recover...." completed successfully.

    With the following "shell" commands, I get this error: "error: device not found"

    With the following "push" commands, it just lists the adb parameters in cmd.

    adb shell mount /system
    adb push su /system/bin/su
    adb shell chmod 06755 /system/bin/su
    adb push Superuser.apk /system/app/Superuser.apk
    adb shell chmod 644 /system/app/Superuser.apk

    I installed HTC Sync, got the drivers, and deleted HTC Sync. My device can connect to the computer - so I don't think it's a cable or driver issue.

    I have USB Debugging enabled, and have allowed Unknown Applications.

    Any ideas?????

    UPDATE: SOLVED

    After the first two CMD steps: "adb reboot bootloader" and "fastboot flash recover....", I went to bootloader on my phone, and started recovery mode. From there I went to the option with mount, and clicked on the mount system folder option. Then on my computer, back to CMD and finished the remaining commands successfully.

    Looks like most people won't need to do that but for some reason the shell mount command wouldn't work from my PC and I had to manually do that from recovery. After that it worked no problem. If anyone else is getting the errors I got, maybe give the above a try.
  17. Crouchy Aus

    Crouchy Aus New Member

    Used this method but it would not let me push su was gettin a bit frazzled after a few attempts but combined zergrush version 2 and voila fully rooted and fully sick thanks a whole bunch for the info I was so glad to see the back of all the resource sucking crap optus had plastered all over my Rhyme it was a laggy bit of excrement unlocked and rooted it flies now.
Loading...

Share This Page