htc sync can't find my phoneSupport


Last Updated: 2013-08-21 09:13:28
  1. benner

    benner Well-Known Member

    I am trying to get HTC sync working and it won't find the phone.

    Also, the phone thinks usb debugging is enabled, even when I uncheck the box. Could this be related?

    Advertisement
  2. Pyr0x64

    Pyr0x64 Active Member

  3. tavaruanative

    tavaruanative New Member

    I also have this prob. HTC does not have te Droid ERIS listed as a product and does not sync either.
  4. benner

    benner Well-Known Member

    I do have the latest version. I am running windows 7. I tried installed using 'run as administrator' and i also tried compatibility mode. no luck.

    any other suggestions would be appreciated.
  5. tuatha

    tuatha Well-Known Member

    I was having this problem too, fixed it last night.

    Exit HTC sync, unplug your phone and bring up task manager on your PC. Look for a process called 'adb' and kill it.

    Restart HTC sync and plug your phone back in. It should connect.

    If not, uninstall HTC sync and install the version that came with your SD card. Follow the same steps.
  6. benner

    benner Well-Known Member

    uninstalled and reinstalled a few times, tried 3 different versions of htc sync, could not find adb in the list of running processes, thought it wasn't installed, downloaded adb for the g1 that some other desire user tried, that didn't work either...

    is this a windows 7 thing?

    i bought my phone in China. whoever smuggled it in pocketed the sd card. i had no choice but to download.

    how big was the sd card anyways? was there anything other than htc sync on it?
  7. nx1977

    nx1977 Well-Known Member

    Manually copy the drivers from the HTC folder to system32 ;)
  8. benner

    benner Well-Known Member

    Thanks nx1977. Could you please give me a little more detail? Do you mean the adb driver I downloaded from the G1 package (there were a lot of files in there)? There is an HTC drivers file in my program files. Do you mean that?

    Do I put them in the root of the system32 or in a file together?
  9. nx1977

    nx1977 Well-Known Member

    Find the HTC folders created under programfiles. Find the driver folder, and copy the contents to system32 folder in your Windows folder. Restart the PC, then Sync will work just fine.

    No need to start stripping exe files ;)
  10. benner

    benner Well-Known Member

    Didn't work. It still appears as disconnected.
  11. Newth

    Newth Well-Known Member

    I keep having a similar problem. I have to install the software then sync my phone. It then works ok. Everytime after that though, it doesn't work again. I get a message "Unable to create device manager instance" whatever that means. If I uninstall then reinstall, works again. Once.
  12. nx1977

    nx1977 Well-Known Member

    Have you both enabled HTC sync on the phone when prompted?
  13. benner

    benner Well-Known Member

    Yep. Here's what happens. I plug in the phone. I select 'HTC sync. The phone says 'connecting...finding HTC Sync on your PC. Please wait...'

    it goes for a long time...

    Then I get a message that says 'Next step... unable to find HTC sync on your PC. Please make sure that HTC sync is installed etc...'

    meanwhile, HTC sync is on the PC saying 'disconnected' in the lower right hand corner of the window. when i select 'tools' > 'phone monitor options' it opens another window with no phones listed and the window frame flashes a few times.

    When I open the task manager, I don't see adb anywhere. I don't see any process that i can recognize as being obviously HTC or phone-related.
  14. benner

    benner Well-Known Member

    Yep. Here's what happens. I plug in the phone. I select 'HTC sync. The phone says 'connecting...finding HTC Sync on your PC. Please wait...'

    it goes for a long time...

    Then I get a message that says 'Next step... unable to find HTC sync on your PC. Please make sure that HTC sync is installed etc...'

    meanwhile, HTC sync is on the PC saying 'disconnected' in the lower right hand corner of the window. when i select 'tools' > 'phone monitor options' it opens another window with no phones listed and the window frame flashes a few times.

    When I open the task manager, I don't see adb anywhere. I don't see any process that i can recognize as being obviously HTC or phone-related.
  15. ank218

    ank218 Member

    Could this be a fire-wall issue? I remember, back in the day, I had to give zone-alarm or whatever fire-wall program I was using, "permission" to let Active-Sync (Windows Mobile Phone Sync) connect. Otherwise, the program on the computer wouldn't even show the phone. Once, I added it... or turned it off, it let me connect without issues. Might try that... not sure if you have a Firewall, or even if HTC Sync needs firewall permission... worth a try though
  16. Dromineer

    Dromineer Active Member

    I had HTC Sync on my PC when I had my Hero and had no problems and when I connected my Desire, I had the same problem. What I did, I uninstalled HTC Sync from my computer, mounted my SD card and ran a fresh install from the copy of HTC Sync on that card. When I tried syncing again.. it worked like a charm. Dunno if that may work for you
    H-Meeuw likes this.
  17. benner

    benner Well-Known Member

    I didn't get an SD card with my phone. I bought it in China and apparently, whoever 'imported' it, removed it. I am using the newest update that I found on the HTC website that they claim works with the Desire.
  18. Dromineer

    Dromineer Active Member

    Did you check your antivirus or firewall? Make sure that HTC is given allow access on any firewall or antivirus application, as this may restrict HTC sync. Also try the suggestion I made by uninstalling HTC sync from your computer and reinstall, and when reinstalling make sure you disable your anti-virus or firewall temporarily until the installation is completed.

    To answer the question in your original post, please keep usb debugging checked, do not uncheck. Like Pyro suggested (which I see you have done) make sure you have the latest HTC Sync install file. After reinstalling, try rebooting your system (always worth a shot).

    Also make sure the USB port is clean, try to connect to other USB ports if possible
  19. benner

    benner Well-Known Member

    all done. i even did a factory reset as suggested someplace else. still no. i can connect as an external hard drive with no problems. just htc sync that doesn't work. i want to have full sync with outlook.
  20. benner

    benner Well-Known Member

    I emailed HTC and got a response a day later. it worked perfectly. here is the message:

    Thank you for contacting us it is truly appreciated.

    In regards to your problem, we can certainly help you with that.

    I am sorry to hear you are still having issues. You may have a background program conflicting with the installation. We can disable all background programs and then start the installation again from scratch to do this:

    1. Save any work
    2. Uninstall HTC Sync
    3. Start>Run>msconfig (Or windows key+r for run)
    4. Services Tab, tick hide all microsoft programs (at the bottom of the msconfig window tick it)
    (This is very important to click on hide all microsoft services first or computer issues can occur - be sure to tick this box)
    5. Now once that is ticked, click on disable all (MS services are hidden as you ticked the box so they will not be disabled now)
    6. Startup Tab, click on disable all
    7. Close/OK then restart
    8. The PC will restart with only essential MS programs running
    9. Click on do not show this again
    10. Install HTC Sync
    11. Plug in your PDA

    Is it working now?

    If it does not see the below steps:

    On our device browse to Settings > Applications > Development and then tick the option to enable USB Debugging. Now re-connect our device to your PC via the supplied USB cable.

    Is it working now?

    If it does not, or if it does, we still need to re-enable all of your background programs that you have installed on your PC to run in the background.

    1. Start>Run>msconfig
    2. Services Tab, click on enable all
    3. Startup Tab, click on enable all (leave any unticked that you do not want that may be slowing your PC down - this is up to you)
    4. Ok/Close restart
    5. The PC will restart back as normal

    Now go into Sync Manager> Tools>Repair

    Is it working now?

    Please let us know how you get on and we will assist you further if and when required as a matter of urgency.

    We trust that this resolves your query, please do not hesitate to contact us again if and when required as a matter of urgency.

    Thank you for contacting HTC.


    Best regards,

    Mat B.

    HTC
  21. nx1977

    nx1977 Well-Known Member

    Check under /windows/system32 that you have the files that are under /program files/HTC/drivers

    Without the drivers installed in system32, it wont work. If they are there, then it is a firewall issue.
  22. Mark One

    Mark One Well-Known Member

    Win7 32 Bit | HTC Sync 2.0.33

    I have the same problem and I've been trying to fix it for days. Very rarely I do manage to connect but the connection always drops again before I have time to start a sync. Weird eh?

    Anyway, here's my results from the HTC advice above:

    1. Save any work
    2. Uninstall HTC Sync
    3. Start>Run>msconfig (Or windows key+r for run)
    4. Services Tab, tick hide all microsoft programs (at the bottom of the msconfig window tick it)
    (This is very important to click on hide all microsoft services first or computer issues can occur - be sure to tick this box)
    5. Now once that is ticked, click on disable all (MS services are hidden as you ticked the box so they will not be disabled now)
    6. Startup Tab, click on disable all
    7. Close/OK then restart
    8. The PC will restart with only essential MS programs running
    9. Click on do not show this again
    10. Install HTC Sync
    11. Plug in your PDA

    Is it working now?

    --------------------------------------

    For a moment yes. I connected the phone and the HTC Synch wizard started up. I ran through the set up process but by the time I had got to the last screen and I was about to click OK with the "sync now" box checked the connection had dropped.

    I unplugged and replugged the phone in multiple times but it was never able to find HTC Sync again.

    ----------------------------------------------------------------------------

    If it does not, or if it does, we still need to re-enable all of your background programs that you have installed on your PC to run in the background.

    1. Start>Run>msconfig
    2. Services Tab, click on enable all
    3. Startup Tab, click on enable all (leave any unticked that you do not want that may be slowing your PC down - this is up to you)
    4. Ok/Close restart
    5. The PC will restart back as normal

    Now go into Sync Manager> Tools>Repair

    --------------------------------------

    This is where it falls over for me - I cannot access Sync Manager on HTC Sync unless I have a connection. It's greyed out under the File menu and clicking the Sync Manager button on the HTC Sync screen does nothing.

    ----------------------------------------------------------------------------

    nx1977

    >Check under /windows/system32 that you have the files that are under /program files/HTC/drivers

    I'm new to Win 7 32bit - but there is no /program files/ directory in C:/windows/system32 but the drivers seemed to install ok.

    > Without the drivers installed in system32, it wont work. If they are there, then it is a firewall issue.

    My firewall (Zonealarm) and windows firewall are turned disabled / off.

    Getting desperate - need advice. Thanks!
  23. nx1977

    nx1977 Well-Known Member

    C:/program files/HTC

    ;)
  24. Mark One

    Mark One Well-Known Member

    lol - drivers seem present and correct ....
  25. nx1977

    nx1977 Well-Known Member

    In both the HTC folder AND system 32?

Share This Page