General HTC Weather Widget

Discussion in 'Android Devices' started by Syv3n, Mar 7, 2010.

  1. Syv3n

    Syv3n Well-Known Member
    43

    Dec 2, 2009
    235
    33
    43
    I am having a problem with the HTC Weather Widget not updating when I unlock my phone. I click on the widget and bring up the settings and check the "Update Automatically" I get a "Data Warning"- This may result in additional charges from your wireless provider. Enable automatic download of weather data? and I click yes. Yet it wont save and it keeps coming unchecked after I exit the widget. I even tried hitting now and I tried a soft reset..Any help would be much appreciated.
     

    Advertisement

  2. mrichick

    mrichick Well-Known Member
    18

    Feb 18, 2010
    55
    12
    18
    Canton, Ohio
    I deleted the widget and then put the same one back on...so far so good but its only been a few hrs
     
  3. Syv3n

    Syv3n Well-Known Member
    43

    Dec 2, 2009
    235
    33
    43

    Do you mean just take it off the screen or can you actually DELETE the application and redownload it? I am still wondering how I get the update automatically to stay checked though?
     
  4. mrichick

    mrichick Well-Known Member
    18

    Feb 18, 2010
    55
    12
    18
    Canton, Ohio
    just took it off the screen and then re-added it under the HTC widgets. Mine doesn't stay checked either.
     
  5. irishpride

    irishpride Well-Known Member
    98

    Mar 2, 2010
    561
    76
    98
    Emerald City
    I'm having the same issue and I've deleted it and put it back on a few times now, nothing has worked. From what I've heard it won't update while your using WiFi, switch to 3G and everything works.
     
  6. slop bot

    slop bot Active Member
    16

    Mar 6, 2010
    40
    1
    16
    I just had that problem and it came back fine after taking it off the screen. Do you have abbotsford canada reappearing over and over? I did until I trashed the widget and started over.
     
  7. mrichick

    mrichick Well-Known Member
    18

    Feb 18, 2010
    55
    12
    18
    Canton, Ohio
    haha...mine was saying San Diego even though I'm in NE Ohio...go figure.

    Syv3n, a co-worker of mine made the switch to 2.1 and was also having weather widget non-compliance. We briefly compared some sync settings (seems like every time our boss walks in the room, we're holding up our phones)

    Under settings > accounts & sync, he had "background data" and "auto sync" unchecked. As soon as he checked both of those options, his weather and correct city info began populating properly. Maybe yours could be that easy?

    I don't know the optimal sync settings on that screen for balancing battery drain and refresh rates...maybe somebody who does can chime in on that. I think "background data" needs to stay on or it will generate error messages and you're stuff wont sync even when you try to do it manually...just my observation but I haven't played with it very much yet.
     
    isherwood likes this.
  8. Caddyman

    Caddyman Well-Known Member
    233

    Nov 10, 2009
    3,216
    638
    233
    Mechanical Piping Designer
    Delaware
    yeah, background data and auto sync need to be on
     
  9. OfTheDamned

    OfTheDamned The Friendly Undead
    VIP Member
    813

    Oct 29, 2009
    9,692
    8,365
    813
    Right Behind You
    "Use wireless networks" also needs to be checked under Settings > Locations for it to be accurate.
     
  10. Filipino.Cowboy

    Filipino.Cowboy Well-Known Member
    38

    Feb 17, 2010
    252
    17
    38
    Middle Tennessee
    This is also a problem for me and several others. However, one of the things 2.1 is doing right is keeping my weather widget updated :) So atleast, it looks like that bug is going to be fixed in 2.1
     
  11. smittythepig

    smittythepig Well-Known Member
    36

    Dec 29, 2009
    290
    1
    36
    Richmond, VA
    i had some odd problem with mine after upgrading to 2.1, where it showed my location as '5' - no idea what that's all about. the hard reset i did yesterday fixed it. it also showed me in Akron, OH at one point before the hard reset. i'm in virginia.
     
  12. abstractsimon2

    36

    Apr 11, 2010
    22
    1
    36
    IT Support Analyst
    Manchester, UK
    I had this issue too, everytime I selected automatically update and went back into the settings it was unselected again. I had background data sync already selected and was using just 3G. What I found it was was (as advised above) enabled auto-sync. As soon as I enabled that too I could put a tick in that box and it would remain in there and remain active. Just need to keep a closer eye on my 3G usage now!
     
  13. rick311

    rick311 Well-Known Member
    68

    Jan 31, 2010
    673
    44
    68
    the thing that sucks is in 1.5 it would update automaticlly even without BG data turned on. now you gotta have it on at all times for it to work. i used to get 2 FULL days without charge on 1.5, now im getting like 1.75 days.
     

Share This Page

Loading...