Huawei Ascend - How to do a Hard ResetSupport


  1. nuttmeg

    nuttmeg Well-Known Member


    next thing to do is flash it back to out of box stat...
  2. KFlannigan5

    KFlannigan5 Active Member

    I got this phone from a co-worker. She said when she was updating her internet connection was cut. When she tried to restart it stopped at the splash screen. I tried every possible thing I could read, most did nothing. this here method did the most...it produced a purple screen. I tried holding it for 5 minutes and nothing happened. I'd like to load CM7 on this thing and give it to a 7 year old as an iPod replacement. (she's beaten the heck outta the iPod so now it sucks)...so do you have any suggestions? She, and I, would greatly appreciate any you may have. Thank You in advance.
    BTW, It's an HUAWEI M860 for MetroPCS, other than that I know nothing about what the original firmware would be, or whatever else may have been done to it besides what I've previously posted.
  3. KFlannigan5

    KFlannigan5 Active Member

    CAn anyone help? This doesn't work at all for me
  4. nuttmeg

    nuttmeg Well-Known Member


    reverting back to stock, ok power down the phone and download and extract this to your desktop MetroStockRecovery-SCRIPTS.zip after you done that press and hold vol down, end key and tap power, your phone should be on the white huawei screen and it should stay there plug your phone to the computer via usb cable, now open the folder that you extracted and run both of these file, first run fastboot-windows you will see a black box come and leave quick, next run metroPCSStock-windows.bat than another black box will pop up and it will do its thing, once it finishes the phone will automatic reboot itself.
    KFlannigan5 likes this.
  5. KFlannigan5

    KFlannigan5 Active Member

    ....and nothing happens, thanks tho
  6. KFlannigan5

    KFlannigan5 Active Member

    just says "waiting for device". I have the drivers installed and adb recognizes it as an unknown device in recovery but....nothing more happens. Appreciate the help tho
  7. Scur

    Scur Well-Known Member

    You mean it says "waiting for device" in the console on your computer? And your phone was sitting on the white screen for a bit before you plugged in the USB?
    KFlannigan5 likes this.
  8. KFlannigan5

    KFlannigan5 Active Member

    yeah, it was on for like 3 minutes before I plugged it in. It's on the white HUWAEI screen. When I run the "metro...." it just says "<waiting for device>"...then no matter how long it sits there...nothing.
  9. KFlannigan5

    KFlannigan5 Active Member

    Omg it started to work!!!!!!!!!!
  10. Scur

    Scur Well-Known Member

    lol Surprise! Welcome to the wonderful world of the Ascend.
    KFlannigan5 likes this.
  11. KFlannigan5

    KFlannigan5 Active Member

    how long should the initial boot up take?
  12. Scur

    Scur Well-Known Member

    I've heard tell of some boot ups taking upwards of 10 minutes, though I've never had one do that myself.

    "All Ascends are not created equal."
    KFlannigan5 likes this.
  13. KFlannigan5

    KFlannigan5 Active Member

    well it's been a few, since I wrote that post "OMG..." I just re-did it to make sure all went well. And yeah, this is no EVO or Droid 3 or Thundervolt that's for sure. We shall see what happens. Thanks again for everything. I'll let ya know what happens
  14. KFlannigan5

    KFlannigan5 Active Member

    still nothing more than the "android" screen
  15. KFlannigan5

    KFlannigan5 Active Member

    adb says.... "? offline" in response to "adb devices" Is this a problem?
  16. KFlannigan5

    KFlannigan5 Active Member

  17. KFlannigan5

    KFlannigan5 Active Member

    I am ready to toss this thing. It's stuck on the Android screen. I've reset it 5 times now and waited ten minuted between each reset. I think it's garbage. Thanks for all the help
  18. KFlannigan5

    KFlannigan5 Active Member

    Guess everyone got busy doing other things. Thanks for all the help, greatly appreciated. The phone still hasn't gone passed the android screen so I'm thinking it's a) done, or b)....it's done. Thanks again.

    Now Imma have to cough up that $250 for an iPod :( hate Apple...too bad Android doesn't make something of the sort....now there's an idea.
  19. Scur

    Scur Well-Known Member

    At this point, I would check that my drivers are all good, pull the card and do a full format on it (I'm assuming this is alright, I always deal with Cricket), delete the files nuttmeg linked you to, then redownload them and start from the beginning. Doesn't take much to get a corrupted file, and if it's not perfect, these kinds of issues arise. I think it's probably happened to most all of us a few times.
    KFlannigan5 likes this.
  20. KFlannigan5

    KFlannigan5 Active Member

    Pull the card? There is no SD card...didn't know there was supposed to be one. Nothing says to write anything to an SD....
  21. Scur

    Scur Well-Known Member

    Got one floating around? Pop it in a card reader and into your computer, do a full format of it, stick it in your phone, and start all over again. If you're holding your phone looking at the front, it's on the left side near the bottom. Pop that tab thingy out and look.

    edit: Without the card, mine is stuck at the splash screen, too.

    edit2: Nope, just took a while, it's booting now.

    edit3: Well, that was a mistake. After putting the card back in, it's still not reading anything from it. Must have screwed with the a2sd or something. Well, fart.
    KFlannigan5 likes this.
  22. KFlannigan5

    KFlannigan5 Active Member


    So do I format and start again? Or....what? And will it run w.out the SD card after installation? PS, I'm quite fluent with computers, phones and the such. I just have no idea about this phone or what's the norm. And besides here there isn't really much support.
  23. Scur

    Scur Well-Known Member

    It seems that it will run without a sdcard, mine just did. Like I said, if you couldn't get it to flash back to stock, I'd re-download the link nuttmeg gave you, and start from scratch.
    KFlannigan5 likes this.
  24. KFlannigan5

    KFlannigan5 Active Member

    I've done the "start from scratch" thing like 5 times now. Only thing different is I'm trying it with an SD card installed. Praying and hoping. I don't have the $$ for the light bill, much less an iPod. But she's 7 and who can say no right?
    Is there anyway the .img that I have is broken? Did you download yours from somewhere else beside Nuttmegs link?
    I just don't get why everything will go as planned and then to have it not boot...I was thinking of taking the "system" image out and replacing it with Cyanogen's? When I extracted the zip no system img came up tho. I tried replacing recovery with Amon and CWM but nothing ever came of it. And as I type this I can tell ya that the phone is just sitting on the Splash. Idk, frustrating.
  25. Scur

    Scur Well-Known Member

    Maybe someone will jump on here and correct me, but I'm not sure you can just switch "images" like that.
    When my phone is at a standstill, and I can't really do anything, and I'm going to do everything from scratch, I flash back to stock this way. Works every time for me. Eventually, sometimes, but invariably.
    I have a whole list of other things I do, but that's the guide I use to start out. On the rare occasions it doesn't work, and still doesn't after about 3 attempts, I'll re-download from the links, and try again. I've just plain tried to brick this phone. I can't do it.

Share This Page