Huawei Ascend Y H866C ROOTED!!!

Last Updated:

  1. Scarsketch

    Scarsketch Well-Known Member

    Huawei Ascend Y H866C POOTED!!!
    If you have been lurking the posts on google for a root for the phone, you are just like me, so i decided to learn some things. I contacted GiantPune and we worked together applying this root:

    download poot, install it let it download and install ministro,

    start poot,it will then start ministro

    Ministro will create some libraries,thats ok.

    Poot will then start, make sure to press the poot button and then it will give you some code

    At the end of the code somewhere in there it should say sucessfully found and wrote su.

    press the built in rootcheck to see if you are rooted

    restart the phone go to the playstore and download Superuser.

    You are now fully rooted!

    All the thanks goes out to GiantPune for his awesome and funny creation.

    Let me know if this works and if I helped you,please press the thank you button!

  2. B33p3rz

    B33p3rz New Member

    Thank you...I bow down to the great pune...rooted and running super user...:) thank you so very much
  3. Dntknw8

    Dntknw8 New Member

    sorry to bother yall but i really dnt know alot about this root stuff, just what ive read on here .this is my first android phone. i tried rooting my huawei ascend y h866c. i used poot like the forum said. root checker said my phone was rooted. after i did that i was in some app and everything on my phone got erased. it was backed up, but i didnt flash my phone, can anyone help me, please!!!!!!
  4. Scarsketch

    Scarsketch Well-Known Member

    Turn phone off. Hold vol up and power button. Factory data reset. Reboot. If not vol up then vol down same sequence.
  5. WJKeene

    WJKeene New Member

    I went to sendspace and was able to download sendspace but could not get Poot from here because I had to download it to a prelisted set of folders which I could not access from the phone. So I downloaded it from other places and tried it. Every time it ran I get an error 22 "A demon materialized while pooting" "su binary was not written"
  6. chevyshaker

    chevyshaker Member

    ok people is there or isnt there a root app for the ascend y m866 ??????????????????????????????????????????????????????????????????
  7. t3084

    t3084 Well-Known Member

    I would suggest doing it all from your computer. unless you all have newer versions of the h866c, i would suggest it is either corrupted file download... or user error :/
  8. grimmchuck

    grimmchuck New Member

    I tried this step by step and I keep getting errors constantly. It alternates between error 22 and error 87. Will not work... Any advice?
  9. yoginigirl

    yoginigirl New Member

    I need to try this too, it looks a little complicated but my phone is so low on memory. I look forward to any help with this issue.
  10. pkelly041961

    pkelly041961 Member

    I tried installing superuser first, then root checker and finally installed z4root. I ran z4root to rousing success which was affirmed by root checker.

    I hope this helps.
  11. staci82

    staci82 New Member

    Hi everyone :) I.wish you guys luck on attempting to root this phone. I somehow managed it shocked even me LoL it took me several tries and amazingly enough I still have a functional phone.
  12. jjanna1969

    jjanna1969 New Member

    New User! first time on sight, and my issue was corrected! Feeling like a Guru ;) Thank you for such detail Metroid Scarsketch in your posting, It made an overwhelming process grasp-able!
  13. papacera

    papacera New Member

  14. papacera

    papacera New Member

    I take donations in paypal for all the accolades ya'll are gonna' shower me with, please no golden showers, I ain't that kinda guy.
  15. EarlyMon

    EarlyMon The PearlyMon Moderator

    You might not want to put down a contract for a new house from PayPal donations for links to someone else's work lol.

    Btw - did the method in the OP here stop working? Give you problems? That would be important information here. What happened when you tried it? Or did you not try it?

    Anyway, glad you're rooted, welcome to the forums!
  16. papacera

    papacera New Member

    Yah, it cleared out alot of bloat, and I was able to download the app I was after. Then because I'm brilliant that way, I went back to ops as normal without adding superuser and other good stuff. That was why I just posted quietly, no big banners or anything. But the steps I used worked perfectly, you too can be like that old commercial with Mickey, try it you'll like his facebook stuff is boring but worth it.
  17. EarlyMon

    EarlyMon The PearlyMon Moderator

    Yeah, you didn't answer my questions -

    Did you try the method listed in the first post here?
  18. papacera

    papacera New Member

    Yes. There, answered. Afirmative, answered again. That would have been the part when I said the "steps I used worked perfectly", oops answered again....heh heh heh. The phone was rooted. The data was moved as specified to the backup apps listed, thge data was recovered from the same programs, however I did not take advantage of the rooting as I should have. By not adding the after rooting apps recommended I was less than brilliant, hence the possible ambiguity in what was posted, I was endeavoring to allow others to explore the same path as I with perhaps more insightful results. I certainly hope this meets with your approval Mr. Moderator sir...anuthing else I can possibly help with please feel free to contact as previously. Yours as ever Steve

Share This Page