1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Huawei Fusion U8652 won't reboot into recovery


  1. Algorithmic

    Algorithmic New Member

    Hello all, I just registered hoping you guys might be able to shed some light on my problem. My Huawei Fusion U8652 won't reboot into recovery :(

    Here's how I got myself into this mess:

    First I rooted my Huawei Fusion U8652 using the SuperOneClick method.

    Then, unfortunately not knowing that I needed a special Clockwork mod for the U8652. I went ahead and just used ClockworkMod's "ROM Manager" app to Flash the ClockworkMod recovery. Once that was done I used ROM Manager to attempt to make a backup of the current ROM. At this point the phone tried to reboot itself to make the backup. However it was never able to get past the first screen where is has the large AT&T logo, and I had to eventually just pull the battery.

    Now it still starts up normally, and I can use the phone fine. But if I try to reboot into recovery, or do a factory data reset, or anything that requires a reboot, it never gets past the first AT&T logo screen and I have to pull the battery.

    Steps I've taken to try and fix this:

    I tried to do a factory data reset, that didn't work, since it requires a reboot. Then after searching around for a bit I found this: AT&T Fusion U8652 Clockworkmod (CWM) Recovery manual | AT&T cell phones|AT&T Phones
    and tried to use RecoveryClockmodByZaDkYn to install the recovery file. But because that requires a reboot when the device is plugged in, it wouldn't work either (my computer registers the device fine so that's not the problem).
    I tried all the volume down/power button holding combinations and all of them result in getting stuck on that first screen and me pulling the battery.

    My question:

    Is there a way to manually install that custom recovery boot file from the RecoveryClockmodByZaDkYn? The phone works fine, including the usb connection and file transfer. It just won't reboot.
    Also Is there a way to do a Hard factory reset? I would love to just start over and do this properly.

    Thank you!!

    Advertisement
    :
  2. Lebo

    Lebo Well-Known Member

    power + down for 10 seconds (a.k.a. Fastboot) should show on the phone as a frozen AT&T logo. Good news is that it IS in the mode ,at this point, to flash Zad's CWM. So plug that USB cable on in and run the instalador.bat.
    Algorithmic likes this.
  3. Algorithmic

    Algorithmic New Member

    Lebo- Thank you for replying! That's great news, I figured something else was supposed to happen at that point. Unfortunately though, after I hold power + down for 10 seconds and plug it into my computer with Zad's CWM instalador.bat running, nothing happens, it only ever says: <waiting for device>.

    I've uninstalled and re-installed the drivers on my computer a few times to see if that was the problem, but they work perfectly well when the phone is not in this mode. So I doubt that's the problem...

    My system is Windows Vista and I'm using this driver:
    AT&T Huawei U8652 Fusion Usb driver free software download | AT&T cell phones|AT&T Phones

    As well as the last ADB driver on this list:
    http://androidforums.com/faqs/443072-adb-guide-updated-12-05-2011-a.html
    (maybe there's a way to check if the phone is being registered by the computer in the correct way?)

    I think the problem is that I've corrupted the recovery boot by installing it from ClockworkMod's "ROM Manager" app, instead of the one from Zads. But really I'm just guessing. Is there possibly a way to just Hard reset the phone so I can rule that out and start over? Everything still works fine otherwise.
  4. SlashQuit

    SlashQuit Member

    I did exactly the same thing (used CW ROM on the U8652, and accepted the version number it came up with.) As Lebo said, you can still install CWM using the instaladot.bat without having to do the power and volume thing.

    I think what I did to get the Instaladot.bat to continue past the 'waiting for device' was to re-install the 'ADB' drivers. I had a copy from my phone, but I think you can also get them here;
    Downloads - Huawei Device Co., Ltd..

    Several times, WinXP would prompt me through the new hardware wizard when I plugged in the phone. I had to install the adb driver many times, even though it was already installed.

    Each time it was working properly, I would see "ADB something device" in the list of "safely remove hardware" entries.
    Also (but I'm not sure this confirms if it means it's detected), if I opened a command prompt and navigated to the adb.exe, a "adb devices" would correctly list the device instead of listing a line that says ????????.
    Algorithmic likes this.
  5. Lebo

    Lebo Well-Known Member

    Algorithmic likes this.
  6. Algorithmic

    Algorithmic New Member

    Thank you so much Guys!!! It worked, It was a driver problem after all. It turns out that my computer could properly install the drivers when it was in normal on mode, but in fast-boot, It would register my phone as a different device, one that wouldn't install the drivers the same way.

    Here's how I fixed it:

    I used the ABD drivers that Lebo posted above while the phone was on and in normal mode. This is neccesary so that windows can create a driver profile for the phone (since they only installed correctly for me in this mode).

    I then held power + down for 10 seconds and plugged it back into my computer. However, installing the same drivers in the same manner as before won't work if you try it again in this mode :/ , it will just keep telling you to reinstall them to no avail. But if you instead go into Device Manager>Android Phone>Device name and right click>properties>Driver tab:

    Then unistall the driver, and re-install the device using the profile made from when the phone was on and in normal mode, this requires you to uncheck the option that only shows you compatible hardware, and search for the previous setup out of the devices you have installed on your computer instead of using the drivers. This one worked for me, and I was then able to flash Zad's CWM. And now everything works great and I have a new ROM.

    Thanks again guys!
    emilatt likes this.
  7. jab471

    jab471 New Member

    I am having the very same problem. My laptop is windows 7 and my desktop is Ununtu. On my laptop when I have clicked on installado, my phone doesn't have recover installed. Somehow my computer isn't registering the driver? On Ubuntu, my drivers are automatically registered ... but all links are directed towards windows. Ugh.
  8. mrhex1

    mrhex1 New Member

    Yeah.........

    The only thing that this succeeded in doing is bricking my phone. It got stuck in a boot loop. Fortunately, I backed up the ROM onto the microSD. I got CWM to boot into recovery mode by holding down 'volume up + power' at the same time. I 'volume up + power' is the factory reset mode. Um this seems like a neat thing to try, but NEVER again for me.
  9. agentz28

    agentz28 Member

    this is what i did too. for some reason i still couldnt get the recovery mode. but when the ATT logo would be up after the whole
    "Pwr Button + Vol Dwn" thing, i would hit the power button one last time and then the rcovery mode would come up. it actually worked like 4 times like this for me.

    i got the C7 ROM installed, these links helped.

    ok this happened to me too. you need to do these steps:
    1. [TUTORIAL] ClockWorkMod Recovery Navigation for Noobs - xda-developers
    2. (optional) back up you contacts, backup SD card prior to following steps.
    3. place a copy of your ROM .zip file on the SD card's root directory (not in a folder).
    4. install the clock work mod from PC.
    5. install ROM manager. choose the option to boot into recovery mode.
    6. navigate to "backup and restore"
    7. select backup, it will start automatically. wait for it to finish, it will take a few minutes. "Backup Complete!" should appear.
    8. now navigate to "wipe data/factory reset" select yes and wait for comfirmation.
    9. now navigate to "Advanced". then navigate to "Wipe Davlik Cache" and select yes and wait for confirmation.
    10. navigate to "Install ZIP from SD card"
    11. navigate to "toggle script asserts". now select it until
    "Script Asserts: Disbaled" is read at the bottom.
    12. navigate to "choose ZIP from SDcard"
    13. Navigate to the .ZIP file you copied to the SD card. select "yes". when its done (should only take a minute). I reccomend powering off the device, removing battery for about 5 seconds.
    14. Reboot normally, everything should be fine.

    Also: if you wish to restore, follow the same basic steps. just go to the restore and backup option to choose the backup to restore from. it might also be a good idea to also backup the newly flashed phone rom to make switching back easier (but slower).

    email for help stshstsh@gmail.com
  10. flypsyde

    flypsyde New Member

    I was able to follow the instructions to root and install CWM on the U8652 from this site. I've since upgraded to CWM v5.0.2.7 using the link to the files that Lebo provided. My question is, if I was to do all of this for another U8652 phone, do I need to install the older version of CWM first? Or can I start right off with v5.0.2.7?

    Much thanks!

    -FlypSyde
  11. flypsyde

    flypsyde New Member

    I figured out the answer to my own noob question. If you have a never been rooted U8652 and want to try out some custom ROMs then I would recommend the following:

    1. do a factory reset (optional, this is only so that when you do your CWM backup it's clean)
    2. root the phone
    3. apply CWM v5.0.2.7 (you don't have to use the CWM by ZaD)
    3. backup your phone using CWM
    4. apply custom ROM
    5. enjoy!
  12. emilatt

    emilatt New Member

    Man, I need algorithmic back on here.
    Same issues he was having. Every time I reboot, the computer no longer recognizes the phone. I try to reinstall the driver but it never works. I have XP sp3 so the layout is a little different than in the thread. I do not have the option to unclick compatible hardware when searching for the driver. I go to the same place where the driver was located and it says "The specified location does not contain information about your hardware." So frustrating. Any ideas out there?
  13. Johnnay147

    Johnnay147 New Member

    hey guys for anyone else is the instalador.bat in spanish for anyone else? and when i do run instalador.bat nowhere does it say on there "waiting for device" ive installed all drivers already and reinstalled them twice. im trying to do this on a Huawei U8652 (AT&T Fusion). Im trying to install clockwork mod recovery for it so i can install a custom ROM but recovery wont install on it. someone please help. thanks
Loading...

Share This Page