1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Huawei U8520 Dual Sim problem with bootloop and no recovery menuSupport


  1. Despo

    Despo New Member

    Hi all

    first of all I apologize if this is not the right place to put my inquiry in, but I could not find the specific forum for this device.

    I have serious problem with this android mobile phone. it is pretty good phone very useful with dual sim function on of them is 3G with WiFi Hotspot but the problem that I have rooted the phone with superoneclick and I have installed a lot of apps in it modifying some language files then when I restart the phone to let the changes take effect then the mobile keep restarting for infinite. Tried to get in to the recovery mode by using Call Button+Volume up+Power but the screen became blank. I spent the whole day searching the the internet to find the solution but with no clue. the problem the device is new and not supported that much in the public forums. could not find Stock Rom. Huawei website and bulletin was not useful.

    is there any way to do it through USB or sdcard and How?

    thanks in Advance

    Advertisement
    :
  2. gilbertchege

    gilbertchege Member

    hi.. i think u will have to reinstall the stock rom/ firmware.. in that way the phone will be like it was when it was new..
  3. Despo

    Despo New Member

    thank u for your reply but my problem I dont have the stock rom and could not find it. I dont mind if the device went back to its original status.

    regards
  4. gilbertchege

    gilbertchege Member

    yeah i have tried looking for it but i haven't found it.. may be ask rob.. the head of this site..
  5. cehamata

    cehamata New Member

    Hello All
    I have the same phone u8520, the phone have not android market in the Andriod Chinese version 2.2 and i need to upgrade root to android 2.3 or higher.

    How i can get the ROM ?
    How i can install it ?

    Please help
    thanks
  6. sasuke002

    sasuke002 Member

    oh i cant go to revovery mode too.

    please help
  7. nu2andy

    nu2andy Well-Known Member

    Hi Despo,
    Here's an extract from a write up on Rooting & ROMing:


    1. Installing Custom Recovery
      • Extract PDAnet to a folder on your PC eg. C:\Downloads\PDAnet_files
      • Extract Ultrajack to a folder on your PC eg. C:\Downloads\UltraJack-recovery
      • Enter bootloader mode:
        • Turn off the phone
        • Hold down the POWER button, the VOLUME DOWN button and the END CALL (RED) button simultaneously for 5 seconds. The phone switches on and gets stuck on the Ideos logo screen.
    2. http://www.google.co.nz/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0CCUQ FjAA&url=http%3A%2F%2Falextheafrican.wordpress.com %2F2011%2F10%2F05%2Fhow-to-rom-dronix-onto-huawei-ideos-u8150%2F&ei=skKRT8TBNa-SiQeAtqSvBA&usg=AFQjCNFnpKlAWTvwbn-bFmXfmt1-cAW2jw&sig2=BncpJYZk-IMuhbt9KatrTw
    It might pay to have a look at this set of instructions and see if it helps.

    If you go to this link:HUAWEI IDEOS - Huawei Device Co., Ltd.. and search for your phone ie. U8520 Reach > choose your language > Software > there is a Kernel (Gingerbread) there to Download. Cheers Neil. ;)
  8. golfinho24

    golfinho24 New Member

    Huawei Deuce u8520 dual
    - Only get to red screen fastboot
    - tried to install multiple recoverys and nothing
    - power on stays on red screen
    - call + v.up + pwr screen off and center button light
    - end call + v.down + pwr red screen and "waiting update", connet to pc and "reading commands"

    and can't do anything!!!!

    Someone HELPME the phone has 1week
    I've got a stock rom but the only thing it has inside is a folder "image" with a file "factory.mbn"

    put that folder inside a black sd card, then, v.down + end.call + pwr and appear red screen and "ERROR: can't boot normal... start fastboot" "waiting update" !!!!
  9. nu2andy

    nu2andy Well-Known Member

    Here's a link to the Firmware: Johnny Paranoia's Other Blog: Huawei U8520 Duplex

    There seems to be only 2 available.
    I think it may be necessary to follow the Huawei Upgrade Procedure to get the phone back to "out of the box state".
    Quote from User FAQ's U8800. (This seems to be standard procedure for Huawei Smartphones.
    2.1 Forced Upgrade
    The forced upgrade method is as follows:
    Note: After the forced upgrade, all user data (contacts, text messages, and multimedia messages) will be lost.
    1. Go to Support - Huawei Device Co., Ltd.. and search for the latest U8150 version, download it to the local drive, and uncompress it to extract the upgrade file.
    2. In the SD card root directory, create a new folder named dload. Take the extracted upgrade file, UPDATE.APP, and copy it to the dload folder.
    3. Insert the SD card into the mobile phone.
    4. When the mobile phone is powered off, press the Volume +, Volume -, and Power keys at the same time to initiate the forced upgrade.
    5. After the upgrade is complete, restart the phone, and continue to use as before.
    Make sure your phone battery is fully charged before carrying out any Firmware Upgrades, and do not do anything with the phone until the procedure is finished otherwise you mat end up with a "BRICK"

    The above info is usually in the Download Firmware. Neil.
  10. aven4d

    aven4d Member

    I can't access recovery menu with my ideos u8150,it gets stuck in the ideos logo,that happened after installing Rom manager and flashed clockworkmod 3.0.2.4,I can't even factory reset in settings,help
  11. nu2andy

    nu2andy Well-Known Member

    Hi aven4d, I've just done 2 (two) boots into Recovery Mode to test the procedure and had no trouble doing it.

    YOU MUST PRESS the GREEN button and the VOLUME UP button and the POWER on button ALL AT ONCE and HOLD THEM for about 10 seconds.
    This enables you to due a Backup Recovery. Cheers Neil.





  12. aven4d

    aven4d Member

    yea i know, believe me i have tried that but still gets stuck in ideos logo,this happened after I flashed clockworkmod 3.0.2.4,okay am able to access the phone and use it,but am not able to go to recovery mod,I have tried factory reset in settings but still won't work,my only problem is the recovery mod,help
  13. nu2andy

    nu2andy Well-Known Member

    When you Rooted your phone did you install Titanium Backup and did you do a Nandroid backup? Neil.
  14. aven4d

    aven4d Member

    no I didn't,I just rooted it,and have never installed titanium backup
  15. nu2andy

    nu2andy Well-Known Member

    How to ROM Dronix onto Huawei Ideos U8150 | alex the african
    This link from Post to Despo is what you should follow. Read it through thoroughly and you'll see that there many steps to take BEFORE just "Rooting and ROMing" is carried out.

    You need to Download quite a number of Apps beforehand. See note about size of Micro SD card suggested. If it all goes South - you need a backup of your original ROM to recover with.

    Read the comments below the main Post and you will see that quite a few ran into similar problems like you have. Try a few suggestions that are listed.
    Removing the battery for a couple of minutes then using the suggested boot buttons after re-installing the battery may help. Good luck Neil.
  16. aven4d

    aven4d Member

  17. nu2andy

    nu2andy Well-Known Member

    Sorry I couldn't be of more help but it pays to research quite a bit before "Rooting" as problems can crop up and bite you.
    There are ways to "unbrick" an Android if you do the Google. Let's know how you get on. Neil.
  18. aven4d

    aven4d Member

    I'll try my best,thanks
  19. aven4d

    aven4d Member

    guys for those suffering the same problem as mine,am proud to announce that there is a way out and it's easy
Loading...

Share This Page