Huge (recall-worthy) problem with the usb port. If you're having the "car mode" problem, look here!Tips


Last Updated:

  1. steslatt

    steslatt Well-Known Member

    I've had this problem twice in the passed 2 weeks. Had my phone since July. Fist time I got the charging icon coming on and off the the second time about a week later it was going into driving mode. Gonna keep my eye on it, if it happens again i'll be sending it back.

    Advertisement
  2. vonlutt

    vonlutt New Member

    To build on the previous information, my phone now likes to think it is always plugged in unless I forcefully move the mini-usb around when i unplug it.

    Also, I cannot get my computer to recognize the device any more, sigh.
  3. Kie

    Kie Well-Known Member

    Interesting.

    I hear the problem is carrier-related. Must depend on some carriers that like to restrict 3rd party hardware being attached. The fact it's happening recently points to the 2.3.6 (or KK+) update. Of course, I could be 100% wrong, but maybe try downgrading to 2.3.5 or stock firmware and see if it solves it. Not helping my own case: I'm on 2.3.6 (custom rom) on Virgin Australia and it works fine!

    Agree with ironass, it doesn't seem to be a HUGE issue.
  4. steslatt

    steslatt Well-Known Member

    I can tell you it is not carrier related. It seems to be hardware related. Its a HUGE issue for the people that have the problem. It effects quite a lot of people as I have seen a thread on XDA as well.
    I first had the problem whilst using MIUI, I was ready to send it back so I reset everything put original firmware back on and it was fine after that. My first thoughts were that it was firmware or kernel related. It was fine for about a week then it happened again. This time I was on stock firmware so it can't be firmware or kernel.
  5. caseh

    caseh New Member

    Hellow, new user here :)

    Got into my car just now and it switched to car mode of its own accord 'wow thats clever' I thought...

    Now its going berserk and doing most of what a lot of people have mentioned. Kies says connected when its idle, switches to car mode, voice recognition setup runs. I also had an added effect of being stuck in my contacts, pressing the back softkey just sent it in circles.

    The battery also dropped from 60% to 20% after a restart...

    I've just popped the battery, blasted the USB mini port with an air duster and its currently charging off a USB cable connected to my laptop. So far so good, can do without this bullsh*t though to be honest.

    On a side note I just noticed my laptop no longer sees the phone as an external HDD when attached. Definitely something not quite right about this.
  6. Kie

    Kie Well-Known Member

    If it's hardware, that should be covered under warranty. A hardware issue would mean that someone who's making these things isn't doing a great job, since it works on some but not others. Or perhaps over-use of the usb port.
    I heard that cleaning the usb port with a toothbrush fixes the problem :p
  7. vonlutt

    vonlutt New Member

    Cleaning the USB with a toothbrush didn't work for me, unfortunately. Will try a can of air, though. We'll see if that works. This really sucks.
  8. ViGiLaNtE351

    ViGiLaNtE351 New Member

    Am getting the same problem just in the last 2 days.
    Had the phone since new 6months ago.

    Will not charge unless reset the phone. Computer doesnt recognise it anymore, but it did 3 days ago.
    The battery App shows its "Over Voltage" also will show a higher battery %age, then drop 20% after phone has had a reboot or i unlock the home screen

    USB port is clean. All 3 cables, (Computer, 240V, Car) have been tested and do the same thing, wont charge unless phone gets rebooted or battery removed/replaced.

    Still under warranty, but all this talk doesnt mean anything unless Samsung are aware of the issue. Do we know that they know its an issue yet?

    Cheers
  9. v3x

    v3x New Member

    Wish I had read this thread earlier and I would have been more cautious :( . Seems like I'm having all the problems described above. Just swapped my iphone 4 for a galaxy s2 earlier today and I've been struggling to get Kies to work alll night. The phone is roughly 2 months old and the previous owner never mentioned anything. Looks like I'll have to trace him up tommorow. Its running 2.3.5 UK Voda. I personally dont think its a software issue but cant vouch for it. New to the android scene :)

    So far I've tried dipping my usb cable into a bottle of acetone(nail polish remover) and put it back into my phone with no luck. The cable is not the original which was supplied if that says anything.

    The phone charges ok in the normal charger
  10. lolz84

    lolz84 New Member

    Hi there!

    First of all, this is my first post on androidforums.com, so, hi!

    I have the exact. same. issue. Well, all of those issues combined. While speaking to the official Samsung dealer in Israel, I was told that a certain amount of phones left the Samsung factory with a problem that is known to Samsung. The problem was described by the dealer as a problem with the PCB part which connects to the USB. It's lacks some sort of coating and is extremely sensitive to humidity which causes it to become corrosive and finally short.

    I don't know if it's just them trying to blame me for a faulty phone or if it is true. What I do know is that they will NOT repair the phone or replace it with another unit. FYI, I've had my SII for 3 weeks. I live in a dry climate, nothing every spilled on the phone or close to it.

    I hope you and the rest of us find a solution to this.
  11. steslatt

    steslatt Well-Known Member

    This has now happened to my Brothers SGS2 as well now. His is worse than mine and the problem won't seem to go away. He will be sending it back this week.
  12. v3x

    v3x New Member

    Lolz84 dont get yourself duped and have a go at them.

    Anyways I had a chat with the chap who I swapped with and he agreed to take it back. He had a chat with vodafone and they offered him a replacement for
  13. Crow2525

    Crow2525 New Member

    Having the same issue as original post.
  14. Crow2525

    Crow2525 New Member

    Background info:
    • Carrier: Virgin AUS
    • Purchased November 2011
    • Charge via 240v plug everynight
    • Never treated the plug very nicely, sometimes the phone would be holding its own weight dangling from the usb cord (accidentally of course)
    • Unrooted
    • Couple of pretty, but possibly virus like apps like those GoLauncher/SMS/Etc.
    • Same issues as original poster. Sometimes driving mode would restart itself over and over, seconds inbetween making the phone unusable.
    • Difficult to replicate the problem.
  15. Crow2525

    Crow2525 New Member

    Here is a movie of the phone doing as described. Don't really need the sound.

    Symptoms as described. I am under warranty still, but I think if multiple people are having a similar problem it should be well documented and investigated.

    Attached Files:

  16. sgilleland

    sgilleland New Member

    I first thought that it was something I did...I reset the phone and it immediately started the same things...exactly like the first post says.
  17. steslatt

    steslatt Well-Known Member

  18. Hawker

    Hawker Well-Known Member

    Touch wood, this hasnt happened to me, but it does indeed seem like an extremely common problem, which is almost certainly hardware related.

    To me, this seems to be a loose connection fault at the handset's USB port.
    Are most of you who have this problem frequently plugging the phone in and out? ie. to a car docking station, car charger, wall charger, PC USB cable etc?

    I dont have a docking station in my car so that does not apply to me, but when I plug the phone to the PC cable, if I ever have to unplug/plug it back in, I always do it at the PC side rather than the handset to minimise wear on the GS2's USB port. So I only plug it in at the handset port at the start of my PC session, and take it out there when I'm done. (eg. due to the unreliability of Kies, I frequently have to disconnect/reconnect, so I always do this at the PC side)

    I would wager if one of you was to open up your phone to the bones, the usb port connection to the board would be loose, or there would be some tenuous soldering points there.
  19. Slug

    Slug Check six! Moderator

    Agreed, thanks for pointing it out. Will do it right now.

    According to at least one afflicted member here, Samsung have acknowledged (at least to their dealers) that the issue is a badly-finished PCB. If it were simple wear-and-tear then my own would surely be suffering, as it's seven months old, charged daily and has been connected to a permanently-attached USB cable on my PC probably as many times.
  20. KingKullt

    KingKullt New Member

    Just bought a new SGS II last week and about a day or two ago it presented some problems mentioned here: MTP initializing every time, like it was connected to a USB port when its not; sometimes entering CAR MODE and switching back; locking up and restarting randomly. Sometimes the Clock screen is selected.
    Seems very unlikely that humidity is the issue, the phone is a few days old, came in a sealed box and not had contact to water. Very annoying problem with the phone, I was getting worried due to few reports on the web, thanks a lot to the other users by sharing their experience. I
  21. DeAtomizer

    DeAtomizer Member

    I had this problem, so i rooted my phone and i couldn't be happier. The phone is faster, cleaner and all the issues it used to have seems to have been caused by the telco's software. Anyhow, i rooted my phone over a month ago and it still is running peeeerfect. FYI that's all.
  22. late8

    late8 Well-Known Member

    A phone should be built to work without the need to root or mess around with settings just so you can get use out of the thing.

    Mine ran hot yesterday for no real reason. I played 2min of shoot the apple and it went very very hot. Just a couple of hours before the phone rebooted randomly.
  23. skc

    skc New Member

    Exact same problem here. Car mode comes on at the most inappropriate times. I'm pissed.
  24. hamiltonian

    hamiltonian New Member

    And another one. IIRC the issues started around Christmas time, possibly when I got the 2.3.4 update. Phone randomly enters Car mode, or (prior to the last hard reset), when I had 'agreed' to the Vlingo EULA, car mode would start up fully, and phone would ask 'what do I want to do'. It would turn itself on, irrespective of whether it was 'asleep' or 'off', causing battery loss - and once 'on', screen would stay on, regardless of other settings.
    I've tried rooting my phone, and de-installing Voice Command, but phone still tries to enter 'car mode'.
    Further, I've had one occasion so far when the USB card 'could not be read' - needless to say, the card itself was fine.

    The issue is extremely irritating and effectively makes the phone useless, as it now won't hold a charge during the working day, and I can't take it to meetings if it won't behave itself.

    Having just gone thro' a complete hard-reset, with only Titanium Backup re-loaded, I'll be trying the warranty route, as AFAIC the phone is not fit for purpose.

    If anyone has any details of the 'known warrany issue' (as in docs from Samsung), would be good to share them.
    cheers,
    h.
  25. JD42

    JD42 New Member

    Howdy all. I went through it all over the last few days and the fix literally yesterday with Samsung. It is a known fault with the USB Port. Not that they will call it a fault per say, but they will fix for free at a Samsung service depot in about an hour or so - I guess it actually takes their engineer 10 minutes.

    It was thanks to the forum that I knew exactly what to go and say and ask for. There was a certain amount of denial mode initially until I pushed it a little and referred them to the Internet forums like this one, then the issue was acknowledged.

    Fix for me was they replaced my actual USB Port and the internal connections that they said had coroded. The engineer admitted it was a common problem and any little bit of dirt, fluff, moisture could cause it. Good Luck.

Share This Page