I cannot get Kies to connect my Samsung Galaxy S3 LTESupport

Last Updated:

  1. harun2502

    harun2502 Member

    Hi , I just bought my Samsung Galaxy S3 LTE recently.

    I cannot get Kies to connect to my Samsung Galaxy S3 .

    I am using a Windows XP computer.

    When I open the Kies program on my computer it says SCH-I535 is connecting but it never connects. It happened once or twice, and after that it keep saying "connecting"

    How can I get this program to work?

    It also happend before to my Samsung Galaxy Tab 8.9. At that time, I was very hardly to snyn my tablet with kies. But now i changed from Iphone to Samsung, and I totally regret to buy Samsung due to this issue.

    Can anyone help me ?

  2. spagman72

    spagman72 Well-Known Member

    If you have other phone drivers other than the ones that Kies installed remove them.
    Then remove Kies and reinstall.
    Also make sure you are using a good data cable, no usb hubs... Change usb ports etc.
  3. goaty007

    goaty007 New Member

    Apart from Kies being absolute crap, try powering off your phone and turning it back on. Kies should then see your phone.
  4. okicu

    okicu Active Member

    also use your original cable on to usb port. I had the exact same problem. I use vista. and after countless hrs searching. samsung it turns out that samsung and windows don't play nice.

    uninstall all usb drivers and kies
    restart your computer
    download latest version of kies and download from samsung website latest SG sIII usb driver then,
    disconnect your internet
    install kies then samsung usb driver
    reboot computer
    then plug-in your phone
    let MPT and PTP install with debugging on and off
    try transfering
    then turn on your internet

    good luck. not sure which step worked for me but do all of them.
  5. andrzewi

    andrzewi Well-Known Member

    I agree a bit, but...
    IT IS 21-st CENTURY, isn't it?
    People who make the supersmartphones should make them user-friendly.
  6. razorwindmo46

    razorwindmo46 Member

    I had the same problem. Install latest Samsung drivers. Wait for windows to get all the updates and finalize install. Then plug in your phone and see if any drivers have a problem (you'll see a computer with something swirling about in the right side tray). After verifying drivers all good, Unplug the phone and install Kies. Now plug in phone and start Kies on both the phone then computer. It will take some time as windows is updating the drivers from Kies again (check the tray). If it still hasn't connected, unplug the phone and plug back in. It takes a few minutes to connect. I personally don't use or like connecting through the browser using Kies WiFi built into the phone. So I use the Kies app. I am using Win7 x64.
    As far as Kies goes, I think it is just added security as a backup. If you have a Google account and start a Google Plus account for music (Google Plus is free for 20,000 songs and steams to any device), everything is backed up. When adding contacts, make sure they are added to Google in the phone and next time you reset or upgrade etc. your contacts will automatically be added when you log your phone into Google account.
  7. elwin15208

    elwin15208 Well-Known Member

  8. evanserickson

    evanserickson New Member

    Open up samsung kies, then connect your device. If you are stuck at the "connecting" stage, like I was, and kies just can't seem to connect to it, that is because you don't have the right driver installed.

    While your phone is connected and in the "connecting phase", (on a mac) go to tools -> install drivers and it will auto detect the driver you need and install it.

    On a windows machine the process is similar, I am not completely sure how to get to the "install drivers" menu option but it shouldn't be hard to find just make sure the device is connected and in the "connecting stage."

    Here is the official Samsung/Samsung kies troubleshooting page for ya:


    P.s. I just got a 4g LTE Galaxy s3 too! I love it.

Share This Page