I can't download Jelly BeanSupport


  1. AdmiralOnDeck

    AdmiralOnDeck Member

    Hey, so I have a Samsung Galaxy S3 on At&t and I'm looking to upgrade it to Jelly Bean. As far as I know, the only way to do that is through Kies on the computer. I've read that that a box will open up letting you know that you can update and from there on you just accept and update it. So I downloaded Kies, plugged in my phone and nothing happened. I'm not really sure what to do beyond that. I don't want to root my phone or anything like that. What do I need to do in order to get the Jelly Bean update?

    Thank you and happy holidays!

    Advertisement
  2. grunt0300

    grunt0300 Well-Known Member

    O.K. Here's how it's done. First plug your phone into the computer using the power cord that came with the phone. Open phone and go to settings>developer options>check box that says USB debugging. Your phone should be detected by Kies, and it should tell you that you can upgrade to 4.1.1. Click on the upgrade, and let the phone do the rest. Do not unplug phone from computer until Kies tells you to do so. Enjoy.

    P.S. If Kies doesn't recognize your phone, delete Kies, and then reinstall.
  3. AdmiralOnDeck

    AdmiralOnDeck Member

    Hey so I tried that and nothing different happens. Kies is recognizing my phone but it doesn't tell me that I can upgrade to 4.1.1. Any other ideas?
  4. AdmiralOnDeck

    AdmiralOnDeck Member

    Also, I'm pretty sure kies does recognize my phone. it shows my phone number and my internal memory but it doesn't say what my current firmware version is. I don't know if that's significant or not.
  5. Mikenk

    Mikenk Well-Known Member

    I had the same exact problem when I tried to load kies. It seemed to be fine; I actually backed up my contacts using it just to try it; but it wouldn't show any info about the firmware version or any option to upgrade.

    It also made "Android File Transfer" not work anymore. as a result, I uninstalled it and didn't try anymore as I decided to stay on ICS. Too much risk and time getting JB with very little gain for my needs.

    However, if you really want to stick with it. I would keep uninstalling and reinstalling. My guess is one of the reinstalls will allow you to do it.

    Mike
  6. grunt0300

    grunt0300 Well-Known Member

    +1. Uninstall, and reinstall is the best way.
  7. Terry51

    Terry51 Well-Known Member

    in kies. Have you gone into Tools and looked at "Firmware upgrade and installation". Here it will ask you to input your phone model and S/N and then it should look for the latest update for it?
  8. AdmiralOnDeck

    AdmiralOnDeck Member

    Yeah, I've tried uninstalling and reinstalling it about 5 times and nothing changes each time.

    When I go to tools and select the firmware upgrade and installation, i enter sgh-i747 in the model number, kies freezes and i have to shut it down.

    I have windows 8 on my machine, is it possible that's making a different?

    Thanks for all the help so far guys
  9. AdmiralOnDeck

    AdmiralOnDeck Member

    Also, this is my first phone I've had that wasn't an iPhone so it's possible there could be some step that is really obvious to you guys that I don't know about.

    Thanks guys!
  10. Terry51

    Terry51 Well-Known Member

    Have you tried entering GT-i9300 for the model instead. Thats what I did to upgrade my s3 with kies and I never had any issues.
  11. AdmiralOnDeck

    AdmiralOnDeck Member

    Yeah, I tried entering that in but it froze kies as well.
  12. thequeenscheese

    thequeenscheese Well-Known Member

    ive had endles issues with kies not working go to sammobile and download the relevant jb rom, download odin and use that theres plenty of instructions online to do this.. thats wht ive just done to get 4.1.2 update as my kies kept crashing out..

Share This Page