I deleted email.apk and I want it back


Last Updated:

  1. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    I've tried many different email.apk's on the internet trying to get this app back but no luck. Some just don't work and other give a parsing error.

    I have LG Ally 2.1 update-1 and if someone could just give me a copy of the email.apk, please!

    I need this for my work and i accidentally deleted it. help me
     

    Advertisement
  2. myfishbear

    myfishbear Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    299
    Likes Received:
    62
  3. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    do you think, if i wait, that 2.2 update will reinstall it? I'm not comfy with flashing rom. Never done it and it scares me from what I read
     
  4. dots

    dots Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    965
    Likes Received:
    245
    I actually have all stock apk's for the ally uploaded. If you would like i can link it to you.
     
  5. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    if it will work. the previous statement was it wouldn't
     
  6. dots

    dots Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    965
    Likes Received:
    245
    It wouldn't hurt to try?

    Here's a link to the stock email.apk that is shipped with the ally.

    Email.apk
     
  7. death2all110

    death2all110 VIP Member VIP Member

    Joined:
    Jun 25, 2010
    Messages:
    1,995
    Likes Received:
    1,208
    you also need the odex file or it wont work properly. goes in /system/app. ive removed the apk and installed it just fine numerous times BUT fails without odex file so you also need the odex file. Both Email.apk and Email.odex Here:
     

    Attached Files:

  8. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    I get error: "application not installed"

    errrr so close!
     
  9. myfishbear

    myfishbear Well-Known Member

    Joined:
    Sep 5, 2010
    Messages:
    299
    Likes Received:
    62
    hey i told you i had the same problem lol reflash your rom or flash another:p... it is the only way i know of. if you are scared just take a xanax before you do it lol. here is what you do. get velocity .2 then get drellisdee's recovery tool not clockworkmod or allyRR and just flash it. it is not hard. people just have problems because they forget to flash their stock recovery afterward but you do not have to do so with drellisdee's tool. bty when you flash, dont use a shitty computer.
     
  10. jetblack

    jetblack Well-Known Member

    Joined:
    Sep 8, 2010
    Messages:
    49
    Likes Received:
    5
    Did you reboot your phone after installing it? I had that happen with system apps, but restarting the phone usually fixed it.
     
  11. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    I did a hard restart and nothing... I guess I have to grow a pair and learn how to flash
     
  12. dots

    dots Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    965
    Likes Received:
    245
    It is not recommened to use the AllyRR tool though because the recovery is out of date. . If you are going to use drellisdee's recovery atleast flash the newest one. It's not hard. :)
     
  13. jetblack

    jetblack Well-Known Member

    Joined:
    Sep 8, 2010
    Messages:
    49
    Likes Received:
    5
    It could also be the permissions on the files. They often get clobbered in the download-copy to SD-move to /system process. Do you have a terminal emulator that you can check them with? Are you familiar with UNIX permissions?
     
  14. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    what about all this shit i'm reading about clearing cache
     
  15. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    I changed permissions with root explorer
     
  16. death2all110

    death2all110 VIP Member VIP Member

    Joined:
    Jun 25, 2010
    Messages:
    1,995
    Likes Received:
    1,208
    connect to adb and try this:
    Code (Text):
    1.  
    2. su
    3. mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    4. adb push /sdcard/Email.apk /system/app/Email.apk
    5. adb push /sdcard/Email.odex /system/app/Email.odex
    6. chmod 0755 /system/app/Email.apk
    7. chmod 0755 /system/app/Email.odex
    8. reboot
    9.  
     
  17. x-amp

    x-amp Well-Known Member

    Joined:
    Jul 14, 2010
    Messages:
    79
    Likes Received:
    14
    i had this problem a couple of days ago myself. all i did was
    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    adb push /sdcard/Email.apk /system/app/Email.apk
    and it installed fine.
    my problem was that i kept getting connection errors after updating the firmware, so i figured I'd just reinstall it. i later figured out i needed to push it back onto the phone :p
     
  18. acura2g

    acura2g Member This Topic's Starter

    Joined:
    Sep 26, 2010
    Messages:
    10
    Likes Received:
    0
    I went velocity 0.2 . Problem solved
     

Share This Page

Loading...