1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

I got root!!!


Last Updated:

  1. androidphiltn

    androidphiltn Active Member This Topic's Starter

    Joined:
    Sep 4, 2010
    Messages:
    44
    Likes Received:
    3
    Just hit up YouTube... There was a photon root vid that worked great! Just search it. One Click Photon Root!
     

    Advertisement
  2. Beach_Head

    Beach_Head Active Member

    Joined:
    Sep 8, 2010
    Messages:
    33
    Likes Received:
    1
    How about helping with a full system dump?

     
  3. kane1513

    kane1513 Well-Known Member

    Joined:
    Aug 30, 2010
    Messages:
    49
    Likes Received:
    2
    Can this be confirmed?
     
  4. mdthomann

    mdthomann Member

    Joined:
    Apr 29, 2011
    Messages:
    6
    Likes Received:
    0
    I have root.... followed photon 4g directions from [ROOT] Photon Torpedo, dockless root access - Page 29 - xda-developers using adb.

    Here is an expanded version of my earlier post that attempts to be a Dummies Guide. A few things:

    1. Turn on USB Debugging in Menu/Settings/Applications/Development/USB Debugging - check the box.
    2. From the market download and install the Superuser App to your phone. You may be asked to update binaries but you can't till you're rooted. It's OK as is.
    3. Download and install the drivers to your PC from the link in step 9 below.
    4. Download both the ADB package and the torpedo root file to your PC from the link in step 9 below.
    5. Create a folder on your C: drive called Root.
    6. Unzip the ADB package to the Root folder and move the torpedo root file there as well.
    7. Plug your phone into your PC with the USB cable. Set USB Settings to Charge Only. (I didn't change this myself but others report better success this way.)
    8. From your PC click Start:Run: type CMD and click OK.
    9. Enter the prompts shown at How To: Root Motorola Photon 4G - BriefMobile

    IGNORE error messages - just enter the lines shown.
    The screen shot below is what a successful root session looks like and takes less than 2 minutes. Note the spacing when typing. It should look exactly like the screenshot.
     

    Attached Files:

  5. souljerzofligh

    souljerzofligh New Member

    Joined:
    Jun 2, 2011
    Messages:
    2
    Likes Received:
    0
    Yep Yep Yep !!!! worked for me too!! Man you rock!
    :D:D
     
  6. matt88si

    matt88si Well-Known Member

    Joined:
    Aug 24, 2011
    Messages:
    259
    Likes Received:
    31
    Okay so I'm feeling the urge to root my Electrify tonight using this method. I just have a question, though: What ROMs are available for the phone and which would you prefer using?

    I really like the layout of ICS so if there is a ROM for that, I'd love to get it. :)
     
  7. smipat42

    smipat42 New Member

    Joined:
    Nov 19, 2011
    Messages:
    1
    Likes Received:
    0
    that was way easier than the desire. Thanks a million man!!
     
  8. matt88si

    matt88si Well-Known Member

    Joined:
    Aug 24, 2011
    Messages:
    259
    Likes Received:
    31
    For some reason the link for the Photon Torpedo is broken and cant be found by Google. =/

    Any ideas of an alternative?
     
  9. slicedcheese

    slicedcheese New Member

    Joined:
    Nov 23, 2011
    Messages:
    2
    Likes Received:
    0
  10. mdthomann

    mdthomann Member

    Joined:
    Apr 29, 2011
    Messages:
    6
    Likes Received:
    0
  11. mdthomann

    mdthomann Member

    Joined:
    Apr 29, 2011
    Messages:
    6
    Likes Received:
    0
  12. cushionsurfer

    cushionsurfer New Member

    Joined:
    Dec 15, 2011
    Messages:
    1
    Likes Received:
    0
    Root worked but each time I use a root only app I get a notification that says "# Your su binary is outdated". How can I update the binary? I tried doing a system update but needs wifi to download and is now stuck on my notifications menu. Andy advice would be appreciated. I came to this from a rooted DROID X and like the phone, but isn't near any many things available for the electrify as the DROID X.

    EDIT: I figured it out within minutes of posting this lol. I love the info you all have posted. Very good stuff and works great. Keep up the good work!!!
     
  13. agroom

    agroom Active Member

    Joined:
    Aug 10, 2010
    Messages:
    31
    Likes Received:
    2
    Just attempted root with the singleclick version suggested by slicedcheese and failed. root.bat said it was successful, but none of my apps are getting root access.

    I tried running root.bat again with no success. Also tried the command line version with no success. Is there something I'm missing?
     
  14. pavilion366

    pavilion366 New Member

    Joined:
    Jan 11, 2012
    Messages:
    2
    Likes Received:
    0
    Last night Root Checker said i was rooted. Checked again today, now it says i don't have proper root access.
     
  15. pavilion366

    pavilion366 New Member

    Joined:
    Jan 11, 2012
    Messages:
    2
    Likes Received:
    0
    Nevermind, i found the problem. It got toggled off somehow in Superuser. You will have to forgive me for my newbie-ness.
     
  16. ERD42420

    ERD42420 New Member

    Joined:
    Jul 18, 2011
    Messages:
    2
    Likes Received:
    0
    What if i have a MAC? What do i do?
     
  17. Bi0ChemicalWar

    Bi0ChemicalWar New Member

    Joined:
    Jan 19, 2012
    Messages:
    1
    Likes Received:
    0
    This method to root my Motorola Electrify was unsuccessful. Would someone please help me to figure this problem out or help find a solution so that I can root the new Motorla Electrify. E-Mail me at chrsclark777@gmail.com or contact me via gtalk. I would really appreciate it.
     
  18. golfnut

    golfnut Member

    Joined:
    Sep 21, 2011
    Messages:
    12
    Likes Received:
    0
    I was unsuccessful as well.......until I opened the .jpg image in mdthomann method. The screenshot will show you exactly what to type in and where.
     
  19. ipyongs

    ipyongs New Member

    Joined:
    Feb 25, 2012
    Messages:
    2
    Likes Received:
    0
    Do you guys have version 2.3.5?

    Thanks.
     
  20. Herach

    Herach Member

    Joined:
    Aug 9, 2010
    Messages:
    6
    Likes Received:
    0
  21. Manatees

    Manatees New Member

    Joined:
    Apr 16, 2012
    Messages:
    1
    Likes Received:
    0
    This page will not let me download the drivers.. I'm not sure if the links are down or if it's my computer. I would really like to root my electrify.
     
  22. Greenbean

    Greenbean Member

    Joined:
    Sep 21, 2010
    Messages:
    8
    Likes Received:
    0
    I have tried this three times on an Electrify and no go,

    What am I missing?
     
  23. camp969

    camp969 New Member

    Joined:
    Mar 5, 2012
    Messages:
    1
    Likes Received:
    0
    i figured out that before typing all the commands in the command shell, you need to make sure to grant permission to make changes to the photon-torpedo.tar file.

    just right click on it, go to properties, go to security

    i set mine to all users can make any changes

    then it should find the file


    now i got rooot!!
     

Share This Page

Loading...