I keep getting "Google Sign-In error" on my phone - How do I fix this???Support


Last Updated:

  1. Isthmus

    Isthmus Well-Known Member

    This has been going on for months now and is driving me insane. I swear it is so bad I'm ready to chuck my old phone and run into the arms of apple.

    I keep on getting an erro message on my phone that says: Google Sign in Error for myemail@gmail.com

    The error asks me to enter the word i see in one of those account verification puzzles.

    You would think that entering it would solve this, but no. at a minimunm I find myself having to enter the damn puzzles 3 times before the damn thing takes and stops showing up (and yes I am entering them correctly). On a bad day I've had to enter the damn puzzles as much as 12 times in a row, before Android was satisfied. The worst part is that this is not an occasional occurrence. Lately is happening every day, sometimes four to five times a day, and every time I'm having to enter the freaking puzzles.

    I'm ready to throw this thing in the garbage.

    If anyone knows how to resolve this so that it stops happening I would be extremely grateful.

    BTW, The phone is a Motorola Droid running 2.2 which I've had for a year and a half. I've generally been please with the phone and love android, but at this point this annoying bug is really souring the experience and usability of the phone and my renewal is coming up so switching is a very real option.

    Thanks in advance for your help.

    Advertisement
  2. AndroidSPCS

    AndroidSPCS Well-Known Member

    Have you tried a factory reset?

    save your data first (make sure your contacts / calendar are synced to your online account), save SMS using apps from the market place, voicemails, etc.

    Then click on "menu" then "setting" then "privacy" and click factory reset.

    It will flash the phone to factory state and you can sign in again. That may fix the issue.
  3. Isthmus

    Isthmus Well-Known Member

    Sadly yes, I've done that once before and It didn't solve the problem.
  4. AndroidSPCS

    AndroidSPCS Well-Known Member

    I would advise try another factory reset, go to recovery and wipe dalvik cache, wipe cache, as well.

    And also try changing your Gmail password before you do this, and see if that fixes it, or change your pw afterwards, too see if it helps.
  5. muziqaz

    muziqaz Member

    Ok, I am having same thing. Every single day I get a notification. But the thing is I am able to check my gmail, go on internet and phone functions as it should.
    Also I will not reset my phone as it has stuff which would be wiped without the ability to save that data, and I don't really want that.
    It all started just few days ago. I never had this before ever in two years.
    this is a sequence of screenshots of the problem: http://i917.photobucket.com/albums/ad13/muziqaz/HTC Desire_ Nexus S/signinerror.jpg
  6. vey

    vey Well-Known Member

    I fixed an Apple phone that had the same trouble with Google once. Went in on a PC and changed the password in Google, then changed everything to the new password.
    johnlgalt likes this.
  7. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member


    Also, check in your Google account online and see if you have enabled two step verification, if so try disabling it and see if it helps.
  8. publicanimal

    publicanimal Well-Known Member

    Yeah, I'm willing to bet that you have enabled two-step verification. You may need to set up an application specific password. Just google "application specific passwords" and you should see what I mean.

    I've been using two-step verification for a while, and it can be annoying sometimes but it's an awesome security feature. I love the Google Authenticator app.
    cwright likes this.
  9. classact

    classact New Member

    I have been having the exact same problem. I checked and I do *not* have two-step verification enabled. It is becoming increasingly annoying. I wish I could find a simple fix.
  10. slovendroid

    slovendroid New Member

    ...maybe is not simple, but here it is (it helped me, and yes, I was pissed off too):

    I've got two google accounts on my Wildfire, one using 2-step verification (2SV) and the other one not using 2SV...both with same problem, mentioned above...

    My solution? You must create 2SV and follow the instructions on your google acount on your pc:

    - click on your accounts name in above right corner in gmail and click account settings
    - find Using 2-step verification and click on it and start setup
    - follow the instructions // after you're done with setup, scroll down and click on Manage application-specific passwords
    - you'll be asked to enter your password again - do it so
    - on bottom find your self a name for your device or application (androidphone for example) and click Generate password
    - those 16 letters are correct password for your android and NOT the one you use for gmail

    ...hope it helps
    bye
  11. droiduserR2D2

    droiduserR2D2 New Member

    Hello Droid users.
    I also had this issue.
    The Answer is as follows:
    What I have found is that a second account is set up on the phone.
    You need to do one of the following.
    1. Add a new gmail account - then remove it, by setting factory reset.
    2. Going to your verizon store and having the Customer Service rep fix it.
  12. visisufi

    visisufi New Member

    My android was bugged with such alert message before even though I still can access to Gmail and other Google products as usual...

    What I've done just delete my account and setup it back again and the alert message gone.
  13. guycanu

    guycanu New Member

    this problem can be fixed in google chrome. Go on yout PC in google chrome and you will see a key on top right of your pc with a ! sign on it. Click on that and do what they asked and that should remove the sigh on your phone

Share This Page