I may have a data issue with my new MT4G?Support


Last Updated:

  1. Nutzer

    Nutzer Member This Topic's Starter

    Joined:
    Nov 21, 2010
    Messages:
    5
    Likes Received:
    0
    All,

    Having this weird sporadic issue with my phone where I would have full bars, shows an H but I can't get on the internet. I noticed a couple of times last night, and I first rebooted the phone, everything came up fine, then later on that night same thing, then I proceeded with switching on my wifi, worked, then turning wifi back off and it worked again. This morning, I woke up, tried getting on the net, same thing, turned wifi on, tested by going online, and it worked, email came through. Turned off wifi, and the data is working now.

    Seems like my data just stopped working and it need to be refreshed by turning on wifi or by rebooting.

    Anyone know of this issue?

    Please help.
     

    Advertisement
  2. GODMODE

    GODMODE Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    197
    Likes Received:
    7
    I had a similar if not exact issue happen to me. Turned out to bethe sim card. It was an older one and it was unable to provision certain part of the network. Once tmo swapped it out, the mt4g has heen fast and flawless.
     
  3. vnguyen972

    vnguyen972 Active Member

    Joined:
    Nov 16, 2010
    Messages:
    41
    Likes Received:
    2
    This happened to me after the first day of usage of the phone. I had Smartphone plan with t-mobile and when I first got the myTouch 4, it worked perfectly with my SIM card but then after a day, it stopped working. I called TMobile and turns out they had to put mine on 4G network... after that I had no problems at all.
     
  4. phatdaddy60

    phatdaddy60 Member

    Joined:
    Sep 7, 2010
    Messages:
    6
    Likes Received:
    0
    Something else I read on the TMobile forum and it worked for me. Log into the T-Mobile site and ensure your MT4G is listed as your current phone. After a day,I received the OTA update and the phone is working flawlessly for the data side (except I live on the fringe of a tower so am on Edge sometimes at home, then I just go to wifi.
     

Share This Page

Loading...