I need Advanced Help with Updater-Script


  1. argedion

    argedion The TechnoFrog Moderator

    I have downloaded the latest Beats Audio Flash Zip I was wanting to change the updater-script file to mount system and then unmount system and reboot

    This is the Original updater-script

    Code (Text):
    1. ui_print(" Beats Audio ");
    2. ui_print(" By: RockoDev ");
    3. ui_print(" Installing... ");
    4. package_extract_dir("system", "/system");
    5. ui_print(" Installed ! ");
    6. ui_print(" Reboot Now ! ");
    This is what I am wanting to do:

    Code (Text):
    1. ui_print(" Beats Audio ");
    2. ui_print(" By: RockoDev ");
    3. ui_print(" Installing... ");
    4. mount("MTD", "system", "/system");
    5. package_extract_dir("system", "/system");
    6. unmount("/system");
    7. ui_print(" Installed ! ");
    8. ui_print(" Rebooting Now..... Goodbye! ");
    9. run_program("/sbin/reboot");
    I get the error "Mount is expecting 4 args got 3. I have tried adding a -w to it to hopefully be the argument it needs but I got Error 7 from that then last attemp I got Error 6 tried to take it back as it is above and got bad file so I figured I need to ask

    I've tried changing the update-binary as well but get the bad file error message as well. The above mount has worked for me in the past on other projects

    Advertisement
    :
  2. CapThrowback

    CapThrowback Well-Known Member

    I'll upload the file I created, and you can compare the script and binary, if you'd like (or I can just upload the binary and script). In mine, I also mount data, for those ROMs (Sense 3.5) where the libs reside on the data partition.

    Your mount commands look fine, though.
    Rxpert83 and argedion like this.
  3. argedion

    argedion The TechnoFrog Moderator

    Hmmm Well its the Nitrous ROM that I'm using with I think is 2.1 because its based of the 4.67 release. but yeah lets see whats going on. I know the mount command works for when building roms and I have changed the update-binary to the latest stock one but still get errors. so I'm just a bit dumbfounded
  4. CapThrowback

    CapThrowback Well-Known Member

    When you say latest stock binary, where did you get it from? I was suggesting that you take one from a ROM or kernel zip, because the ones from an official OTA will also likely require 4 arguments. Maybe uploading mine will help you find the difference (but I think it's the update-binary).

    P.S. The mounting data shouldn't make a difference either way. It just makes the zip work more universally.

    EDIT: updater-script & update-binary attached.
    argedion likes this.
  5. argedion

    argedion The TechnoFrog Moderator

    Ok thanks i'll check that one out and see. The update-binary & script that are in the beats came from them, I changed the update-binary from a rom that I have been playing with which was based on the latest OTA and the mount command has worked fine with it for that so don't know
  6. argedion

    argedion The TechnoFrog Moderator

    nope got the same thing. So I started thinking is it the files or is it my recovery (Amon RA Style 3.11) I'm going to flash 2.3 and see if it works then. One more thing I want to ask to make sure I'm not screwing up the Zip is in compression and not in Store mode correct?

    EDIT: Flashed back to Amon RA 2.3 got the same error. So that wasn't the issue. Ok so running out of ideas here.
  7. CapThrowback

    CapThrowback Well-Known Member

    I don't ever touch the compression of the zip file. I literally just drag and drop the updated binary and script into the file using 7-zip, and I've never had a problem. I can give you my whole zip, if you want. You can try just dropping your script into it and see if it works. I know mine works as-is.
    Rxpert83 likes this.
  8. argedion

    argedion The TechnoFrog Moderator

    Yeah go ahead and send it. Oh I hadn't messed with the zip other than updating I was just thinking about extracting and seeing if recompressing it would work
  9. CapThrowback

    CapThrowback Well-Known Member

    Here you go!

    BeatsAudiob0314.zip - update-binary & updater-script updated

    Let me know if it doesn't work for you for some reason. Maybe it'll help you figure out what's going on with yours.
    argedion likes this.
Loading...

Share This Page