I need to get back to S-On, unrooted and running orignal T-Mobile UK ROM.


Last Updated: 2012-02-10 14:32:56
  1. notebook

    notebook Well-Known Member

    The above instructions will only work for Revolutionary rooted phones. I'm not familiar with the Goldcard way of rooting phones; it's probably conflicting with the Revolutionary root. If you're using the SD card with the Goldcard on when carrying out the above, that might be causing a problem. Try a fresh SD card for the PG88IMG.zip. But, again, there might be a conflict that's preventing that.

    Are you trying to install an RUU.exe or are you flashing an RUU ROM.zip?

    It might be that you can get to where you want via the Goldcard, but it does say Revolutionary on your boot screen so I don't know how that may affect things.
  2. HYCAET

    HYCAET Guest

    I'm no longer rooted. I have S-off, and made a gold card so i could install a stock RUU. thought i'd then be able to get an OTA to bring me up to 2.3.5. That didn't happen so I used to RUU for that, but it just gets stuck.

    I've just tried a different SD card but nothing happens. My concern now is, that i've got S-off, and can't get back to S-on, so presumably will never get OTA updates again.

    EDIT: I'm talking RUU.exe.
  3. notebook

    notebook Well-Known Member

    Android Flasher might be worth a try - it simplifies the flashing process. However, I don't know how or if it will work on your phone, so use it at your own risk. You don't need to be rooted to use it, just S-Off'd.

    If you decide to use it, make sure you have the right kind of HBOOT image file, i.e. the one linked to in this thread (PG88IMG.zip), although you'll need to unzip it first to use it with Android Flasher.
  4. HYCAET

    HYCAET Guest

    Thanks so much for your replies. I tried everything I could but had no luck.

    In the end I decided to root again and I'm not running a pre-root 2.3.5 with Sense 3.0

    It works perfectly so I'm happy now. I really enjoy the whole rooting thing so glad I've done it now.
  5. armenayva

    armenayva New Member

    @notebook and @HYCAET
    I have rooted my desire S with revolutionary, so I have S-off, hboot ver 6.x.x and flashed the zip file provided in revolutionary's website to gain root access, I did not put any custom rom! my rom version is 1.47.401.4.

    I want to install this RUU_Saga_S_HTC_Europe_2.10.401.5_signed_prerooted
    or I am hoping to find a Singed and not rooted version.

    Initially I rooted my phone to install sense 3 but then I found out that there is official update.

    what would be the correct approach to this.

    I understand it has to start with hboot replacement to 0.98.000x

    please note that this update changes hboot to 2.x version.

    I am kind of new to all this so I would appreciate a step by step guide(for a dummie)!

    thanks in advance
  6. notebook

    notebook Well-Known Member

    @armenayva

    You could follow HYCAET's example and try the pre-rooted RUU you mention. This might work with your HBOOT version, which is the same as HYCAET's. It worked for him!

    Alternatively, you can follow the instructions here (earlier in this thread).
  7. tsaguna

    tsaguna New Member

    notebook

    my phone is not branded can i follow this instruction?
  8. tsaguna

    tsaguna New Member

    i tryed both PG88IMG.zip but S is off help please
  9. FoX777

    FoX777 Well-Known Member

    You really need to give more info. what you did to get s off, what's your hboot, are you sure the updater file didn't work.

    what you mean, but s is still off?

    Have you located what RUU you will be putting on. have you looked into other ways of flashing the hboot.
  10. koral

    koral Member

    Mine just flashes for a second and nothing happens...
  11. HYCAET

    HYCAET Guest

    I hadn't been able to change my Hboot for months, but this week I asked over on XDA and this is the answer I got, and it's worked for me - using the ENGHbOOT file linked to by notebook.

    -Download this file, it has the adb and fastboot files needed to proceed
    -Extract the file to "c:\" so that the path looks like this C:\android-tools
    -Install HTCDriver (Fastboot drivers) (should already be installed from revolutionary) but here's the link again
    -Open cmd and type "cd/"
    -then type "cd android-tools"

    *To test whether you have set up all the files correctly and your phone is connected correctly you can do the following;
    *Plug your phone in (when plugging in select CHARGE ONLY (i.e. leave on the home screen)
    *In cmd type "adb" and press enter, it should show a list of commands, then type "fastboot"and press enter, it should also show a list of commands)
    *If both these commands work you have extracted the files to the right place and have setup cmd right.
    *then type "adb devices"
    *Should show connected phone serial if not then try get the latest HTCdrivers


    Flash the ENG HBoot

    To flash the ENG HBoot you can use one of these methods;
    1) Fastboot
    -Place the .img file (extracted from PG88IMG.zip) in C:\android-tools
    -Boot phone into fastboot
    -Run command "fastboot flash hboot engHBOOToverARX.img" in CMD
  12. FoX777

    FoX777 Well-Known Member

    From here under section 2
  13. HYCAET

    HYCAET Guest

    I'm not looking for props, just sharing some info.
  14. UnROOT

    UnROOT New Member

    Hi guys, i received a DESIRE S, but this phone has been with other guy that sells me that phone.

    Now i think its rooted because i did de power button e down, and i got this:

    SAGA PVT ENG S-OFF
    HBOOT-0.98.2000 (PG8810000)
    RADIO-38.03.00.03_M
    eMMC-boot

    Ill give more information about my phone:
    software number 1.12.0.0

    Is that a way to unroot my phone? PLEASE :(((((

    EDIT: Sorry for my bad english. Im Portuguese.
  15. notebook

    notebook Well-Known Member

  16. FoX777

    FoX777 Well-Known Member

    As said above,

    since you have a eng hboot already just flash a RUU, simple as that.
  17. UnROOT

    UnROOT New Member

    But my hboot is 0.98.2000 :( i dont know what type of root was used, because i bought the phone to a person. :(

    i dont know nothing about root's, all i want is the official updates, and when i try, the phone says that im updated, but its not because i got 2.3.3 and sense 2.1 :(

    and another question, which RUU should i use? im from Portugal :(
  18. notebook

    notebook Well-Known Member

    Can you confirm the software information on your phone? Menu > Settings > About phone > Software information - Android, Sense and Software number versions. I've never seen a software version for the Desire S that begins 1.10*.

    If you have a branded phone with a branded ROM, then you have two choices a) to find a branded RUU of the same brand for your phone or b) make a Gold Card and flash a stock RUU.

    (The list of RUU's linked to in FoX777's guide is probably the most comprehensive list there is. Others may be on the net, but without more information regarding your phone (see above) you may find it hard to find anything.)
  19. UnROOT

    UnROOT New Member

    SAGA PVT ENG S-OFF
    HBOOT-0.98.2000 (PG8810000)
    RADIO-38.03.00.03_M
    eMMC-boot

    Android 2.3.3
    Sense 2.1

    Software Number:
    1.12.0.0

    Cidnum:
    11111111

    I dont know if its brand phone because i bought from 1 guy :/ i think its rooted because its s-off, but i dont got the app "super user" :S

    what can i do?
  20. notebook

    notebook Well-Known Member

    @UnROOT

    CIDnum: 11111111 - This indicates that you have 'Super CID' which means you can flash any ROM to your device, although I would recommend the latest stock ROM, which should flash over your current ROM, i.e RUU_Saga_S_HTC_Europe_2.10.401.8_Radio_20.4801.30.0822U_3822.10.08.04_M_release_225161_signed.exe from this list.

    Download the file to your PC > Ensure you have HTC Sync (or its drivers installed) > Connect the USB from your PC to your phone > Run the RUU See here for more details.

    Remember to back up any personal data before doing this.
  21. UnROOT

    UnROOT New Member

    Hehe, thanks, look at my thread in xda forums: there

    It's the same answer so i think both of you (amidabuddha and notebook) are right :)

    THANKS!!!!!!! :) :)
  22. DaveV

    DaveV Member

    I have a desire S - The only reason I tried to root it was to allow Tasker to become a system app and allow it to turn GPS on. Anyway I did not get far at the time only managing to get to
    --Revolutionary--
    SAGA PVT SHIP S-OFF RL
    HBOOT-6.98.1002
    RADIO-3805.06.02.03_M
    eMMC-Boot
    Mar 10 2011,14:58:38
    Gingerbreak and the other breakig methods woud not work.
    Now I would like to return to stock.
    After three hours on the forums.... Downloaded PG88IMG.zip and a RRU
    RUU_Saga_S_HTC_Europe_2.10.401.8_Radio_20.4801.30.0822U_3822.10.08.04_M_release_225161_signed.exe
    Loaded the ADB "Android 1.0" drivers.
    ==============================
    OK I am failing at Step 1 to back out the hboot.
    ==============================
    1) Just putting PG88IMG.zip in root and rebooting into fastboot I get "parsing file" and "update bypassed"
    ========================================================
    2) Down loaded "Android Flasher" connected USB while in Fastboot and ADB driver loads. Select desire s and point it at the .img from the zip file for boot image.Log as follows
    sending 'hboot' (1024 KB)...
    OKAY [ 0.203s]
    writing 'hboot'...
    (bootloader) image update is bypassed!
    OKAY [ 0.031s]
    finished. total time: 0.234s
    rebooting into bootloader...
    OKAY [ 0.203s]
    finished. total time: 0.203s
    rebooting...
    finished. total time: 0.156s
    =========
    3) ======================================================================
    DOS - Fastboot
    went to this link and followed the instructions
    How To: Install ADB and Fastboot on your Windows computer for use with your Android phone | Android Articles | dotTech
    Phone in fastboot again and connect to usb
    image in C:\android-tools
    opened CMD window
    "fastboot flash hboot hboot_0.98.0000_361a7ba6_0310.img "
    CMD log
    C:\Andrtool>fastboot flash hboot hboot_0.98.0000_361a7ba6_0310.img
    sending 'hboot' (1024 KB)... OKAY [ 0.219s]
    writing 'hboot'... INFOimage update is bypassed!
    OKAY [ 0.016s]
    finished. total time: 0.234s

    ================================================

    So why is the update being bypassed?????????

    Thanks Dave
  23. FoX777

    FoX777 Well-Known Member

    The only thing I can think of is that it won't allow the stock hboot to be flashed (however it should). Try flash ENG hboot (0.98.2000) then the RUU.

    Attached Files:

  24. DaveV

    DaveV Member

    Oh well done! - did not work with the zip in root but flashed the image
    engHBOOToverARX.img with android flasher

    sending 'hboot' (1024 KB)...
    OKAY [ 0.203s]
    writing 'hboot'...
    OKAY [ 0.359s]
    finished. total time: 0.563s
    rebooting into bootloader...
    OKAY [ 0.172s]
    finished. total time: 0.172s
    rebooting...
    finished. total time: 0.156s

    I then deleted the img file from boot and went back into fast boot to see whats happening .

    --revolutionary-- header has gone

    SAGA PVT SHIP S-OFF RL -> SAGA PVT SHIP S-OFF
    HBOOT-6.98.1002 -> HBOOT-6.98.2000 (PG8810000)
    RADIO-3805.06.02.03_M -> No change
    eMMC-Boot -> No change
    Mar 10 2011,14:58:38 -> Feb 24 2011,21:19:05

    So will now try loading the rom.
    RUU_Saga_S_HTC_Europe_2.10.401.8_Radio_20.4801.30. 0822U_3822.10.08.04_M_release_225161_signed.exe

    Will have to wait a while as I can't afford down time on the phone at the moment. I'll be back. Dave
  25. FoX777

    FoX777 Well-Known Member

    @DaveV

    If possible, before you run the RUU can you please post the command "fastboot getvar all" results, that way I can assure you that the RUU will install perfectly.

    And if at all possible (READ: do it) make a goldcard, just incase you have a odd cid.

    However you should not run into any problems.

Share This Page