I ran out of space ugh! SolutionTips


Last Updated:

  1. lordfly911

    lordfly911 Well-Known Member This Topic's Starter

    Joined:
    Jul 22, 2010
    Messages:
    84
    Likes Received:
    2
    I found my A200 running out of free space. I was baffled. I just recently rooted and went exploring using Disk Usage. I found the /data/GPS directory had 7 GB of data in it. It was full of gl*.txt files. It seems that every time an app uses the GPS it puts a file here. I did find a script that is suppose to do this, but I could not get it to work. I used ES file explorer in root mode, selected all of these files and deleted them. What a relief.

    So once every month this little procedure needs to be done. Now if someone could just find a way to keep this from happening or have an auto cleaner, that would be cool.

    Thoughts?
     

    Advertisement
    qazzy2004 likes this.
  2. Mrhelper

    Mrhelper Well-Known Member

    Joined:
    Apr 30, 2012
    Messages:
    168
    Likes Received:
    77
    You can leave the internal GPS receiver turned off as I do, because it is not very sensitive anyway, or you can try what a few others have and turn off the GPS logging that was apparently left on in the ICS ROM by mistake.

    (Caution: The following method alters data in the ROM image. A mistake here can result in severe system problems. Before trying anything like this, it is a good practice to have reliable system backups and adequate experience with flashing and recovery for your device.)


    As root:

    Mount /system as RW instead of RO.

    Edit /etc/GPS/gpsconfig.xml

    Change from cLogEnabled="true" to cLogEnabled="false"

    Boot the device.
     
    dbldipp and lordfly911 like this.
  3. lordfly911

    lordfly911 Well-Known Member This Topic's Starter

    Joined:
    Jul 22, 2010
    Messages:
    84
    Likes Received:
    2
    Actually I find the GPS is extremely accurate. Besides that, I will try the fix you suggested. This is the first time I have seen it suggested. Maybe I was not looking in the right place.
     
  4. lordfly911

    lordfly911 Well-Known Member This Topic's Starter

    Joined:
    Jul 22, 2010
    Messages:
    84
    Likes Received:
    2
    That worked. Thanks a lot.
     
  5. greeder

    greeder Member

    Joined:
    Aug 13, 2012
    Messages:
    13
    Likes Received:
    0
    Wow. Thank God, a solution. Mine has been having the same trouble.
     
  6. greeder

    greeder Member

    Joined:
    Aug 13, 2012
    Messages:
    13
    Likes Received:
    0
    OK. I went looking into my /data directory and it was empty. What am I doing wrong.
     
  7. Mrhelper

    Mrhelper Well-Known Member

    Joined:
    Apr 30, 2012
    Messages:
    168
    Likes Received:
    77
    If you have not rooted the device and then granted root access to the file manager, you do not have permission to see anything under /data, so it will appear to be empty.
     
  8. greeder

    greeder Member

    Joined:
    Aug 13, 2012
    Messages:
    13
    Likes Received:
    0
    OK, that's what I thought. But what is the best way to root the device or get root access? SimpleTool? From the instructions, it appears that I have to download and install three files. But the directions are not clear about which files go onto the PC and which go onto the tablet. I'm confused.
     
  9. Dr3amAth3m3

    Dr3amAth3m3 Active Member

    Joined:
    Feb 2, 2013
    Messages:
    36
    Likes Received:
    3
    I'm scared poopless about rooting my device. Not fair we don't get Jellybean.
     
  10. rockyptjoe

    rockyptjoe New Member

    Joined:
    Jan 3, 2012
    Messages:
    1
    Likes Received:
    0
    What does the logging do? Is it something that is necessary for the gps to run accurately, etc?
     

Share This Page

Loading...