I tried to root my Stratosphere...


Last Updated:

  1. jknowles8985

    jknowles8985 New Member

    Using Heimdall in Ubuntu 10.11 (or 11.10 I'm dyslexic sometimes whichever the newest is.)

    I wasn't able to get very far. I followed the steps exactly as in the thread.

    When I got to the code part of it, in the terminal, I got as far as this:



    Code (Text):
    1. heimdall detect
    2. Device detected
    3. the-master@Justins:~$ sudo heimdall flash --kernel root-zImage
    4. Heimdall v1.3.2, Copyright (c) 2010-2012, Benjamin Dobell, Glass Echidna
    5. http://www.glassechidna.com.au
    6.  
    7. This software is provided free of charge. Copying and redistribution is
    8. encouraged.
    9.  
    10. If you appreciate this software and you would like to support future
    11. development please consider donating:
    12. http://www.glassechidna.com.au/donate/
    13.  
    14. Initialising connection...
    15. Detecting device...
    16. Claiming interface...
    17. Setting up interface...
    18.  
    19. Checking if protocol is initialised...
    20. Protocol is not initialised.
    21. Initialising protocol...
    22. Handshaking with Loke...
    23. ERROR: Failed to receive response!

    I can't get any further and can no longer use my phone. Can someone please help?

    Update: I tried to do it using the heimdall front end GUI, but it gave me the error "Tar header contains invalid file size." I hope this clears it up a little.

    Another Update: I've managed to get my phone restarted. I did this by downloading the pit from the phone.

    Update: I now have the superuser.apk on my phone but it does not seem to be functioning properly. I do not know how to get it to work. Please help

    Issue Resolved: I was using the wrong version of Heimdall. I had accidentally downloaded the latest version of the program instead of 1.3.1. 1.3.2 is not fond of the kernels that needed to be flashed. Now I feel like an idiot, I've been working on this all day, and once I figured out what was wrong, it took me 10 minutes to do.

    Advertisement

Share This Page